Sign in with
Sign up | Sign in
Your question

Very large (HUGE) problem, A7A266

Last response: in Motherboards
Share
June 14, 2001 7:05:31 PM

I need _someone's_ help, because I've never had a problem on this large of a scale before =) This isn't your "my computer is detecting 255MB of ram instead of 256 on my a7a" problem, I can't even get into my system because of the new A7A board and windows 2000.

Here is the current dilema: I've had an emachines OEM box for awihle now, bought the new Asus A7A266 board and am putting all of my devices into the board from the emachines, leaving the board and its processor in the old box. Now, did all the installation, few hitches here and there, got past post into bios. Recognizes my hard drive, recognizes the master boot partition.

I currently have only 1 hard drive, 13GB, partitioned so that I have a windows 2000 NTFS partition, and linux. When i start up with the new motherboard, LILO comes up (the linux utility that lets you pick your operating system). I can pick windows 2000 or linux. Linux boots fine but doesn't recognize the keyboard for some reason, but I'm not worried about that. Windows 2000 starts booting, hits the colorful startup screen and fails.

The error is a STOP error, Inacessible_boot_device. I looked this up on many pages/forums, and its kind of a common error sometimes when you upgrade your hard drives or motherboards. I've tried the obvious suggestions like checking to make sure my hard drive is set to the correct master/slave jumper etc. The problem seems to be with the motherboard and the harddrive in windows 2000, so I'm not sure what to do. I want to try and upgrade the bios, and see if that fixes the compatibility problem. If anyone has had a similar error and fixed it, please post how.

Anyway, back to the situation at hand: I cannot flash the bios. Remember, I cannot boot into windows 2000. The windows2000 boot disk lets me go into a "command-console" mode, which isn't really a command prompt because you can only do a certain number of commands (cannot run exe's btw). In this command console I tried using the command "chkdsk", which is what the blue screen error told me to do. Of course the hard drive checked out fine. So, the command console didn't help because I cannot run the bios program I have which is on a floppy. I cannot do a windows 9x startup disk dealy, because my hard drive is NTFS and the 9x systems only recognize fat compatible drives.

So, the above choices are out. I cannot just take soomeone's windows 98 hard drive and let it load into windows 98 on my current setup (I think that would work, 98 would detect all of the hardware hopefully) I cannot do that because my master boot partition is modified to have linux lilo handle it, not windows 2k or any other operating system. Of course none of my friends have lilo installed or anything, and I'm not sure if that would work regardless. If I were to put in a 98 hard drive and then startup, I do believe the master boot partition would look for the lilo manager to execute, fail, and stall. Also, I cannot boot off of the windows 2000 CD rom for some reason (I have CD as my 2nd boot check, after the floppy, but even with the 2k CD in there it goes past it and to the hard drive to load windows 2000). Actually I'm not sure if the CD is even bootable, but it would be nice because the windows 2000 startup disks take like 15 minutes to load the necessary files (4 disks!) and it has limited options.

So, that's my position. I'm currently online becuase I reverted back to my other motherboard setup. I have friends who can look things up for me on the internet, but I'm not too concerned about that because the #1 most probable solution (updating the new mobo's bios) is impossible because I cannot get these files from this disk (also have them on CDrom) into memory to run them. I have the image and the dos-based flashing program as well as the windows one. I'm in windows but cannot flash because I'm on my original motherboard.

Any suggestions would be incredibly helpful, this problem is holding me up, I cannot sleep at night =) I'd like to gather all of the information I can because It's a perty painful process switching all components to the other motherboard considering I only have one case. I don't want to switch everything, find out it doesn't work, and come all the way back to this system to try some more solutions.
Right now my computer components w/ the new motherboard are in a box in a heap =) it works tho, nice looking computer.... just can't get into windows =(

Also I was thinking, I remember the 9x boot disk once letting me have a command prompt when my hard drive died, but I only had access to A: in the command prompt and couldn't really do anything. Does anyone remember if the windows boot disk will work if you're hard drive is not readable by dos (NTFS)? If that works, I could just do that because I only need access to the disk to flash the bios (or so the program says, methinks).
Help!
Thanks.

-Phil Crosby
http://www.philisoft.com
http://www.graphics-design.com
June 14, 2001 7:12:52 PM

Did you do a fresh install of Windows 2000 when you changed motherboards? If not, then I would definately start there. Just changing motherboards and keeping the same existing OS will most of the time kill your computer.

"In three words I can sum up everything I've learned in life: It goes on." -Robert Frost
June 14, 2001 7:20:19 PM

Thanks for the advice.
Many people say this motherboard has problems even when you do a fresh install. I could try that, but as I mentioned I only have one hard drive and was wondering if I could avoid trying to back everything up and then reinstalling it again. I do NOT want to lose the data, but I could always dump it to CD, its just time consuming.

Also, does anyone know if installing the drivers off the CD in windows 2000 on this motherboard and then rebooting with the other motherboard would fix any recognition problems?

Oh how I wish I hadn't chosen NTFS... I thought it was faster a year ago when I hit enter to "reformat and repartition" Doh! Didn't tell me that you can't access win98 on it... =P

-Phil Crosby
http://www.philisoft.com
http://www.graphics-design.com
Related resources
June 14, 2001 7:22:04 PM

yes very true, its happened to me every time I tried to do it. The other thing is that it might not recognize your hard drive controller. there is a SLIGHT chance if you plugged your hard drive into the CD rom drive controller you could get into windows and then install the driver for the hard drive controller. I know that windows 2000 is very picky on hard drive controllers.
June 14, 2001 7:37:29 PM

I had that problem before and I found that cooling the hard drive fixed it. When the HD got hot it just wouldn't boot.

a more likely situation though...Win2k probably detects that the southbridge (including the HD controller) on your board is different than the driver it has, and rather than try to boot an unstable system it just refuses to boot.

If you can install the correct mobo drivers than try that, but if nothing else works I'm pretty sure a fresh install of Win2k and then linux will take care of all your problems.
Anonymous
a b V Motherboard
June 16, 2001 3:17:29 PM

Do you have plug n play OS enabled in your BIOS? If it is BIOS 1.02 - turn it off NOW - then upgrade BIOS to 1.04.

Frankly - this switch is such a pain in the ass in the A7A266's BIOS I'd be inclined to disable it if you appear to be having any trouble.

Let us know how it goes...
!