Sign in with
Sign up | Sign in
Your question

Crysis 2 Freezing Completely

Last response: in Video Games
Share
July 10, 2011 3:55:33 AM

Hey all,

On my PC Crysis 2 freezes randomly (running on any setting), and when it does, it freezes my PC completely (the audio locks up as well) and the only way to get it running again is turning my PC off and then turning it on again. I've so far removed and reinstalled my graphics card drivers, I've ran it in compatibility mode and it hasn't really done anything to fix it! This is the only game on my computer to suffer this issue so far, GTA IV and Flight Sim X run fine, and I should mention the computer I'm trying to run it on is relatively new (3 weeks old!).

System Specs:
>Intel i5-2500 Processor
>Corsair 4GB DDR3 Ram
>Gigabyte GA-P67A-UD4-B3 Motherboard
>Gigabyte AMD Radeon HD 6950 1GB Graphics
>Seagate 1TB 7200RPM HDD
>TP-Link Wireless N PCI Adapter
>Cooler Master 700W PSU
>Windows 7 Home Premium SP1 64-Bit OS

I'll also say that being my first PC build, I'm relatively new this kind of 'help seeking', and any help would be greatly appreciated!
July 10, 2011 5:15:19 AM

Have you tried with the patches for the game ?
m
0
l
July 10, 2011 5:38:10 AM

Yes, I've tried the 1.9 patch/DX 11 support, still crashes randomly
m
0
l
Related resources
July 10, 2011 6:51:28 AM

so this happens only with crysis 2 ? have you defragmented your hard drive ? also use ccleaner and clean up your registry.
m
0
l
July 10, 2011 7:16:39 AM

Well, Crysis 2 is the only game that freezes my computer completely. The only other game issue I've had is with Portal 2, which randomly crashes to the desktop...
I've ran CCleaner a few times and defragged my HDD however it doesn't seem to fix it... but thanks for the advice so far!
m
0
l
July 10, 2011 8:09:44 AM

check your event logs and make sure its not something else causing the lockup. rather than the game.
the game may just be showing up a weakness in the system.
in bios make sure you run optomized defaults. and that hpet (high precision event timer) is enabled and matches your o.s.
m
0
l
July 10, 2011 8:24:48 AM

^that too.
m
0
l
July 10, 2011 8:59:50 AM

Okay, I can find the 'critical' events that show when I had to power off then on my computer again (because of the complete freezing), but I can't see what caused it... am I mean to be looking elsewhere?
m
0
l
July 10, 2011 12:29:03 PM

I've loaded optimized defaults, set H.P.E.T. to 64-Bit, and I've used GPU-Z to monitor GPU temps and it never (at any sensor) exceeds 70 degrees Celsius (even under load). It still freezes randomly and locks up everything else with it...
But again, thanks for the advice and suggestions!
m
0
l
July 10, 2011 3:58:52 PM

so the errors you saw were just from kernal event 41 unexpected power off...
so your machine is completely locking, meaning its crashing b4 it has time to write a log file. also its likely the hdd locked up 2...
lock ups of this kind are very rarely software related. as the o.s. will have a lot of error handling...
so i would be looking at your memory and its timings... the last time i had this issue it was my memory being at the wrong multiplier. go into bios and set the memory to 1 jdec speed setting lower. so if its 1600 your test setting is gonna be 1333. leave the volt's and cas latency on there default values.
hopefully this will stabilize your ram... i had a similar issue with my ram when i got my current rig.

m
0
l
July 10, 2011 4:06:45 PM

Does using 'WhoCrahsed' software help find out the culprit for this random freezes ?
Also this can be a problem of your hardware. My guess is your RAM. You should should see if it's got any sorts of dust in it. Use an eraser to clean the RAM.
m
0
l
July 10, 2011 5:50:19 PM

Quote:
I'll also say that being my first PC build, I'm relatively new this kind of 'help seeking', and any help would be greatly appreciated!


It helps us to help you when all the information is supplied.

Quote:
Corsair 4GB DDR3 Ram


Complete Specs would help, IE. Model#, Speed, Timings, Voltage as displayed on the modules themselves and exactly how you are running them, what timings are you using or have you left it all on Auto? (Leaving on Auto is a Bad Idea By The Way)

Quote:
Gigabyte AMD Radeon HD 6950 1GB Graphics


What Graphics drivers are you running, and have you tried re-installing them or using a different driver release?

Are you overclocking anything?

Quote:
I've loaded optimized defaults


Tends to point to no, regarding overclocking? Right?

The more information you supply the easier it is to pin down the possibilities of your problem, some BIOS settings really should be manually set whether you are overclocking or not, but how much experience do you have maneuvering and setting your BIOS?

HEXit is probably on the right track suspecting your memory so why don't you answer these questions to give us more of an understanding of your current situation.
m
0
l
July 11, 2011 12:57:21 AM

Alright, regarding the RAM, the complete specs are:
>Corsair DDR3 4GB PC-12800/1600 (2x XMS3 2GB) CMX4GX3M2A1600C9 Ram
>2x240-pin DIMMs
>Non ECC unbuffered
>9-9-9-24 Latency
>XMS heat spreader
>Voltage: 1.65V
>Suitable for i7/ i5 core processors

I have never worked with RAM settings, I rarely go into the BIOS, let alone modify it.
I'd assume the RAM is still in it's Auto settings...

I believe my Graphics Card (Model No. R695OC-1GD) is a factory overclocked card, from 800Mhz to 870Mhz. I have tried under-clocking it back to the stock clock of 800Mhz, but it didn't seem to have any effect. I have completely uninstalled, removed and reinstalled (the latest) my graphics cards drivers as well and that seems to have no effect either unfortunately...
m
0
l
July 20, 2011 6:01:05 PM

Try using MSI afterburner and changing the voltage a little higher. I tried this on my gtx 560 Ti, and it worked fine! Good luck (:

Btw my specs are:

some 700w psu (forgot brand)
i5 2500k
8gb ddr3 1333mhz
gtx 560 Ti
asus p8p67 LE (B3)
1 tb hdd (black scorpio or something i think) 7200 RPM, 64mb cache
m
0
l
!