Please help me. I can't play games smoothly anymore.STILL NOT RESOLVED

I've had my PC for maybe 2 weeks and everything was fine u til recently. What happens is, when playing a game, for example, Metro 2033, the screen twitches and jitters like crazy when when moving my mouse. It's like the frames freeze and then skip. Heres a short video of it happening 2 or 3 times.

http://www.youtube.com/watch?v=n9hVn08HrKw&feature=channel_video_title

This happens all the time now despite playing at consistently high FPS.

I have a GTX 560 TI and a Phenom 2 x4. I'm playing at max settings in 720p and don't go below 30 fps. I usually am around 50 to 70

I have just discovered that this only happens in DX10 and 11 but not DX9. What doesn't make sense is the fact that I played through 3/4 of the game max settings DX11 with ABSOLUTELY NO PROBLEM. I went through some of the most intense scenes with high frames. Why is it not working anymore?

Edit: I just discovered that the issue no longer exists when recording a clip with fraps. As soon as it stops recording the issue returns. What does this mean?
23 answers Last reply
More about please play games smoothly anymore still resolved
  1. Looks like you have a microstuttering issue, the framerate is dropping for a very short period of time, too short to register on the framerate counter. You can try running Metro's benchmark, it provides a framerate graph at the end, if you see a lot of extremely brief dips to something like 6 FPS on the graph that is a good indicator that you have this problem.

    Is this issue across all games, or restricted to just Metro 2033 in DX10 or 11 mode? Did you update your graphics drivers recently? If you have you can try rolling back to an older version or reinstalling the current version, most of the time microstuttering is due to driver problems. You can also force vsync in the nvidia control panel. Metro doesn't have a vsync option for some reason, but enabling it may help stabilize your framerate.
  2. Can you link the Metro benchmark. I don't really know what it is.

    And I can't find Vsync in my Nvidia Control Panel. The only categories are...

    3D settings
    Display
    Stereoscopic 3D
    Video
  3. Vsync should be under 3D settings.

    Look for the Metro 2033 Benchmark exe in the game's main directory.
  4. I did it maxed out in 720p and these were the average reults from 2 runs

    Average: 60
    Max :129.40
    Min :3.70

    Also did it in 1080p with 2 runs

    Average:30
    Max:54.77
    Min:2.75

    So now what?
  5. Have you tried running the benchmark with your network adapter disabled? I've seen rigs exhibit this kind of behaviour when they have picked up some nasty bit of malware or such like and if it was working OK before and has just started doing this out of the blue...
  6. I just did the benchmark again and am getting worse results now. WTF

    Do you think I might have a virus or something?
  7. Was this with the network adapter disabled?
  8. As Supernova asked, have you updated your graphics drivers ? Do you experience this problem with any other games apart from Metro 2033 ?
  9. Yeah the adapter was disabled.

    And my Drivers are all up to date. Gonna download the Civ5 demo and see how it works because Metro 2033 is the only DX11 game I have.
  10. DudE132 said:
    Yeah the adapter was disabled.

    And my Drivers are all up to date. Gonna download the Civ5 demo and see how it works because Metro 2033 is the only DX11 game I have.

    I would run the benchmark a few times with the adapter enabled and then the same amount of times with it disabled to see if a pattern emerged.
  11. It's averaging like 20 fps now in 720p. What the. This is too confusing
  12. Watch your language. :non:
  13. Ok

    I can't even start the Civ5 demo properly. The screen goes black and says"mode no supported". I then had to reboot

    What the fudge is going on
  14. Tried rolling back to your old drivers ?
  15. I don't know how. I believe the only drivers I have ever installed were the most recent ones.
  16. delete all drivers and do a sweep cleaning out all the old drivers and then install the latest drivers
  17. I just downloaded CCleaner and have no idea what to do.

    Ok never mind that isn't for drivers.
  18. Uninstalled the drivers and installed the new ones and it's still happening...

    Edit: Something interesting just happened. After trying to start up the Civ5 and having it one again lock up, I restarted the computer and tried to open a web page, and it said "Cache read error". I then refreshed and it was fine but does that mean anything?
  19. Could be a problem with your virtual memory. How much is your paging file set to ? Please mention each drive.
  20. Sorry but I have no idea what you just said lol. I'm new to all of this.
  21. Click on:
    >my computer
    >Properties
    >Advanced system settings
    >Under system properties click on advaned tab
    >In performace box click on settings
    >in performance options dialog box, click on advanced
    >In virtual memory, you'll find the paging size of the files.

    But I'm guessing its not the problem here. But still, do check
  22. It says

    Total paging file size for all drives: 4095

    I then clicked on "change to see if there was any thing else and it said

    Minimum allowed: 16MB
    Recommended: 6142
    Currently allocated: 4095
  23. I just noticed that the micro stuttering/twitching goes away when I record using fraps. As soon as it stops recording it starts happening.

    Can someone please help me out?
Ask a new question

Read More

PC gaming Games Video Games