Sign in with
Sign up | Sign in
Your question

Crysis 1&2 fps degradation

Last response: in Video Games
Share
July 13, 2011 8:22:19 PM

Now that I'm having the same issue with crysis 2, Im curious now if anyone else has experienced this.

Quick senario:
Install Crysis Warhead : game runs at a solid 40-50fps, all settings maxed out - msaa 8x vsync on, 1920x1200
Take a break for a bit form the game, several weeks or months or whatever, come back and game runs mid 20's fps

My system being well maintained, all drivers up to date, regular defrags, virus, spyware scans etc, and after reinstalling video drivers I end up rage reformatting.

This fixes the problem. Then the same thing happens all over again. Stop playing for awhile, come back to the game, back to mid 20's from the 40-50fps.

Again, ended up rage reformatting, that again fixing the problem bringing fps back to normal.

Crysis 2:
Game didnt run super great at first, was running 11.5's at the time when 11.6's were out, so I installed those.
Fyi I always use driver sweeper when reinstalling drivers.

Fps at this point were smooth. I dont have any numbers, because I didnt know how to see fps in game at the time and for some reason I couldnt get fraps to work, but fps was approx 45-60, sp and mp. Again, everything maxed, dx11, vsync on

It was only the next day I got in the game and my fps had dropped randomly in sp, to the mid 20's, and mp fps was 25- 60, fuckin all over the place.

Tried again to reinstall drivers, reinstalled the game, everything still the same. As b4 Im gettin ready to rage reformat again, hoping this will fix the problem as it did b4.


Crysis warhead system specs: AMD phenom II 955 black ed. | hdradeon 4890's crossfire | corsair 750w | 6gb ddr3 corsair dominator | MSI 790fx-gd70 |

Crysis 2: same specs except 2gb 5870's crossfire instead of 4890's

More about : crysis fps degradation

July 14, 2011 4:44:17 AM

Have you tried turning off Aero? I find that if I don't, Crysis 1 & 2 loose a fair bit of performance much of the time. Much like you've described.

If you wish to toggle it on and off, make a .bat program with the following script:
@echo off
sc interrogate uxsms | find "1062"
if %errorlevel%==0 goto :sc_start
sc stop uxsms
exit

:sc_start
sc start uxsms
exit
July 15, 2011 3:30:57 AM

bystander said:
Have you tried turning off Aero? I find that if I don't, Crysis 1 & 2 loose a fair bit of performance much of the time. Much like you've described.

If you wish to toggle it on and off, make a .bat program with the following script:
@echo off
sc interrogate uxsms | find "1062"
if %errorlevel%==0 goto :sc_start
sc stop uxsms
exit

:sc_start
sc start uxsms
exit

Yea I tried that didnt get any performance boost. Im pretty sure thats not the issue anyway beings I wasnt just having a standardd low fps issue, it was a degrading fps issue. My pc was entirely capable of running the games at maxed out settings, its just that somthing was gettin thrown off in my system at some point and I just cant seem to figure out what keeps happening.
!