Sign-in / Sign-up
Your question

Battlefield Bad Company 2 freezing

Tags:
  • PC gaming
  • Battlefield
  • Video Games
Last response: in PC Gaming
July 23, 2011 5:40:46 AM

Hello,
I've been having some issues with Bfbc2. Whenever I get into a server, about 5-30 minutes in I get an audio loop (sort of like the sound of a bluescreen, a kind of buzzing) and then I have to hard reboot. I have read multiple threads on multiple forums about this problem, but none of them appear to have occurred in 2011. Which makes me believe that it has been "fixed." Unfortunately, It still occurs for me. Many of the threads have stated that the problem was with the realtek sound drivers, but after removing the previous ones, trying the stock windows ones, and then the newest realtek ones I was unable to prevent the freeze. It's the only game in which I experience instabilities, and I'm baffled. Does anyone have a resolution for me?

More about : battlefield bad company freezing

July 23, 2011 6:15:06 AM

Do you use MSI Afterburner? MSI Afterburner, for whatever reason, has a conflict with Battlefield: Bad Company 2. Exit out of it, verifying that the task is gone on TASKMGR and then you can play. This happened to me too. Good luck! :) 
m
0
l
July 23, 2011 11:39:51 AM

you may also wanna try a usb headset or dedicated sound card that doesnt use the realtech hardware... then you can dissable it completley... you may also want to go into bios and turn of azalia support if available.
m
0
l
Related resources
July 29, 2011 3:35:39 AM

Take grizzlywan's advice. If you do use MSI Afterburner, I guarantee you that's the issue. I had the SAME EXACT issue you're having. I updated to their newest stable version 2.1, and that's when my issues started. I originally thought it was my power supply...because it only seemed to happen in BC2, because BC2 nearly maxes out my CPU and makes my GPU run at 60% (definite CPU bottleneck there :p ). So I tried running Prime95 and MSI Kombustor in X-Treme Burn-In Mode at the same time to make it pull max wattage to re-create the problem...and nothing happened.

I also tried uninstalling (and even disabling altogether) my onboard Realtek audio drivers (another known issue with BC2), and that still didn't work. Apparently Afterburner 2.1 has issues with BC2. I wanted 2.1 because they added voltage control for my card (Radeon 6870) in that build, and that wasn't available in 2.0. So I uninstalled 2.1 and put 2.0 back on, and I played for about 2 1/2 hours with no issues whatsoever. Definitely revert back to 2.0, and here's the link to do so:

http://msi-afterburner.en.softonic.com/
m
0
l
July 29, 2011 5:12:07 PM

Hey, It was afterburner, and I was able to delete a .cfg file that was causing the issue! thanks!
m
0
l