Sign in with
Sign up | Sign in
Your question

I cant play bioshock on my new laptop =/

Last response: in Video Games
Share
July 30, 2011 11:57:02 AM

I bought a laptop with these specs ASUS K52JT-XT1 Laptop Computer - Intel Core i7-740QM 1.73GHz, 4GB DDR3, 500GB HDD, DVDRW, 15.6" Display, ATI Radeon HD 6370, HDMI which i would think that could run bioshock, it starts with the beginning nvidia clips and it freezes at the starting logo where you have the menu options, you cant do anything at all in there. Im thinking maybe its because of the 1.73 ghz but it a quad processor so it overclocks by itself when needed. I been googling things up but not finding any answers, anybody have any ideas?

this is the laptops link in case anybody needs it =S http://www.tigerdirect.com/applications/searchtools/ite...

More about : play bioshock laptop

July 30, 2011 12:40:26 PM

maybe it is because of the windows 7.
maybe it is because of the 64-bit operating system.

did you run things in 'emulation' mode?
is there anything that can bring the emulation to 32 bit?


and finally..
did you apply all of the patches for the game?
m
0
l
July 30, 2011 2:38:41 PM

It's most likely the processor holding you back. Not much you can do about that though. Lower the resolution and graphics quality from outside of the game and then try it. Make sure all of your drivers are up to date on the video card.
m
0
l
Related resources
a b D Laptop
July 30, 2011 4:06:39 PM

theres no real reason why it wont work unless your gfx is letting you down. your cpu although a little slow is a quad and will match most midrange 775 quads in clock per clock performance.
update your drivers. make sure you run the dx updater that cam with the game and you should at least get to the options menu to change the rez and the likes.
m
0
l
July 30, 2011 4:53:35 PM

This is more likely a problem with the game. As Hexit said, make sure your GPU drivers are updated. Have you tried re-installing the game ? You're GPU is fairly a low end one, but it doesn't mean it won't run the game though.
m
0
l
July 30, 2011 6:03:23 PM

anwaypasible said:
maybe it is because of the windows 7.
maybe it is because of the 64-bit operating system.

did you run things in 'emulation' mode?
is there anything that can bring the emulation to 32 bit?


and finally..
did you apply all of the patches for the game?

Thank you for your answer, i am not quite sure i was looking into see if it was compatible with them, so far i got an asnwer for bioshock 2 but not one =/. also can you tell me something about emulation, i tried to find out more about it, but it seems you need a higher upgrade for windows for that is that correct?
m
0
l
July 30, 2011 6:04:52 PM

foshi13 said:
It's most likely the processor holding you back. Not much you can do about that though. Lower the resolution and graphics quality from outside of the game and then try it. Make sure all of your drivers are up to date on the video card.

Thank you for answer, i been trying to find the settings outside the game but with no luck =/, i did try to update all the drivers, although the processor is low, it can overclock itsest to run about 2.8 ghz =S...
m
0
l
July 30, 2011 6:05:32 PM

HEXiT said:
theres no real reason why it wont work unless your gfx is letting you down. your cpu although a little slow is a quad and will match most midrange 775 quads in clock per clock performance.
update your drivers. make sure you run the dx updater that cam with the game and you should at least get to the options menu to change the rez and the likes.

Thank you for answer, i have not tried updating dx i will try that =]
m
0
l
July 30, 2011 6:16:02 PM

i would think direct x needs to be up to date.
the soundcard drivers need to be stable.
and the graphics card drivers.. i wouldnt know if the ati drivers make any difference.
i know the nvidia drivers didnt really make much of a difference.

if your version of windows 7 isnt high enough for emulation mode.. i apologize.
i didnt know/remember all versions of windows 7 couldnt emulate windows xp or 32-bit.

maybe if you right-click on the shortcut you will find some options that could help the game run better.

but direct x up to date.
soundcard up to date
and the patches for the game
this should be enough to give it a go and change the settings.

i have bioshock 1 and 2 ... both of them are a cranky punk on windows xp.
seems like version 2 was worse than version 1 though.
once it gets going.. it is pretty smooth and solid.

so if the drivers and direct x are up to date.
then you would probably want to back-track bioshock errors.
but
i would look in the bios for anything helpful before blaming the game itself.
if you dont know your computer hardware is capable of revving up 100% .. then you shouldnt go blaming the video game.
m
0
l
a b D Laptop
July 30, 2011 11:41:00 PM

theres no need to emulate anything on win7. if the game is 32bit and you have 64bit o.s it will just install in the x86 folder and run from there...
you will need a premium version of win 7 to run the games in compatibility mode which i guess the other guy is on about... which is sort of emulating but not 32bit... it will run the compatability mode in what ever bit rate your o.s is.
so if you select xp (sp1) mode the game will run as if it was running on an xp o.s. regardless of the bitrate.
m
0
l
!