Joystick not Connecting

The short story: I have tried everything I can think of, and I still can't get my PC to recognize my joystick.

The long story:

Relevant portions of my system:
Epox 8KTA3 motherboard (VIA KT133A chipset)
AMD 1.2 GHz Athlon
640 MB PC133 DRAM
Diamond Monster Sound MX400
ATI Radeon LE 32MB DDR
Thrustmaster Attack Throttle w/ Top Gun joystick
CH Pedals (rudder pedals)
Windows 98

My overall system was working fine, but in the middle of playing "Crimson Skies," the game began to stutter (almost like I was out of memory) and then I lost my joystick. The game would respond to keyboard inputs, but not to the joystick.

I rebooted, thinking "Win98 bug," but now Win98 Control Panel/Game Controllers showed that my Attack Throttle was not connected.

I double-checked connections, rebooted, and still nothing. I rebooted into safe mode and removed any other game ports or sound card references in System Properties/Device Manager. No joy. I tried removing the Attack Throttle, then installing another joystick. No joy. I removed, then reinstalled, the MX400 drivers. No joy. I removed the MX400 completely and installed a Thrustmaster gameport card. No joy. I reinstalled Win98 -- no joy. I've tried doing everything that I could think of and that Microsoft recommended at their troubleshooting site for Win98. I've played around with my BIOS, but haven't really seen any improvement (I have disabled the onboard audio and gameport). I have even bought a Rockfire USB-Nest, which connects a joystick to a USB port -- I can get Windows to recognize the joystick this way, but in games, I can't use my keyboard or mouse.

There were two things that happened soon (but not immediately) before I lost the joystick: I installed VIA's new 4-in-1 drivers and the VIA.INF, and I was overclocking my Radeon LE using Powerstrip.

I have now since gone back to the default memory speed for the Radeon, but I'm not sure how to remove the 4-in-1 drivers (or if they're even the problem).

I am at my wit's end on this one -- I would greatly appreciate any help anyone can lend.

Thanks,


Gary Bond
St. Louis, MO
garygbond@aol.com

"Be patient in affliction..."
3 answers Last reply
More about joystick connecting
  1. Ok, so you tried a new joystick on the MX400 and then the thrustmaster on the game port card. Did you try the other joystick on the game port card. I think that would be the only thing you havent tried. If new joystick works on the game port card then its possible that the MX400 and Thrustmaster are shot. IF the game port on the MX400 shorted or if the joystick is powered then it could have shorted taking out both devices. Thats the only insite I have to this one. I think you have do everything else possible to try and fix this one.

    Screw overclocking my comps got <font color=red>NOS</font color=red>!!!!
  2. Yup, tried that combination (new joystick, new gameport). No joy.


    Gary

    "Be patient in affliction..."
  3. Then its got to be gremlins, j/k. Dont know what to tell ya man, you have already done everything I could thing of to do. Very last option I would take would be a low level of the drive. Install win98 using only the graphics card. Do a update of all the Via drivers. Install the game port card or the mx400 and try a joystick. That way the machine would be a fresh and stable as possible. You could also try differant PCI slots. If that doesnt work then you might aswell start hunting for those gremlins.

    Screw overclocking my comps got <font color=red>NOS</font color=red>!!!!
Ask a new question

Read More

Motherboards Joystick