Sign in with
Sign up | Sign in
Your question

Hitman Blood Money crash windows 7

Last response: in Video Games
Share
August 11, 2011 8:01:54 AM

Hi,
I am using windows 7 and have a problem in launching Hitman Blood Money . The red bar alone loads and then game crashes to desktop without notifying any error in the process. I have tried all possible solutions i knew- changing the DEP settings, running in compatibility mode, running it as admin, etc. Still no clue whats the reason. Can U Pls Help In this Issue??? :sweat: 

a b $ Windows 7
August 11, 2011 8:34:00 AM

i just installed this the other day and it works fine...
have you patched it?
have you checked the event logs. control panel/admin tools/events.
is your system up to spec?
m
0
l
a b $ Windows 7
August 12, 2011 3:53:39 PM

What are your PC specs ?
Have you tried re-installing ?
m
0
l
Related resources
August 19, 2011 3:42:25 AM

Guys i've reinstalled this game no. of times. And my system is upto the mark i believe. I've also patched it and tried that event thing too. :sweat: 
May be i need a website from which i can get download a fresh setup for the game. Pls Pls give me one that will be probably free of these bugs after installation. :heink: 
m
0
l
a b $ Windows 7
August 19, 2011 10:58:19 AM

Apart from buying from steam and downloading the game from there, there's nothing else you can do. You can buy it for a cheap price too. And, are you running the legit copy of the game ?

m
0
l
October 31, 2012 8:42:33 PM

qwert_123 said:
Hi,
I am using windows 7 and have a problem in launching Hitman Blood Money . The red bar alone loads and then game crashes to desktop without notifying any error in the process. I have tried all possible solutions i knew- changing the DEP settings, running in compatibility mode, running it as admin, etc. Still no clue whats the reason. Can U Pls Help In this Issue??? :sweat: 



I found a fix on my ACER Laptop with Intel Imbeded HD Graphics that has been working for 2 weeks now without problem.

Blood Money was having trouble starting up from Steam. It would hang and never enter the red bar load screen. I selected

Disable Desktop Composition.

find HitmanBloodMoney application
Right click to Properties
Click Tab Compatability
In Compatability only checkmark/select Disable Desktop Composition.

I did not need to select any other options such as run as Administrator or compatiable with XP etc. It works without issue now. Windows lets you know that it is entering a lower state of desktop color at launch from STEAM fyi.
m
0
l
!