Sign in with
Sign up | Sign in
Your question

Crysis 2 Freeze Screen help!

Last response: in Video Games
Share
August 18, 2011 9:39:20 PM

Hey !

i play crysis 2 on max settings with no lagg at all and it runs perfect, except that the game/screen freeze's when i have played a while! and then i have to press alt, ctrl, del to trun the game off..

any opinions what it can be?

i realy want to play this game but there is no fun when the game freeze and i have to start form last checkpoint everytime. plz help

* my OS is windows 7 64 bit

* 8 gb ram

* radeon hd 6870

* cpu: i7 socket 1366

edit: when i tired the game now it crash right after loading

More about : crysis freeze screen

August 20, 2011 12:06:06 PM

If you have done all that werner123 said and the GPU's temperature is OK and still get the problem try raising the GPU's core voltage a little.
Related resources
August 20, 2011 1:54:14 PM

try dropping the settings a little and see if that stops the crash..
August 22, 2011 6:42:18 AM

If it overheats I don't think the game would simply freeze up - the entire system will. You won't be able to <crtl><alt><del> to close the game, the system will be too slow. I'm willing to bet unstable graphics card or RAM due to either overclocking or faulty/old memory. It sounds a lot like a graphics card running out of memory. Try dropping the settings a little (as HEXiT mentioned), specially the anti-aliasing settings (it uses A LOT of VRAM), and see if that solves the issue.
August 22, 2011 4:25:37 PM

Toxxyc said:
If it overheats I don't think the game would simply freeze up - the entire system will. You won't be able to <crtl><alt><del> to close the game, the system will be too slow. I'm willing to bet unstable graphics card or RAM due to either overclocking or faulty/old memory. It sounds a lot like a graphics card running out of memory. Try dropping the settings a little (as HEXiT mentioned), specially the anti-aliasing settings (it uses A LOT of VRAM), and see if that solves the issue.



i fixed it :)  all i had to do was pathing it and it helped. ty for all answare's. for thoose who said turn down the video options that didnt help.

but now that all is fine i can start playing XD
!