Sign in with
Sign up | Sign in
Your question
Closed

Dead Island Frame rate Issues

Last response: in Video Games
Share
September 7, 2011 8:37:59 PM

Whatsup guys. I've just started playing Dead Island (cool game btw), but everytime I hit a zombie, my frame rate drops from 120 to about 50, even 40. Any1 know what the problem could be?

I'm running a Sapphire Radeon 5970, core i7 930 3ghz.

Any solutions/suggestions?
September 8, 2011 1:49:22 AM

I got a similar problem. (my system is worst so my FPS is only 40-50) so when ever a Zombie comes to hit me it drops to like 20 or lower (I Am recording though so that could be why) but Switching to "Single Player" Mode helped quite a bit

-Mithness
Score
0
September 8, 2011 10:11:38 AM

its a buggy game that is obviously not ready for release, like deus ex. everyone is having the same problem. wait for a patch or hotfix. It frustrates me that some companies can't release a finished game, it actually rarely happens.
Score
0
Related resources
September 8, 2011 2:58:52 PM

there are a few hotfixes out right now, but a serious patch will be hitting on friday. My issue was when i would force vsync it would lag like hell, but when i disable the game runs full blown @120-150fps and my gpu temp hits all time highs for me. At least its playable for me, because it is incredibly fun.
Score
0
September 11, 2011 11:25:16 AM

“We deeply regret that an incorrect version of Dead Island was inadvertently made available to players on Steam launch in North America,” Deep Silver spokesperson Aubrey Norris said.
Many people have had dodgy problem from the wrong version being released.
The only problems i've uncounted is frame rate dropping from 110 to 30-40 when recording with fraps, and a keyboard button enables a nocliping mode lol random.
Score
0
September 11, 2011 6:32:33 PM

deicidechaos said:
“We deeply regret that an incorrect version of Dead Island was inadvertently made available to players on Steam launch in North America,” Deep Silver spokesperson Aubrey Norris said.
Many people have had dodgy problem from the wrong version being released.
The only problems i've uncounted is frame rate dropping from 110 to 30-40 when recording with fraps, and a keyboard button enables a nocliping mode lol random.

That problem with the no clip mode and such was patched first day. The patches are all in to fix alot of issues but the game is still poorly ported. Vsync isn't even an option it has to be forced through the control panel, and the game gets choppy when doing so . Its totally playable in its current state now, but the high gpu and CPU temps still are an issue when vsync is disabled
Score
0
September 12, 2011 2:35:04 AM

wow, no clip mode lol, havn't heard that one since back in the doom days. was the cheat command "IDNOCLIP"?
It still baffles me how they can get away with releasing games that have obviously not been tested well, its like selling a BETA version.
Score
0
September 12, 2011 3:07:59 AM

iam2thecrowe said:
wow, no clip mode lol, havn't heard that one since back in the doom days. was the cheat command "IDNOCLIP"?
It still baffles me how they can get away with releasing games that have obviously not been tested well, its like selling a BETA version.

Yes, it was one of the biggest fails of this year. They have apologized and fixed the issues that made the game unplayable. I still would like a vsync option in game instead of getting hitchy performance by forcing it to run at lower temps.
Score
0
September 12, 2011 3:40:46 AM

iam2thecrowe said:
wow, no clip mode lol, havn't heard that one since back in the doom days. was the cheat command "IDNOCLIP"?
It still baffles me how they can get away with releasing games that have obviously not been tested well, its like selling a BETA version.



Well, at least you buy the game one time only, and then they fix whatever they can, and even apologize for it, but imagine a game like World of Warcraft where they test a patch before it is released for a few good weeks, and they still release it full of bugs... and you get to play a monthly subscription for that too...

Anyway, the game runs decently well on my system, with highest settings, but it's true I have vsync disabled since it puts a bit of a stress on my 5770; but I never got to check in-game temps for CPU and GPU, will take a look at that.
Score
0
September 12, 2011 4:14:46 AM

Eldd said:
Well, at least you buy the game one time only, and then they fix whatever they can, and even apologize for it, but imagine a game like World of Warcraft where they test a patch before it is released for a few good weeks, and they still release it full of bugs... and you get to play a monthly subscription for that too...

Anyway, the game runs decently well on my system, with highest settings, but it's true I have vsync disabled since it puts a bit of a stress on my 5770; but I never got to check in-game temps for CPU and GPU, will take a look at that.

Yeah without vsync the game runs smoothly but the issue I have with that is limiting my gpu. I run around 130-160 fps and my gpu runs high temps as a result. With vsync its a little choppy but it also locks at 60 fps and limits my gpu to 40-50% usage which keeps my temps down . Damn console ports killing my experience on hardware that's 8-10x more powerful
Score
0
September 12, 2011 7:15:32 PM

The game doesn't like Cross-Fire. If I do it my FPS maxes at 32. With only one 5870 I hit 120-130FPS with max details @ 1080p. I set vsync in the Video file, and it seems to work ok with the latest patch, some slight stutter every once in while. Now that it's patched, its actually pretty fun. I was hating it on day 2 because of the issues but it seems like they got it right.
Score
0
!