Sign in with
Sign up | Sign in
Your question
Closed

Witcher 2 feels like I'm playing underwater. Everything is slow

Last response: in Video Games
Share
September 12, 2011 12:56:55 AM

Hello,
I have a pavilion dv6 with 2nd generation Intel(R) Dual Core(TM) i7-2620M with 3.4 GHz Turbo Boosted + 16GB RAM +1GB Radeon(TM) HD 6490M Graphics Card + 1TB 5400RPM Hard Drive. I tried setting the graphics to the lowest possible and it still feels like gareld is running through water. I know I'm running on a craptop but does anyone have suggestions?
thanks

Best solution

September 12, 2011 2:14:39 AM

Try using a desktop? j/k =oP

The White Wolf deserves better...

What is the laptops native resolution, if it is 1080p you could try downsizing the resolution that you are using or send the Video to a monitor and do it that way.

Also update your graphics drivers and or patch the games.

Aside from that you are pretty limited on the options you have when it comes to fixed hardware.
Share
September 12, 2011 5:10:49 PM

the gpu is the shortfall here
Score
0
Related resources
September 13, 2011 3:26:50 AM

Indeed, the GPU is not the most capable when it comes to heavy lifting.
Score
0
September 13, 2011 6:14:52 AM

Apart from your CPU, RAM, HDD etc, the GPU is definitely your problem.
Try patching up the game. The latest is 1.35.
The game is very demanding. Try turning the resolution down as well instead of playing it at your native one. (i.e, if you are).
Still, if you aren't able to play the game well, play it on a desktop.

You can also play around with the texture size etc, in the User.ini file, for more FPS, but with worse eye candy.
Score
0
September 13, 2011 6:19:05 AM

800X600 might be ugly, but you should be able to play
Score
0
September 23, 2011 6:43:34 PM

Best answer selected by crazewarp.
Score
0
September 23, 2011 7:33:44 PM

This topic has been closed by Area51reopened
Score
0
!