S.T.A.L.K.E.R. Clear Sky graphics lag?

Hi, I have installed stalker cs on my new, fairly high end rig and I am experiencing varying performance, mostly poor. Initially, right after installing this game on my ssd boot drive and incorporating the latest patch (ver. 1.5.10), I put the game on max settings to try to conquer the graphics aspect of this game (having played this game before on my 4yr old rig, i had someday wished to exploit the potential of this games beauty). I started the game and it ran flawlessly and beautifully, with a damn smooth fps. It took effort not to drool. After playing for a bit, i chose to retire; closing the game and shutting down my system.

Next day, I decided to load it up again, however I had a drastically polar experience. The main menu interface was incredibly laggy, with my mouse jumping all over the place. I decided to bear with it and load my savegame, hoping that the game would snap out of it. No solution, I could hardly quit the game with all the lag. After quitting, I rebooted my system, and tried again. That time there was less lag, but it was still unplayable.

I had this same experience on my old rig. I know the first 2 stalker games are both graphically intensive and very inefficient. I just expected the problem to be resolved with more computing power. Plus I have a hard time understanding how a game can run near perfectly, then next day it performs like elephant excrement...

I have dedicated a significant amount of my available time searching for a solution, however all I managed to find were unclear answers or answers to scenarios that weren't quite the same as mine (situations implying that the game initially and consistently underperformed versus a gamble of good performance or bad on game startup). I did install the Clear Sky Complete mod/patch, hearing it would be a fix, but to no avail. Any help would be greatly appreciated!

System specs (not oc'd...yet):

i5 2500k @ 3.30GHz
p67a-gd80
Corsair Vengance 2x4GB DDR3 1600
MSI N560GTX-Ti Hawk
Corsair Force 3 ssd (boot drive)
Hitachi sata 3 1TB hdd
Reply to jsn81992
2 answers Last reply
More about clear graphics
  1. no solution, however i did notice this quirk lately.. if i start the game right after a fresh reboot, itl run smoothly. but, if i exit the game and relaunch it, the game will usually be choppy again...
    Reply to jsn81992
  2. There is a very good fix for this. People with Nvidia cards will be suffering a lot here. Here are the steps to improve FPS by about 80 FPS:
    1) Ensure that you have the newest GPU drivers. (Start>Search>"Nvidia">Geforce Experience>(In program)Second tab)
    2) Turn on administrator mode, Windows 7 compatibility mode and turn off fullscreen optimalization. (Right click your icon and go into properties. Then Compatibility, the third tab. Turn on Compatibility mode for Windows 7 and tick both of the options on the bottom.)
    3) Turn off DVR, game mode and game bar. (Start>Search>"Settings">Gaming. Then on all tabs turn everything off. You won't be needing DVR as you have Shadowplay, game mode doesn't help FPS (tends to do the opposite for most games). The game bar may be important to you if you use it, but turn it off for now. Later on if you fix the problem you can try to turn it back on.
    4) Set your GPU as the default PhysX processor. (Right click on your desktop, then click the Nvidia control panel. In 3D settings select "Configure Surround function, PhysX" and set the Processor to your graphics card. Don't forget to click "set/save" on the bottom right.) Leave this panel open.
    5) Set your Nvidia game options as specified by me. (In 3D settings select manage 3D settings. Then choose program options. You may have to run the game so that is shows in number 1.. Select one of the four stalker games. Set the following: Power managment mode - Prefer maximum. Tripple buggering - Off, Threaded optimization - On, Vertical VSync - Off.)
    6) You can now close that. Now set your power managment on your computer. (Start>Search>"Edit Power plan" or Start>Search>"Control Panel">Sound and Devices>Power options. In there set it to high performance.)
    7) Restart your PC. After try turning one of the games on, IF YOU GET NORMAL FPS, DO NOT DO THE FOLLOWING STEP. Otherwise if the problem continues turn on debugging mode for your GPU. (Right click on your desktop, then click the Nvivia control panel once again. Then Help>Debbuging mode (On) and Help>Allow (The one below that one)... (On).)
    8) Now once again run the game. If the issue still persists for you guys, just pm me with the following stuff:
    -system utility (Win+R>msinfo32 or Start>Search>"msconfig32". Then click File>Save As and send me it in a PM.)
    -Nvidia system info file. (Right click your desktop. Nvidia panel once again... (System info (bottom left corner) and then save that and also send it to me.)

    I will be making a tutorial on this for youtube soon. So if you do not understand this then wait for that.
    Reply to marcelbarlik
Ask a new question Answer

Read More

PC gaming Games Graphics Video Games