Sign-in / Sign-up
Your question

BC2 Crossfire Crash, help?

Tags:
  • PC gaming
  • Crossfire
  • Video Games
Last response: in PC Gaming
Anonymous
September 15, 2011 8:43:34 PM

I'm running HD6870s in Crossfire and whenever I go into BC2 and play for like 20-40 minutes my whole computer locks up and the only way to fix it is by pressing the reset button.

Specs,
Gigabyte GA-990FXA-UD5
Corsair 8GB (2x4096MB) CL9 1600Mhz VENGEANCE
XFX Radeon HD6870
HIS Radeon HD6870
AMD Phenom II X4 965 @3.4GHz
Corsair TX850w

I don't know exactly what the temps are but when I was running a single card the GPU was around 70-80C, CPU was about 40-56C and HDD around 30-40. But I have more fans now and stuff so it's actually cooler than before. It was working fine before I got all my new stuff so I was thinking maybe I installed the RAM wrong on the MB or that the game just doesn't like Crossfire.

I'm playing with MSI Afterburner and HWmonitor on, but they never caused a crash before. I've tried playing on lowest and highest in-game settings.
I might download Speedfan and log my temperature to see how hot it gets.

I'm also using the latest drivers. Have any of you guys experienced this? I'd love to get help as soon as possible since me and my clan plays BC2 competitively so these crashes are pretty bad :( 

More about : bc2 crossfire crash

Anonymous
September 15, 2011 9:48:22 PM

Just tried the game with Crossfire disabled in the CCC thing. Seems to have fixed it which is a shame :/ 

Not sure thought, I'll try full games tomorrow.
September 16, 2011 12:53:58 PM

You should check your temps.
Also, is the game fully patched and updated ?
Related resources
Anonymous
September 16, 2011 3:53:05 PM

My CPU is at 48C both HDDs at 33C, GPU1 is at 67C and GPU2 is at 78C.
Not even near a crash temp.

Nothing wrong with the cards, tried both individually today for about 3 hours each.

My bet, it's either the game or the drivers.
Anonymous
September 16, 2011 11:25:37 PM

New info guys,

The computer is still locking up even when I have crossfire disabled in "ATI Control Center" only way to get out is by doing a hard-reset.

More PC Info:
OS: Microsoft Windows 7 64bit
Processor: AMD Phenom II X4 @ 3.4GHz | 140w
Processor-cooler: Corsair H50
Motherboard: GIGABYTE GA-990FXA-UD5
RAM: 2x 4GB Corsair Vengeance 1600MHz CL9 1.5v
Graphic card: HIS Radeon HD6870 + XFX Radeon HD6870
Hard drive: Seagate 7200 250GB SATA + Extern Iomega 2TB
PSU: Corsair TX850w
Other Cooling: 5x120mm fan, one of them is an LED. 1x220mm LED fan
Temperatures: I logged an earlier crash today and the CPU was at 55C, GPU1 at 63C, GPU2 at 73C and HDD at 36C.

I had no crashes before I got my new motherboard, graphic card and RAM. I don't know if 850w is enough for this rig but that might be the problem?

I've also heard that Realtek can be a problem sometimes but I have a USB headset so it shouldn't really matter? I have not updated the BIOS or anything either.

I appreciate all answers, I'm starting to get a little desperate :( 
September 17, 2011 5:39:50 AM

Does the crashes happen only when gaming or even when sitting idle ?

Or does the crash happen with only one game ? (BFBC2) ?
Anonymous
September 17, 2011 11:08:14 AM

Only in BC2
September 17, 2011 12:45:59 PM

Is the game patched ? updated ?
Which version of CCC are you using right now ?
Anonymous
September 17, 2011 2:29:23 PM

The game is updated else I wouldn't be able to play at all. I'm using 11.8
September 18, 2011 4:46:16 AM

Roll back to your previous drivers, then.
Anonymous
September 18, 2011 1:43:02 PM

I've tried 10.04, 10.10, 11.6 and 11.8. None of them "work".