Sign in with
Sign up | Sign in
Your question

Games goes to blackscreen

Last response: in Video Games
Share
September 21, 2011 1:50:32 AM

I have been playing some games like Dead space 2 and Dead island. But every once in a while the game goes black and then normal again. It all started when I got my GTX 550 ti. What is the problem? Is there something wrong with the video card drivers?

More about : games blackscreen

a b U Graphics card
September 21, 2011 3:33:49 AM

what psu do you have?
m
0
l
September 21, 2011 7:54:50 PM

It's a corsair ultra x4 500W PSU.
m
0
l
Related resources
September 22, 2011 8:19:33 PM

OK! Never mind. The problem was fixed by using an DVI-D cable instead of a VGA cable to a DVI-D to VGA adapter. (-_-)
m
0
l
September 22, 2011 8:48:15 PM

Never mind again. Still black on Dead Island. Anyone have an idea?
m
0
l
a b U Graphics card
September 23, 2011 12:12:27 AM

force vsync on and see how that works for you; dead island had been known to overheat gpus. Is this the only game it does this on?
m
0
l
September 23, 2011 1:00:50 AM

FlintIronStagg said:
force vsync on and see how that works for you; dead island had been known to overheat gpus. Is this the only game it does this on?


Dead Rising 2, Dead Space 2, Fallout 3, and Deus Ex Human Revolution also has this problem but not as much as Dead Island. Also, how do you force vsync on?
m
0
l
a c 142 U Graphics card
September 23, 2011 2:14:44 AM

You can try forcing vsync in the nvidia control panel. If that doesn't work, you can donwload Rivatuner and use the D3DOverrider Tool to force vsync.
m
0
l
a b U Graphics card
September 23, 2011 6:04:55 AM

Supernova1138 said:
You can try forcing vsync in the nvidia control panel. If that doesn't work, you can donwload Rivatuner and use the D3DOverrider Tool to force vsync.

There you go, in the NVIDIA control panel you should find it
m
0
l
September 23, 2011 9:23:40 PM

OK ill try that.
m
0
l
September 24, 2011 5:40:14 PM

No it still goes to blackscreen on Dead Island. -_-
m
0
l
a b U Graphics card
September 24, 2011 7:37:26 PM

did you force it then make sure to click here it says " use the 3d advanced settings" in your nvidia control panel? if not, it wont force vsync.
m
0
l
September 24, 2011 9:13:39 PM

yes i did and i also used the d3doverrider but it still doesnt work.
m
0
l
!