Sign in with
Sign up | Sign in
Your question
Closed

Crysis 2: Your GTS 450 is unsupported...

Last response: in Video Games
Share
September 21, 2011 10:28:56 PM

...continuing might cause your game to crash

The game starts but i can only play untill the part where the aliens kill my freinds in the water, after destroying the submarine, and the guy in the nano suit scares them off
The game always crashes in the following loading screen

I got the error (your graphics card is unsupported) only once when i tried to run two instances of the game
tried rolling back drivers with no luck

here's my specs

i5 760 @ 2.8GHz
ga p55a ud3
4GB kingston RAM @ 1333MHz
EVGA gts 450 @stock clocks (the one that first came out -no fpb) + 8400gs for physX (don't ask)
Windows 7 Ultimate 64-bit

nvidia drivers:
formerly: 285.26
now: 270.61

oh and the game is updated to 1.9 and i have both the DX11 update and the highres texture pack
September 21, 2011 10:42:06 PM

okka01 said:
...continuing might cause your game to crash

The game starts but i can only play untill the part where the aliens kill my freinds in the water, after destroying the submarine, and the guy in the nano suit scares them off
The game always crashes in the following loading screen

I got the error (your graphics card is unsupported) only once when i tried to run two instances of the game
tried rolling back drivers with no luck

here's my specs

i5 760 @ 2.8GHz
ga p55a ud3
4GB kingston RAM @ 1333MHz
EVGA gts 450 @stock clocks (the one that first came out -no fpb) + 8400gs for physX (don't ask)
Windows 7 Ultimate 64-bit

nvidia drivers:
formerly: 285.26
now: 270.61

oh and the game is updated to 1.9 and i have both the DX11 update and the highres texture pack



The 8400gs would be the problem, take that out I mean do you really need physx and i'm pretty sure a 450gts has pyhsx
September 21, 2011 10:45:34 PM

Have you tried it without the physx card?
Related resources
September 21, 2011 11:11:26 PM

disabled it via device manager -no difference
also tried with texture pack disabled
September 21, 2011 11:12:38 PM

You could get a ati 5770 best budget card with damn good performance.
September 21, 2011 11:22:59 PM

:non:  im not looking for a new card :non: 

Best solution

September 21, 2011 11:27:28 PM
Share

Any issues with other games? If not uninstall and reinstall.
September 22, 2011 7:13:31 AM

no issues with other games except older ones (bioshock, battlefront... but these weren't meant for win 7, right?)
September 22, 2011 7:50:38 AM

it was the 1.9 patch
downgrading to 1.0 solved the problem
September 22, 2011 7:53:41 AM

Bioshock should work on Windows 7 just fine, it certainly does for me anyway. Any game that was designed to run on Windows Vista should be able to run on Windows 7 without much trouble, the two operating systems are very similar. Bioshock is recent enough to support Vista. The Star Wars Battlefront might have issues, being a game from 2004, I can only suggest running XP compatibility mode for that game.
September 22, 2011 8:14:47 AM

Indeed, Bioshock 1 and 2 working fine on Win 7 64bit.
September 22, 2011 2:53:46 PM

from another post, SW Battlefront needs to be run in compatibly mode for it to work.
Bioshock 1 & 2 should work fine in win7
Thanks for the post and solution...I have the same video card, but I am not playing Crysis 2 just yet.
September 22, 2011 7:22:52 PM

Bioshock runs fine on my other win7 x64 computer
but battlefront 2 wouldn't run on any win 7 computer (tried it on some of my friends' computers) not in compatability mode and not without it
September 22, 2011 8:05:02 PM

I've played Crysis 2 on a GTS 450 with no problems
September 23, 2011 12:33:21 PM

crysis 2 just gave me the same error on my other computer with a gt220
September 23, 2011 1:39:40 PM

Minimum requirement for the game is a 8800GT which is alot faster than a GT220.
September 23, 2011 10:57:16 PM

benski said:
Minimum requirement for the game is a 8800GT which is alot faster than a GT220.

yes, but i still got the game to run on the card on "Advanced" (medium) graphic settings
September 23, 2011 11:07:04 PM

...on 1280x1024 i might add
sorry i checked and it's 1024x768
October 2, 2011 1:56:01 PM

Best answer selected by okka01.
October 2, 2011 3:34:21 PM

This topic has been closed by Area51reopened
!