Sign in with
Sign up | Sign in
Your question

Flickering Games in Fullscreen

Last response: in Video Games
Share
October 5, 2011 8:11:33 PM

While attempting to play games like Osmos and Crayon Physics Deluxe, my computer screen constantly flickers when the games are in fullscreen, my taskbar flickering over the game display at the bottom of the screen. If I attempt to play Heroes of Newerth in full screen, the screen does not flicker, but I am unable to see the cursor but still able to navigate the menus by following the buttons which highlight as I run my invisible cursor over them. If I put any of these games out of full screen mode, they work completely fine (no flickering, I can see the cursor).

What could possibly be the problem? It seems like my system is unable to recognize when it needs to go into fullscreen, as when I attempt to watch Youtube videos fullscreen the taskbar is on top of the Youtube control bar (making it impossible to pause, configure volume, or jump to a specific part of the video via the Youtube control bar). Any ideas on what could be causing this and how to fix it?

Here's my specs:

Windows 7 64bit
Model: HPE-550y
AMD Phenom II X6 1045T Processor 2.70 GHz
8 GB RAM
Radeon HD 6850 graphics card

EDIT: And I guess it might be to helpful to know that while I do have issues with these games, games like League of Legends and Deus Ex: Human Revolution work perfectly fine in full screen.
October 6, 2011 3:13:11 AM

If no one can help me out here, could you possibly point me in a direction where I might be able to find an answer?
m
0
l
October 6, 2011 6:05:22 AM

install the 11.8 or 11.9 hd gfx drivers... open your ccc panel and go to the bottom of the list of drop downs you should see an update button. just press it... or go directly to the ati/amd site
it sounds like your display driver has become corrupted. or you have the screen set to the wrong size
m
0
l
Related resources
October 6, 2011 6:45:28 AM

HEXiT said:
install the 11.8 or 11.9 hd gfx drivers... open your ccc panel and go to the bottom of the list of drop downs you should see an update button. just press it... or go directly to the ati/amd site
it sounds like your display driver has become corrupted. or you have the screen set to the wrong size


Well I updated my driver (it did have to be updated) and it didn't have any effect. I've actually used multiple graphics cards with this system, it used to have an AMD Radeon HD 6450 and it was doing the same thing. So when I installed my 6850, I also reinstalled the drivers but it didn't change anything.

I have my screen resolution set to 1920x1080, which is the recommended resolution. I've tried changing it and also adjusting the resolution of the actual games to no avail. Is there something specific I should change it to?
m
0
l
October 6, 2011 11:46:15 AM

if your at native rez and the correct frequency native to the monitor...
the games you dont have trouble with are mass appeal games?
1 thing they all have in common is direct x installs and updates with the games...
your not so large user base titles may not... you may just get the core files or you may have to update direct x manualy from the games install folder...
other than that all i can think of is a possible conflict with amd overdrive... try turning that off and on to see if theres a difference...
i know for sure on some 2 screen setups it can cause corruption on 1 or both screens if you say, have a browser open the same time as you have an avi running.

make sure gpu scaling is off in your ccc panel. sometimes games dont like it on.
make sure the rest of the gaming settings are at default... again some of the more exotic settings like morphological filtering can cause issues.
m
0
l
October 7, 2011 12:35:18 AM

When I turned on LCD overdrive, the flickering in my games stopped! (Although I still wasn't able to get Heroes of Newerth to get working again...) So what does this mean? Because I can't keep LCD overdrive always on, can I? When ever I close my ccc it turns off even though I click the apply button.
m
0
l
October 7, 2011 5:56:41 AM

make sure your ccc panel is running as administrator... this should enable it to update the config. also you can try making it a preset... you turn it on and apply it then go the the dropdown preset and click add and bind a key to it. click ok
now turn it off and apply and go back to preset to create another preset and keybindong...

now stat your game and try turning it off and on...
you can do this with a lot of the functions if you like it.
m
0
l
October 7, 2011 6:01:42 AM

as for the cursor problem you could try changing to aero off... go to the games icon and get the properties up... select compatibility and check turn visual fields off.
then dissable dpi scaling... and try your game. maybe set compatability mode to xp if you need to.
m
0
l
October 9, 2011 7:11:40 PM

I was unable to set Overdrive as a preset and figured out that it was apparently incompatible with Aero, so I just changed my theme to basic and then when I started up a game, it wasn't flickering without overdrive enabled. So I guess those games were just incompatible with Aero, too?

I tried everything you recommended for the cursor problem but it didn't change anything. Any other possible solutions?

Thanks so much for your help already, btw.
m
0
l
December 26, 2012 3:07:44 PM

Can you all please speak with proper English words when helping people?! Give complete directions on how to do things in a computer. For instance, Badjoke made a reference to a "amd overdrive" but who the hell other than a IT person would know what the hell that is!! Explain in step-by-step instructions where to find this godforsaken item in a computer! What I am asking for should have been common-sense to anyone! "Gee, Not everyone reading my response will have a computer degree, so I should be more intelligent and explain where to find this computer item in a standard computer."

If you cannot use common-sense when responding to someone asking for help, then please realize that you are useless to the average person seeking help! There is nothing more annoying than looking for help and getting a moron to claim he can help you!
m
0
l
!