Sign in with
Sign up | Sign in
Your question

Can my PC run RAGE

Last response: in Video Games
Share
October 7, 2011 9:53:07 AM

CPU: AMD Athlon II X4 630 (2,8 GHz)
RAM: 4 GB DDR2
GPU: ATI Radeon 4850 PowerColor 1 GB , 256 bit.

I play on 1280x1024 resolution...Can I Max out Rage???

This is a PC requirements for Rage:

Minimum:

OS: Win XP SP3, Vista, Win 7
Processor: Intel Core 2 Duo or Equivalent AMD
Memory: 2GB
Hard Disk Space: 25GB
Video Card: GeForce 8800, Radeon HD 4200

Recommended:

OS: Win XP SP3, Vista, Win 7
Processor: Intel Core 2 Quad or Equivalent AMD
Memory: 4GB
Hard Disk Space: 25GB
Video Card: GeForce 9800 GTX, ATI Radeon HD 5550

My graphic card is better than ATI Radeon HD 5550. So, what you have to say? :) 

More about : run rage

October 7, 2011 10:03:03 AM

Try it and find out.
October 7, 2011 10:04:41 AM

Hi, With all the problems with Rage, I would say no your Rig will not perform and you might have graphic problems.
I would wait until they patch the game, I dont think its worth $60, not for 10 hours of play time, low Rez graphics.
I even see some glitches on my Rig, where as all other games I can run with no problems.

My Rig:
-EVGA GeForce GTX 590 Classified Hydro Copper-H2O cooled.
-Intel Core i7-2600K @ 4.8Ghz-H2O cooled
-GIGABYTE GA-Z68X-UD7-B3
-2X WD VelociRaptor 300GB 10000RPM in RAID-0.
-Mushkin Enhanced Redline 12GB DDR3
-Asus VG236H 120Hz LCD monitor with Nvidia 3D Vision Kit.
-Auzentech X-Fi Prelude 7.1 PCI sound card.
-1000Watt Logitech Z-5500 Digital THX Certified 5.1 Speakers.
-THERMALTAKE Toughpower 1200W
-THERMALTAKE Aluminum Armor LCS Super Tower, Liquid Cooling System
-Windows 7 64bit



Related resources
October 7, 2011 2:46:05 PM

Stay away from Rage; poor performance, short gameplay, dated graphics, no sense of exploring the world. I recommend you read Bethesda forums about Rage, and see how most of the people that bought Rage are having serious and extensive problems with this game.

So if I were you, I'd pass.
October 7, 2011 2:47:42 PM

i dont think anyone can play rage on pc until a patch
October 7, 2011 2:51:56 PM

This game sounds even more retarded than GTA IV. I didn't think there would be a game that could surpass that. Go id Software, go!
October 7, 2011 2:53:55 PM

try dead island for the first week it was out; unplayable. they patched it and made it right though
October 7, 2011 3:32:12 PM

Ive been playing Rage on my PC for the last 4 hours without issue.
October 7, 2011 3:35:33 PM

Uther39 said:
Ive been playing Rage on my PC for the last 4 hours without issue.

did they issue a hotfix or something? i heard horror stories. no vsync and awful tearing but when you force it, the game crashes. lots of LOD issues with terrible pop-in and textures that wont load
October 7, 2011 3:47:22 PM

FlintIronStagg said:
did they issue a hotfix or something? i heard horror stories. no vsync and awful tearing but when you force it, the game crashes. lots of LOD issues with terrible pop-in and textures that wont load


Works fine for me too, I had to force vsync but I don't get the texture loading problems other people experience..... not sure why!
October 7, 2011 3:57:38 PM

The only issue ive had with the game, is a load of mutants trying to eat me, and blokes with stereo typical British accents trying to shoot me.
October 7, 2011 4:08:28 PM

Uther39 said:
Ive been playing Rage on my PC for the last 4 hours without issue.


You're one of the few happy ones that can play the game without delayed loading textures, slipping, glitches, visual artifacts and so on. Congratulations :) 

Look at this for instance, this is what one should do in order for the game to run at acceptable frame rates, and without the pop-in textures:

1.Create a Rage shortcut with the following launch parameters:
+cvaradd g_fov 12 +com_allowconsole 1 +com_skipIntroVideo 1 +image_anisotropy 16 +image_usecompression 0 +g_showplayershadow 1 +m_smooth 0

2.Create a file called rageconfig.cfg in Rage/base/ and put the following commands in there:
seta image_usecompression "0"
seta image_anisotropy "16"
seta vt_pageimagesizeuniquediffuseonly2 "8192"
seta vt_pageimagesizeuniquediffuseonly "8192"
seta vt_pageimagesizeunique "8192"
seta vt_pageimagesizevmtr "8192"
seta vt_maxppf "24"
seta vt_maxlockedpages "256"
seta vt_minlod "-2"
seta vt_lodBias "-2"
seta vt_maxaniso "2"
seta vt_qualityhdplossless "1"
seta vt_qualityhdppower "0"
seta vt_qualityhdpspecular "0"
seta vt_qualityhdpnormal "0"
seta vt_qualityhdpdiffuse "0"
seta vt_qualitydctpower "100"
seta vt_qualitydctspecular "100"
seta vt_qualitydctnormal "100"
seta vt_qualitydctchroma "100"
seta vt_qualitydctluma "100"
seta vt_restart

3. Go to C:\Users\UserName\AppData\Local\ and create a folder called "id software" (Then create a folder called "rage" inside that folder.

This is a fix that actually works, sort of, better than the original release of the game, anyways. When one person, who paid for a piece of software, they'd expect it not to have to go through all the hassle to alter the game up to this point, especially when one's not a very PC-savvy person. If it'd happen to me, I'd get my money back and boycott future releases from such a game developer. It's unacceptable.
October 7, 2011 5:22:27 PM

been trying a load of different commands in the config file with little or no improvement...
1 minute the screen is rock solid 2-3 later its full of artifacts... i think some of the above works on ati cards but not all.
October 7, 2011 5:29:25 PM

HEXiT said:
been trying a load of different commands in the config file with little or no improvement...
1 minute the screen is rock solid 2-3 later its full of artifacts... i think some of the above works on ati cards but not all.


This fix has been tried (and found working) on the 11.6 ATI drivers, but not on the "fixed-for-Rage" drivers ATI released. As a matter of fact, it's loading the textures with little pop-in, but once they've been taken into the field of view, next time they are viewed, they show no more pop-ins. Fix should work for 5000 and 6000 series.

For most people, it's an improvement, but there might be cases where it does not apply though.
October 7, 2011 5:47:49 PM

bumnut53 said:
Works fine for me too, I had to force vsync but I don't get the texture loading problems other people experience..... not sure why!

Do you have NVIDIA? I heard the worst of problems were on ATI cards
October 7, 2011 5:54:13 PM

I have nvidia, Asus Direct CUII GTX580, it runs the game at max AA and settings at resolution 2560x1440, and it looks lovely, only thing im mifed about is that you can not play the campaign in co-op mode :(  ...........
October 7, 2011 6:20:32 PM

Uther39 said:
I have nvidia, Asus Direct CUII GTX580, it runs the game at max AA and settings at resolution 2560x1440, and it looks lovely, only thing im mifed about is that you can not play the campaign in co-op mode :(  ...........

I guess I shouldn't have any issues running it on my machine then
!