Right click with delayed results

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Does anyone have the problem I have of right clicking
on a file on the desktop only to have the working in
the background hour glass show up for about eight
seconds before the menu comes to life? This doesn't
happen when I right click on a folder.

I have WinXP Home SP2. Had the same problem
before the SP2 update.
5 answers Last reply
More about right click delayed results
  1. Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

    Same here. I did some research and it appears that it has something to do
    with third-party shell extension incompatibilities or conflicts with sp2.
    I've tried disabling some programs and uninstalling and it only helps with
    some file types. Hope there is an easy solution someone knows about!

    Al

    "Kevin" wrote:

    > Does anyone have the problem I have of right clicking
    > on a file on the desktop only to have the working in
    > the background hour glass show up for about eight
    > seconds before the menu comes to life? This doesn't
    > happen when I right click on a folder.
    >
    > I have WinXP Home SP2. Had the same problem
    > before the SP2 update.
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

    Kevin wrote:
    > Does anyone have the problem I have of right clicking
    > on a file on the desktop only to have the working in
    > the background hour glass show up for about eight
    > seconds before the menu comes to life? This doesn't
    > happen when I right click on a folder.
    >
    > I have WinXP Home SP2. Had the same problem
    > before the SP2 update.
    >
    >
    Similar problem with me. After SP2 cannot get to the
    properties of any drive device, so I can't add folders,
    share drives, name drives, etc. Right click + properties
    creates a perpetual hourglass. Microsoft SP2 support is
    baffled (and does not indicate they have even heard of this
    problem).
    MS did make two suggestions, neither of which worked for me:
    1) create a new user account just in case the old user
    account is corrupt;
    2) get into MY Computer Properties Advance Performance
    Settings on Data Execution Prevention tab select "turn on
    DEP...EXCEPT THOSE I SELECT Add Browse and choose and add
    C:\windows\explorer.exe.
    I am in the process of add/remove removing SP2 and then
    reinstalling in safe mode (suggestion from this NG). I do
    not believe that a remove of SP2, for me, changes all the
    registry entries back, so I fear I will be stuck with this
    until I reconfigure (reload XP fresh). It is a pity that the
    paranoia and put-out-the fire mentality of MS does not allow
    MS to thoughtfully create a safe solution for attacks while
    preserving the integrity of (previously) stable computer
    systems.
  3. Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

    User Friendly wrote:
    > Kevin wrote:
    >
    >> Does anyone have the problem I have of right clicking
    >> on a file on the desktop only to have the working in
    >> the background hour glass show up for about eight
    >> seconds before the menu comes to life? This doesn't
    >> happen when I right click on a folder.
    >>
    >> I have WinXP Home SP2. Had the same problem
    >> before the SP2 update.
    >>
    > Similar problem with me. After SP2 cannot get to the properties of any
    > drive device, so I can't add folders, share drives, name drives, etc.
    > Right click + properties creates a perpetual hourglass. Microsoft SP2
    > support is baffled (and does not indicate they have even heard of this
    > problem).
    > MS did make two suggestions, neither of which worked for me: 1) create a
    > new user account just in case the old user account is corrupt;
    > 2) get into MY Computer Properties Advance Performance Settings on Data
    > Execution Prevention tab select "turn on DEP...EXCEPT THOSE I SELECT Add
    > Browse and choose and add C:\windows\explorer.exe.
    > I am in the process of add/remove removing SP2 and then reinstalling in
    > safe mode (suggestion from this NG). I do not believe that a remove of
    > SP2, for me, changes all the registry entries back, so I fear I will be
    > stuck with this until I reconfigure (reload XP fresh). It is a pity that
    > the paranoia and put-out-the fire mentality of MS does not allow MS to
    > thoughtfully create a safe solution for attacks while preserving the
    > integrity of (previously) stable computer systems.

    No. Uninstalling SP2 and reinstalling it in safe mode was
    not a cure. In testing, I was able to get XP to generate an
    error report which I have sent off to the MS tech working
    with me off the XPSP2 help site (e-mail request for help).
    Maybe the zillion lines of that report will be helpful.
    Basically, the error found something awry in Windows
    Explorer (what a surprise!).
  4. Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

    User Friendly wrote:

    > User Friendly wrote:
    >
    >> Kevin wrote:
    >>
    >>> Does anyone have the problem I have of right clicking
    >>> on a file on the desktop only to have the working in
    >>> the background hour glass show up for about eight
    >>> seconds before the menu comes to life? This doesn't
    >>> happen when I right click on a folder.
    >>>
    >>> I have WinXP Home SP2. Had the same problem
    >>> before the SP2 update.
    >>>
    >> Similar problem with me. After SP2 cannot get to the properties of any
    >> drive device, so I can't add folders, share drives, name drives, etc.
    >> Right click + properties creates a perpetual hourglass. Microsoft SP2
    >> support is baffled (and does not indicate they have even heard of this
    >> problem).
    >> MS did make two suggestions, neither of which worked for me: 1) create
    >> a new user account just in case the old user account is corrupt;
    >> 2) get into MY Computer Properties Advance Performance Settings on
    >> Data Execution Prevention tab select "turn on DEP...EXCEPT THOSE I
    >> SELECT Add Browse and choose and add C:\windows\explorer.exe.
    >> I am in the process of add/remove removing SP2 and then reinstalling
    >> in safe mode (suggestion from this NG). I do not believe that a remove
    >> of SP2, for me, changes all the registry entries back, so I fear I
    >> will be stuck with this until I reconfigure (reload XP fresh). It is a
    >> pity that the paranoia and put-out-the fire mentality of MS does not
    >> allow MS to thoughtfully create a safe solution for attacks while
    >> preserving the integrity of (previously) stable computer systems.
    >
    >
    > No. Uninstalling SP2 and reinstalling it in safe mode was not a cure. In
    > testing, I was able to get XP to generate an error report which I have
    > sent off to the MS tech working with me off the XPSP2 help site (e-mail
    > request for help). Maybe the zillion lines of that report will be
    > helpful. Basically, the error found something awry in Windows Explorer
    > (what a surprise!).

    You are dealing with a KNOWN PROBLEM that MS acknowledges
    but apparently cannot fix. This condition, and variants have
    been around for several years.
    In addition to the suggests listed here, some people think
    that certain applications also are responsible. Check with
    each of your application publishers or search the internet
    for the “right-click” problem and your application. Other
    suggestions relate to updating drivers.

    My experience is that even a vanilla fresh install from
    scratch of XP (SP1 on the install disks) from the install
    disks carries this problem with it. I’ve restored vanilla
    four times and this condition is present. Upgrading to SP2
    does not improve the situation. For me the condition appears
    randomly: sometimes it just hangs with an hourglass,
    sometimes it allows me to use properties and make changes
    immediately, sometimes it takes ten seconds, sometimes, 30
    seconds. These are my tests with only the OS installed
    (absolute minimum default reconfiguration, wipe the disk and
    start all over install) (and with the rest of the junk
    thrown in by the manufacturer or MS as part of the default
    minimum install).

    HERE ARE SOME OF THE SUGGESTIONS I HAVE GATHERED FROM THE NET.
    *
    http://support.microsoft.com/default.aspx?scid=kb;en-us;819946

    Visual Effects
    clear fade slide menus into view (I disabled all of the
    choices as an alternative – i.e. Adjust for Best
    Performance) (This will change the lock of the desktop and
    task bar.)
    OK

    and also
    Control Panel
    Folder Options
    General
    “Use Windows classic folders.”
    OK

    and also
    Control Panel
    Folder Options
    View
    clear “Automatically search for network folders and printers.”
    OK

    * http://support.microsoft.com/default.aspx?scid=kb;en-us;819101
    Control Panel
    Display
    Appearance
    Effects
    “Clear the Use the following transition effect for menus.”
    OK

    * Disable: Data Execution Prevention
    Three ways to disable DEP:
    1) IMPORTANT: Save a copy of your original Boot.ini file
    as a backup before you make changes. Now how the heck you do
    this in the root directory is a challenge since you cannot
    right-click on that folder! I saved boot,ini to another
    folder, renamed it “copy of “ and dragged it back to the root.
    * Click Start -> Run
    * Enter Attrib C:\Boot.ini -r -h -s
    * Click Start -> Run
    * Enter Notepad C:\Boot.ini
    * Under [operating systems] replace the parameter
    /NoExecute=xxxxx with /Execute
    * Save the Boot.ini file
    * Click Start -> Run
    * Enter Attrib C:\Boot.ini +r +h +s
    * Restart your computer
    or
    2) Control Panel
    Advanced
    Setup and Recovery
    Settings
    System startup
    Edit
    Under [operating systems] replace the parameter
    /NoExecute=xxxxx with /Execute
    This auto opens notepad so you can save it first with a
    backup name), and save the changed version as boot.ini.
    or
    3: Control Panel
    System
    Advanced
    Performance
    Settings
    Data Execution Prevention
    Turn off for essential programs, for all programs
    Apply
    OK

    Make sure that client server for NetWare is not activated
    (unless you run Novell!!)

    If you run PGP (Pretty Good Protection) cryptography
    encoding I have seen a suggestion to turn it off (uninstall
    it) or get the latest version compatible with XP.

    MS e-tech suggestions for troubleshooting consists of
    msconfig turning off all start items and letting computer do
    a “clean boot.”
    Also to selectively allow ms/windows services to boot, but
    not non-ms services. In other words, MS does not have a clue.

    None of the above work for me, but that’s what’s out there.
  5. Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

    Kevin,

    i had exactly the same behaviour. Everything I clicked or started the first
    time, was delayed for about 10 seconds. I regognized the problem after sp2
    was installed. But uninstalling did not solve the problem.

    But then I found out, that I had some disk I/O errors in the system event
    log. Now XP is changing the disk access mode from DMA (fast) access to PIO
    Mode only. This setting will override the settings in the bios!

    I have a german version of XP, so i dont know exactly the english naming for
    the form labels, but try to do the following:

    To check your settings just go to Control Panel > system > Hardware > Device
    Manager
    then under the ID ATA/ATAPI Controller double click the primary ID Channel,
    and choose the second tab "Advanced settings". The Mode for both devices
    should be "DMA if possible". If this is the case and the current mode is set
    to PIO, then you have to do the following steps, to get back to DMA:

    - Delete the drive(s) in the device manager connected to that controller.
    - Delete the Primary IDE-Channel / Controller
    - Reboot your system.

    After reboot, the system will find your controller & Disks. After a second
    reboot the access mode should be set back to DMA.

    For me this solved the problem. Because my disk has some bad sectors, XP
    regognised some errors during installing SP2. therefore the system changed
    the access mode to PIO.

    Now everything is working well for me. It would be interested to me to know
    if you had the same problem, so please let me (and others) know, if that
    steps brings your system back to normal.

    Regards,
    Michael


    "Momma" <Momma@cincity.co> schrieb im Newsbeitrag
    news:OseorVuuEHA.3808@TK2MSFTNGP10.phx.gbl...
    User Friendly wrote:

    > User Friendly wrote:
    >
    >> Kevin wrote:
    >>
    >>> Does anyone have the problem I have of right clicking
    >>> on a file on the desktop only to have the working in
    >>> the background hour glass show up for about eight
    >>> seconds before the menu comes to life? This doesn't
    >>> happen when I right click on a folder.
    >>>
    >>> I have WinXP Home SP2. Had the same problem
    >>> before the SP2 update.
    >>>
    >> Similar problem with me. After SP2 cannot get to the properties of any
    >> drive device, so I can't add folders, share drives, name drives, etc.
    >> Right click + properties creates a perpetual hourglass. Microsoft SP2
    >> support is baffled (and does not indicate they have even heard of this
    >> problem).
    >> MS did make two suggestions, neither of which worked for me: 1) create
    >> a new user account just in case the old user account is corrupt;
    >> 2) get into MY Computer Properties Advance Performance Settings on
    >> Data Execution Prevention tab select "turn on DEP...EXCEPT THOSE I
    >> SELECT Add Browse and choose and add C:\windows\explorer.exe.
    >> I am in the process of add/remove removing SP2 and then reinstalling
    >> in safe mode (suggestion from this NG). I do not believe that a remove
    >> of SP2, for me, changes all the registry entries back, so I fear I
    >> will be stuck with this until I reconfigure (reload XP fresh). It is a
    >> pity that the paranoia and put-out-the fire mentality of MS does not
    >> allow MS to thoughtfully create a safe solution for attacks while
    >> preserving the integrity of (previously) stable computer systems.
    >
    >
    > No. Uninstalling SP2 and reinstalling it in safe mode was not a cure. In
    > testing, I was able to get XP to generate an error report which I have
    > sent off to the MS tech working with me off the XPSP2 help site (e-mail
    > request for help). Maybe the zillion lines of that report will be
    > helpful. Basically, the error found something awry in Windows Explorer
    > (what a surprise!).

    You are dealing with a KNOWN PROBLEM that MS acknowledges
    but apparently cannot fix. This condition, and variants have
    been around for several years.
    In addition to the suggests listed here, some people think
    that certain applications also are responsible. Check with
    each of your application publishers or search the internet
    for the “right-click” problem and your application. Other
    suggestions relate to updating drivers.

    My experience is that even a vanilla fresh install from
    scratch of XP (SP1 on the install disks) from the install
    disks carries this problem with it. I’ve restored vanilla
    four times and this condition is present. Upgrading to SP2
    does not improve the situation. For me the condition appears
    randomly: sometimes it just hangs with an hourglass,
    sometimes it allows me to use properties and make changes
    immediately, sometimes it takes ten seconds, sometimes, 30
    seconds. These are my tests with only the OS installed
    (absolute minimum default reconfiguration, wipe the disk and
    start all over install) (and with the rest of the junk
    thrown in by the manufacturer or MS as part of the default
    minimum install).

    HERE ARE SOME OF THE SUGGESTIONS I HAVE GATHERED FROM THE NET.
    *
    http://support.microsoft.com/default.aspx?scid=kb;en-us;819946

    Visual Effects
    clear fade slide menus into view (I disabled all of the
    choices as an alternative – i.e. Adjust for Best
    Performance) (This will change the lock of the desktop and
    task bar.)
    OK

    and also
    Control Panel
    Folder Options
    General
    “Use Windows classic folders.”
    OK

    and also
    Control Panel
    Folder Options
    View
    clear “Automatically search for network folders and printers.”
    OK

    * http://support.microsoft.com/default.aspx?scid=kb;en-us;819101
    Control Panel
    Display
    Appearance
    Effects
    “Clear the Use the following transition effect for menus.”
    OK

    * Disable: Data Execution Prevention
    Three ways to disable DEP:
    1) IMPORTANT: Save a copy of your original Boot.ini file
    as a backup before you make changes. Now how the heck you do
    this in the root directory is a challenge since you cannot
    right-click on that folder! I saved boot,ini to another
    folder, renamed it “copy of “ and dragged it back to the root.
    * Click Start -> Run
    * Enter Attrib C:\Boot.ini -r -h -s
    * Click Start -> Run
    * Enter Notepad C:\Boot.ini
    * Under [operating systems] replace the parameter
    /NoExecute=xxxxx with /Execute
    * Save the Boot.ini file
    * Click Start -> Run
    * Enter Attrib C:\Boot.ini +r +h +s
    * Restart your computer
    or
    2) Control Panel
    Advanced
    Setup and Recovery
    Settings
    System startup
    Edit
    Under [operating systems] replace the parameter
    /NoExecute=xxxxx with /Execute
    This auto opens notepad so you can save it first with a
    backup name), and save the changed version as boot.ini.
    or
    3: Control Panel
    System
    Advanced
    Performance
    Settings
    Data Execution Prevention
    Turn off for essential programs, for all programs
    Apply
    OK

    Make sure that client server for NetWare is not activated
    (unless you run Novell!!)

    If you run PGP (Pretty Good Protection) cryptography
    encoding I have seen a suggestion to turn it off (uninstall
    it) or get the latest version compatible with XP.

    MS e-tech suggestions for troubleshooting consists of
    msconfig turning off all start items and letting computer do
    a “clean boot.”
    Also to selectively allow ms/windows services to boot, but
    not non-ms services. In other words, MS does not have a clue.

    None of the above work for me, but that’s what’s out there.
Ask a new question

Read More

Desktops Microsoft Windows XP