Sign in with
Sign up | Sign in
Your question

abit kg7 bios limited to 2G?

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
October 1, 2001 8:57:46 PM

I have been attempting to install 4G of mem into an abit kg7-raid. I have used an assortment of the following:

Corsair 1G, 2 banks, registered, ecc
Corsair 512M, 1 bank, registered, ecc
Crucial 256M, 2 banks, registered, ecc

All attempted combinations at or below 2G work perfectly.

With all combinations 2G < n 4G, the bios reports only 2G present. This includes configuations like:

slot4 256M
slot3 1G
slot2 1G

where I believe that POST is testing only 3/4 of a 1G dimm.

With 4G installed, I get a "bios checksum" failure.

I can't get a response out of abit addressing this.

Ed

More about : abit kg7 bios limited

Anonymous
a b V Motherboard
October 1, 2001 9:39:58 PM

I'm only guessing here, but these things seem like they might affect your memory.

1. Don't mix memory stick types
2. In the Advanced Chipset features part, try all 4 different ECC settings.
3. try both CAS latency settings (2.5, 2)
4. SDRAM timing: try Auto, Normal, Fast, Turbo (forget about ULTRA!)
5. I assume you are not trying to overclock while you are doing this.

Like I said, I really don't know, but these things will certainly have an affect on your system memory behavior.

afterthought: What happened when you installed 4 sticks of 1G? you said you are trying to install 4G of memory right?

After,afterthought: Are you flashed to 4J (Most current bios)?<P ID="edit"><FONT SIZE=-1><EM>Edited by Insidious on 10/01/01 05:44 PM.</EM></FONT></P>
Anonymous
a b V Motherboard
October 1, 2001 10:06:34 PM

Insidious,

1. I tried all 1G dimms first. A few more details on what I observed with 3 1G dimms installed:

bios show banks 2,3,4,5,6,7 occupied so it does see all 3 dimms

ecc modes introduce a 30sec / 1G dimm delay while the parity bits are initiallized before the bios displays anything on the screen. A 3G configuration exhibits a 90 sec delay as expected.

when 3G is installed, the 2G that is visible is stable.

memtest86 observes 3G as present and then hangs. Note that memtest86 is known to only work up to 2G. I don't have a memory test for configurations > 2G.

2) I have tried the different ecc setting with no effect.

3) I have only tried 2.5 so far.

4) I have only tried auto so far.

5) No overclocking on this machine.

With 4G installed, I get a "bios checksum" error and the machine boots with 640K of memory available.

I am using bios 4j which was delivered on the board.

It is my impression that the bios post never even attempts to check for memory configurations larger than 2G.

Ed
Related resources
Anonymous
a b V Motherboard
October 1, 2001 10:21:23 PM

I don't blame ya for being frustrated. It sounds to me like you are trying all the right things. (I really thought with ECC disabled and the conservative RAM settings (2.5/Auto) you would be ok.)

ABit has "stretched the facts" before. I remember they didn't really deliver 4X AGP correctly for a while on the KT7. (I don't remember the details but it had to do with fast writes and Side Band not really being available if 4X was selected.) I also remember when they said the KT7 would increase the FSB without affecting the PCI speed... well that was hogwash too.

Sigh.... C'mon ABit... you have good MoBos you don't need to do the weenie stufforz!
Anonymous
a b V Motherboard
October 1, 2001 10:47:32 PM

I think my step is to go buy a Tyan TigerMP board and try that... Unfortunately, Tyan's manual says only 3.5G or 3G (different claims in various places) will work and even those references have footnotes saying that the configurations have not been verified.

Ed
!