Sign in with
Sign up | Sign in
Your question
Closed

Deus-Ex Human Revolution Crashing

Last response: in Video Games
Share
October 16, 2011 9:04:53 PM

Ok, when i try launching deus-ex my screen goes black and then I get a BSOD every time I launch it, yesterday it was working fine it was the first time i installed it and i got to play 2 hours ,now today it just blue screens when launched,Itried direct launch and steam both don't work ,I also reinstalled twice and still won't work,Idk whats wrong help!

Gpu:6950CFx
Cpu:fx8120
mobo:asusCH5
October 17, 2011 1:58:57 AM

I tried reinstalling catalyst drivers till won't work I tried going into the setup and disabling dx11 it worked for some people but not me I just get a blue screen when i try to enter it says launching then computer freezes and blue screens.
Score
0
October 18, 2011 2:34:53 AM

I tried with a different catalyst version still gives me a crash seriously need help on this please
Score
0
Related resources
October 18, 2011 4:32:07 PM

Clean(CCleaner) your video drivers out and reinstall the drivers.

Score
0
October 18, 2011 4:42:13 PM

Does the BSODs happen in any other game? Or only in Deus Ex?
Score
0
October 18, 2011 7:08:18 PM

Only deus ex.
Dirt 3 crysis2 and everything else works fine.
Score
0
October 18, 2011 8:49:57 PM

I did the ccleaner and drive sweeper and reinstalled cataylst drivers and it still crashes on me when I launch, sometimes Bsod most of the time just a crash followed by a restart.

Score
0
October 18, 2011 9:07:11 PM

Andy34 said:
Ok, when i try launching deus-ex my screen goes black and then I get a BSOD every time I launch it, yesterday it was working fine it was the first time i installed it and i got to play 2 hours ,now today it just blue screens when launched,Itried direct launch and steam both don't work ,I also reinstalled twice and still won't work,Idk whats wrong help!

Gpu:6950CFx
Cpu:fx8120
mobo:asusCH5



I have a similar problem, it used to work fine but I think the new steam patch today has broken it :( 

i7 950
SLI 570 x 2

EDIT - just noticed your original post was before the patch released
Score
0
October 18, 2011 9:14:50 PM

bumnut53 said:
I have a similar problem, it used to work fine but I think the new steam patch today has broken it :( 

i7 950
SLI 570 x 2

EDIT - just noticed your original post was before the patch released


The first time i ran it I played 15 min then the next morning for 2 hours, then in the afternoon Itried running it steam had a patch I Think considering it took longer or it to launch then it just crashed on me and its been that way since.
Score
0
October 19, 2011 4:28:14 PM

Did you try and play the game in compatibility mode? This seems like a problem with the game itself.
Which OS are you running?
Score
0
October 19, 2011 6:45:13 PM

theres no issues with the game that i have... im more inclined to think there systems are unstable. i notice the OP has the new bulldozer... this may be a sign that the game is unstable on the hardware... as the o.s doesnt fully support the cpu.
also get a bluescreen reader like http://www.nirsoft.net/utils/blue_screen_view.html it will help you display the issue in a more readable form.
Score
0
October 19, 2011 7:13:16 PM

Compatibilty mode? Also it crashes when i try to run the setup also.
I have Windows7 Professional 64 bit.

EDIT: I tried the blue screen viewer, it says Caused by Driver"ntoskrnl.exe"
and Address:"ntoskrnl.exe+7cc40"
Now that I remember the day it decided to stop working was the day I installed the AsusCrosshair V Formula's 0813 BIOS which adds full support for Bulldozer CPU's. The day I ran Deus EX:HR I was using the 0705 BIOS which doesn't have full support,maybe that why its not working for me?
Anyone here got a FX8120 and Asus Crosshair V Formula that can run Deus Ex:HR with the 0813 BIOS? Or Can check for me?

REEDIT: Tried with the 9913 BIOS and still doesn't work.
Score
0
October 24, 2011 11:25:38 PM

Really need help over here. Sigh I was looking forward to playing this game.
Score
0
October 25, 2011 7:13:35 PM

I tried both overclocked(4.2) and at stock(3.1), I also tried at stock voltage and under volted,currently undervolted.
None of my Gpus are overclocked although they are both unlocked 6950-->6970 ( Cross Fired Sapphire 6950 2gb TOXIC Edition with dual bios switch).
Should I try to see if it works on position 1 which is 6950 there on position 2 right now which is 6970?
Score
0
October 25, 2011 11:32:00 PM

I finally made progress.I got to the setup without getting a blue-screen,but windows crashed after i clicked play.
Used bluescreenview and here is what It says caused the crash ,well whats at the bottom of the crash report(Long list alert):

ntoskrnl.exe fffff800`03055000 fffff800`0363e000 0x005e9000 0x4e02aaa3 6/22/2011 10:53:23 PM Microsoft® Windows® Operating System NT Kernel & System 6.1.7601.17640 (win7sp1_gdr.110622-1506) Microsoft Corporation C:\Windows\system32\ntoskrnl.exe
hal.dll fffff800`0300c000 fffff800`03055000 0x00049000 0x4ce7c669 11/20/2010 9:00:25 AM
kdcom.dll fffff800`00baa000 fffff800`00bb4000 0x0000a000 0x4d4d8061 2/5/2011 12:52:49 PM
mcupdate.dll fffff880`00c34000 fffff880`00c41000 0x0000d000 0x4a5bdf65 7/13/2009 9:29:09 PM
PSHED.dll fffff880`00c41000 fffff880`00c55000 0x00014000 0x4a5be027 7/13/2009 9:32:23 PM Microsoft® Windows® Operating System Platform Specific Hardware Error Driver 6.1.7600.16385 (win7_rtm.090713-1255) Microsoft Corporation C:\Windows\system32\PSHED.dll
CLFS.SYS fffff880`00c55000 fffff880`00cb3000 0x0005e000 0x4a5bc11d 7/13/2009 7:19:57 PM
CI.dll fffff880`00cb3000 fffff880`00d73000 0x000c0000 0x4ce7c944 11/20/2010 9:12:36 AM
Wdf01000.sys fffff880`00e02000 fffff880`00ea6000 0x000a4000 0x4a5bc19f 7/13/2009 7:22:07 PM
WDFLDR.SYS fffff880`00ea6000 fffff880`00eb5000 0x0000f000 0x4a5bc11a 7/13/2009 7:19:54 PM
ACPI.sys fffff880`00eb5000 fffff880`00f0c000 0x00057000 0x4ce79294 11/20/2010 5:19:16 AM
WMILIB.SYS fffff880`00f0c000 fffff880`00f15000 0x00009000 0x4a5bc117 7/13/2009 7:19:51 PM
msisadrv.sys fffff880`00f15000 fffff880`00f1f000 0x0000a000 0x4a5bc0fe 7/13/2009 7:19:26 PM
pci.sys fffff880`00f1f000 fffff880`00f52000 0x00033000 0x4ce7928f 11/20/2010 5:19:11 AM
vdrvroot.sys fffff880`00f52000 fffff880`00f5f000 0x0000d000 0x4a5bcadb 7/13/2009 8:01:31 PM
partmgr.sys fffff880`00f5f000 fffff880`00f74000 0x00015000 0x4ce792c0 11/20/2010 5:20:00 AM
volmgr.sys fffff880`00f74000 fffff880`00f89000 0x00015000 0x4ce792a0 11/20/2010 5:19:28 AM
volmgrx.sys fffff880`00f89000 fffff880`00fe5000 0x0005c000 0x4ce792eb 11/20/2010 5:20:43 AM
AiChargerPlus.sys fffff880`00fe5000 fffff880`00fe6e00 0x00001e00 0x4cd79d3a 11/8/2010 2:48:26 AM
mountmgr.sys fffff880`00d73000 fffff880`00d8d000 0x0001a000 0x4ce79299 11/20/2010 5:19:21 AM
vmbus.sys fffff880`00d8d000 fffff880`00dc9000 0x0003c000 0x4ce79b89 11/20/2010 5:57:29 AM
winhv.sys fffff880`00fe7000 fffff880`00ffb000 0x00014000 0x4ce792c2 11/20/2010 5:20:02 AM
atapi.sys fffff880`00dc9000 fffff880`00dd2000 0x00009000 0x4a5bc113 7/13/2009 7:19:47 PM
ataport.SYS fffff880`00dd2000 fffff880`00dfc000 0x0002a000 0x4ce79293 11/20/2010 5:19:15 AM
msahci.sys fffff880`00c00000 fffff880`00c0b000 0x0000b000 0x4ce7a416 11/20/2010 6:33:58 AM
PCIIDEX.SYS fffff880`00c0b000 fffff880`00c1b000 0x00010000 0x4a5bc114 7/13/2009 7:19:48 PM
amd_sata.sys fffff880`00c1b000 fffff880`00c32000 0x00017000 0x4d714f75 3/4/2011 4:45:41 PM
storport.sys fffff880`01020000 fffff880`01083000 0x00063000 0x4d79a55f 3/11/2011 12:30:23 AM
amd_xata.sys fffff880`01083000 fffff880`01091000 0x0000e000 0x4d714f78 3/4/2011 4:45:44 PM
asahci64.sys fffff880`01091000 fffff880`0109d000 0x0000c000 0x4d89a2ef 3/23/2011 3:36:15 AM
amdxata.sys fffff880`0109d000 fffff880`010a8000 0x0000b000 0x4ba3a3ca 3/19/2010 12:18:18 PM
fltmgr.sys fffff880`010a8000 fffff880`010f4000 0x0004c000 0x4ce7929c 11/20/2010 5:19:24 AM
fileinfo.sys fffff880`010f4000 fffff880`01108000 0x00014000 0x4a5bc481 7/13/2009 7:34:25 PM
Ntfs.sys fffff880`01249000 fffff880`013ec000 0x001a3000 0x4d79997b 3/10/2011 11:39:39 PM
msrpc.sys fffff880`01108000 fffff880`01166000 0x0005e000 0x4ce79334 11/20/2010 5:21:56 AM
ksecdd.sys fffff880`01200000 fffff880`0121b000 0x0001b000 0x4ce7930b 11/20/2010 5:21:15 AM
cng.sys fffff880`01166000 fffff880`011d8000 0x00072000 0x4ce79e2d 11/20/2010 6:08:45 AM
pcw.sys fffff880`0121b000 fffff880`0122c000 0x00011000 0x4a5bc0ff 7/13/2009 7:19:27 PM
Fs_Rec.sys fffff880`0122c000 fffff880`01236000 0x0000a000 0x4a5bc111 7/13/2009 7:19:45 PM
ndis.sys fffff880`014b6000 fffff880`015a9000 0x000f3000 0x4ce79392 11/20/2010 5:23:30 AM
NETIO.SYS fffff880`01400000 fffff880`01460000 0x00060000 0x4ce79381 11/20/2010 5:23:13 AM
ksecpkg.sys fffff880`01460000 fffff880`0148b000 0x0002b000 0x4ce79e9a 11/20/2010 6:10:34 AM
tcpip.sys fffff880`0169f000 fffff880`018a3000 0x00204000 0x4e001123 6/20/2011 11:33:55 PM
fwpkclnt.sys fffff880`018a3000 fffff880`018ed000 0x0004a000 0x4ce79321 11/20/2010 5:21:37 AM
vmstorfl.sys fffff880`018ed000 fffff880`018fd000 0x00010000 0x4ce79b8a 11/20/2010 5:57:30 AM
volsnap.sys fffff880`018fd000 fffff880`01949000 0x0004c000 0x4ce792c8 11/20/2010 5:20:08 AM
spldr.sys fffff880`01949000 fffff880`01951000 0x00008000 0x4a0858bb 5/11/2009 12:56:27 PM
rdyboost.sys fffff880`01951000 fffff880`0198b000 0x0003a000 0x4ce7982e 11/20/2010 5:43:10 AM
mup.sys fffff880`0198b000 fffff880`0199d000 0x00012000 0x4a5bc201 7/13/2009 7:23:45 PM
hwpolicy.sys fffff880`0199d000 fffff880`019a6000 0x00009000 0x4ce7927e 11/20/2010 5:18:54 AM
fvevol.sys fffff880`019a6000 fffff880`019e0000 0x0003a000 0x4ce793b6 11/20/2010 5:24:06 AM
disk.sys fffff880`019e0000 fffff880`019f6000 0x00016000 0x4a5bc11d 7/13/2009 7:19:57 PM
CLASSPNP.SYS fffff880`01600000 fffff880`01630000 0x00030000 0x4ce7929b 11/20/2010 5:19:23 AM
crashdmp.sys fffff880`01630000 fffff880`0163e000 0x0000e000 0x4a5bcabd 7/13/2009 8:01:01 PM
dump_storport.sys fffff880`0163e000 fffff880`01648000 0x0000a000 0x4db1df50 4/22/2011 4:04:32 PM
dump_amd_sata.sys fffff880`01648000 fffff880`0165f000 0x00017000 0x4d714f75 3/4/2011 4:45:41 PM
dump_dumpfve.sys fffff880`0165f000 fffff880`01672000 0x00013000 0x4a5bc18f 7/13/2009 7:21:51 PM

Edit:I tried running the setup and it gave me a blue screen,so much for progress I noted it said 2ndary processor something something
Score
0
October 26, 2011 6:59:05 PM

No SSD and I don't find the GPU unstable I run witcher2,crysis2 and dirt all on ultra and i have had no problems also I did a clean install of the drivers. In a few hours im going to see if changing the bios of the mobo might change anything or if setting it to a 6950 does anything,although ASUS recommend you update the bios asap if using a FX chip.Also yesterday it worked fine for 3 minutes it got to the menu then it froze up and blue screened.
Score
0
October 26, 2011 8:22:38 PM

Ok, I tried with 6950s and it still didn't work,I noticed the boards q led light for the ram was red which means there is a problem,yet it only goes red when I get a bad OC or when I launch Deus Ex HR. I checked with memok and there are no problems everything running fine 9-9-9-24 1600Mhz G-skill 8gb,I checked if windows was corrupt and I found no problems
Score
0
October 28, 2011 11:11:44 AM

Wow having same problem with BF3 it crashes or blue screens when i launch it although disabling crossfire fixes it for BF3 it doesn't for deus ex I still get that error on 2ndary processor blah blah blah.
Score
0

Best solution

October 29, 2011 12:03:54 AM

I had the same problem with Deus Ex HR, with an FX-8150 (Bulldozer/Zambezi) on an ASUS Sabertooth 990fx mb. I was using the beta 0810 bios, which has "Update AMD CPU Firmware" as the description. When I downgraded to the version 0705 bios, the problem went away.
Share
October 29, 2011 10:10:25 AM

Ugh, I'm using the unofficial 9913Bios on my CrosshairV its better for overclocking putting the bios to 0705 is the only thing I haven't tried, then again I don't wanna lose my 4.2 on 1.27V (211x20)I guess I'll just switch it out whenever I wanna play deus ex or at least until my 2nd or 3rd play though xD

^ worked thanks.
Score
0
October 30, 2011 2:32:19 PM

Best answer selected by Andy34.
Score
0
!