Sign in with
Sign up | Sign in
Your question

HELP! new TUSL2-C USB ports don't work right

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
October 9, 2001 11:07:42 PM

My poor old ABIT BH6 finally bit the dust (one of the power Mosfets was all toasted) so I needed a new socket 370 Mobo. The ASUS TUSL2-C sounded good, got one, and after much fiddling finally got the i815 drivers all set up. This was using all the same components as with the BH6, including the HD w/ win98 1st edition set up. I have an optical USB mouse which seemed OK at first.
**BUT** the USB ports act very weird. When I boot up or restart, the USB mouse is unresponsive (no lights from sensor even.) Looking into control panel, I see four devices under USB: (qty 2) Intel(R)82801BA/BAM USB Universal Host Controller - 2442 and -2444; (qty 2) USB Root Hub. All use Intel driver dated 5-1-2000 from the i815 chipset. There are two sets of USB ports on this board one on the backplane by the PS/2 ports and two on a header board.
So, the USB ports aren't even powered. I look in Device Manager and both the USB Root Hubs have exclamation points. It says that "Winblows failed to get a response from the devices and has permanently disables them, see ASD in WIN help." ASD says that "There are no ASD errors in the system."
This is where it gets weird: If I remove both root hubs in Device Manager and then reboot, upon entering Windows the "New Hardware detected" comes up and detects both root hubs, the USB mouse, and "installs" the drivers for them. These are the same Intel drivers that didn't work before. The USB mouse comes up as a "Windows USB/PS2 Bowser Mouse Combo" and proceeds to work perfectly...until I reboot again, when the USB Root Hubs both have exclamation points again.
I know that was long-winded, but I didn't want to leave anything out. To sum up: if I remove the two USB Root Hubs before rebooting, they are detected as new hardware, drivers are loaded and they work fine; if not removed, they don't work, have an error in device manager with that ASD thing.
ITS DRIVING ME CRAZY!! Please Help!!

Thanks,
MadMan

More about : tusl2 usb ports work

a b V Motherboard
October 10, 2001 3:02:19 AM

It's a configuration error, usually caused by sharing. Try setting you BIOS to PNP OS-NO and/or changing your cards around.

Back to you Tom...
Anonymous
a b V Motherboard
October 10, 2001 6:38:41 AM

Changing to non-PnP OS alone has not solved the problem.
I had a strange thought, though, see what you think...Since this HD was originally set up and running on a BH6 with 440 BX chipset, maybe WIN still has some of the .inf or setupfiles or whatever that worked with that chipset and it is defaulting back to them. I did notice one thing: on the driver tab for all the USB devices it says all the files are from Intel dated 5-1-2000, but the *actual files* when looking in driver file details are version 4.10.1998 from M$. I tried deleting these files but they were back when I rebooted. Are the ICH2 .inf files somehow not being used correctly?? what do you think?
I will try swapping some cards tomorrow, maybe even go for a reformat and totally fresh install, though I have only one HD and no way to back up my personal files...*sigh*

As Always, thanks Crash, you can always be depended upon for some useful input
Related resources
a b V Motherboard
October 10, 2001 4:14:56 PM

OK, did you run the Intel INF update utility that came with the new motherboard?
I would go into safe mode and delete everything from device manager, reboot, let your hardware be redetected, then go into device manager and delete everything that is listed twice with one being flaged, reboot again, and let windows find the correct hardware. That should get all your hardware detection to show the current stuff, you can rerun the INF update utility if you need to.

Back to you Tom...
October 10, 2001 4:25:50 PM

if you want to remove usb devices without formatting you can give this a try,

go to safe mode, device manager, remove any usb devices
after this go into windows/inf/other and remove the inf files, and then regedit goto hkey_local_machine/enum and delete USB key if it still exists (this should force windows to redetect the usb ports)
you can then update the usb drivers with the correct ones for the motherboard....
October 10, 2001 4:29:01 PM

I don't know if this applies in your case, but...

Whenever I install a new mobo, I find it best to reinstall Windows. Windows doesn't like having a spine transplant. Swapping just about anything else on the system is OK, but switching the mainboard seems to choke it up.

So, if nothing else seems to work, try reinstalling your OS.



-DOOM
"Ultimately, there is no knowledge -- only belief."
Anonymous
a b V Motherboard
October 10, 2001 5:17:13 PM

Yes, I did run the INF update utility. I also noticed there is a new BIOS dated 9-21-2001 which only says it added VCore for Tualatin CPUs (which is cool), but who knows it might help too??
Thanks for all the suggestions, I will try them all and report back. One other oddity that makes me think it is a conflict with the old Mobo setup: when I reboot and the USB Root Hubs come up bad, if I do update driver and use "show all drivers in a certain location and let me choose one" and then repoint Windows to the Intel drivers (even though it says it is already using them) the Root Hubs work right away. I will try the safe mode deal, as I really don't want to reformat and lose all my driver and program download updates and "other" downloads ;) 
Anonymous
a b V Motherboard
October 10, 2001 9:53:06 PM

I did a combination of Crash and Skuzz's recommendations, but those alone did not solve the problem. I saw that one of the USB Universal Host Controllers was sharing an IRQ with my 3Com PCI ADSL modem. Thinking it would be good to get all the devices alone, I tried to force the DSL modem's PCI slot to use IRQ 12, which is normally for the PS/2 mouse.

STILL no luck though. So I reset the BIOS back to default settings, changed the settings I knew didn't interfere with the devices, and THEN lo and behold I found that the default setting is for IRQ5 to be reserved "for legacy devices." Well, I don't have any of those (I thought) so I set the reserve status for IRQ5 to "no." Same problem...sigh.
I decided "Self, why not try it with IRQ5 reserved, couldn't hurt..." So, I did and guess what? Creative SB16 Emulation *acts* like a legacy device. duh. After letting the BIOS set up the IRQ's look like this:
0: System Timer
1: Keybd
2: Programmable Interrupt Controller
3: #Com ADSL PCI Modem; IRQ Holder for PCI steering(hereafter abbreviated)
4: Intel 82891 BA/BAM USB Univ. Host Ctrlr. -2442; IRQ Holder
5: Creative SB16 Emulation
6: Standard FD controller
7: ECP Printer Port (LPT1)
8: System CMOS/Realtime Clock
9:Intel 82801 BA/BAM USB Univ. Host Ctrlr -2444; 3Com Etherlink 3C905B-TX NIC; Creative SB Live!; 4xIRQ Holder
10: Intel 82801 BA/BAM SMBus Ctrlr - 2443; IRQ holder
11: Radeon DDR; IRQ Holder
12: {nothing}
13: Numeric Data Processor
14 and 15: Intel 82801BA UltraATA Ctrlr; Primary and Secondary U-ATA Ctrlr, one on each IRQ.
Heh. The only thing funny is that IRQ 9 is loaded to the gills and 12 is empty. Maybe I'll get brave someday and try to force one of those devces to use IRQ12...or maybe not:) 

Thanks for all the help!
!