Sign in with
Sign up | Sign in
Your question
Closed

Battlefield 3 Stutter?

Last response: in Video Games
Share
October 25, 2011 6:25:01 AM

Anybody else getting stutter on ultra settings even when framerate is locked at 60fps with Vsync enabled.

More about : battlefield stutter

Best solution

October 25, 2011 6:27:08 AM

Yes, There is a new Nvidia drive that came out like 8 hours ago. Not sure about ATI. I have a GTX580 and am getting stuttering with Vsync on. I quit and am working on solving my issue.

DANG it my PC is NOT SLOW! RUN FAST, NOW! HAHA
Share
October 25, 2011 6:32:31 AM

Yes I updated to the new driver 285.62 before starting the game. Been searching and a site stated there is something wrong with the new driver. I'm going back to try the old beta driver. I get the stutter when turning. Perfectly smooth when walking straight.

BTW game is the $hit!
Score
0
Related resources
October 25, 2011 6:33:48 AM

What are your PC specs? This game is a killer. I have to turn down from Ultra settings. The new driver DID help me.
Score
0
October 25, 2011 6:38:02 AM

-CPU- i5 2500k OC @ 4.3GHz 
-Cooler- CM Hyper 212 
-Motherboard- Asus-Z68-Pro 
-RAM- G.Skill DDR3 1600 CL8 1.5v 
-GPU-EVGA GTX 590 Classified
-Samsung Spinpoint F4 2tb HDD 
-PSU-Corsair 1050 watt Professional Series 
-Case-Cooler Master HAF X
-OS- Windows 7 64bit

So far amazing. My FPS has not fallen below 60fps with Vsync on, all settings on ultra.
Score
0
October 25, 2011 7:00:13 AM

They will have half a dozen patches in the next 2 months. Classic BF style
Score
0
October 25, 2011 7:24:15 AM

I found putting it on Auto works pretty well. The settings it chooses are acceptible and keeps 60fps.
Score
0
October 25, 2011 10:58:56 AM

jay2tall said:
I found putting it on Auto works pretty well. The settings it chooses are acceptible and keeps 60fps.


Have to agree with this. I have a single gtx 570, the auto settings put half settings on ultra and half on high. The only change I had to make on custom was disabling motion blur because it's obnoxious. Game hasn't dipped below 60fps yet. Put it up to full ultra and couldn't really see much difference in image quality but fps were lower than what I'm willing to play a shooter with. Auto settings seem well tuned generally.
Score
0
October 25, 2011 11:30:46 AM

I am wondering if Nvidia and ATI did not do some testing and made general system specs, then tuned the settings. So we get pretunes settings that are close to our current systems. I've been playing since 1AM EST and It hasn't flinched.
Score
0
October 25, 2011 12:10:43 PM

for the 590 owner, its not microstuttering is it, you've still an SLI setup there, and with only 1.5GB per card you might be struggling with Vram as well, especially at ultra and hi res, at 1152p (yes I know) I was using all of my Vram on my 470 on high on the beta, although it streams textures heavily? so this may not be important. I'm in the UK so I don't know about the full version yet!!!!!
Score
0
October 25, 2011 1:01:10 PM

13thmonkey said:
for the 590 owner, its not microstuttering is it, you've still an SLI setup there, and with only 1.5GB per card you might be struggling with Vram as well, especially at ultra and hi res, at 1152p (yes I know) I was using all of my Vram on my 470 on high on the beta, although it streams textures heavily? so this may not be important. I'm in the UK so I don't know about the full version yet!!!!!


No I play Crysis 2 dx11 & high res and as long as I stay at a constant framerate there is never any microstutter, super smooth. I'm only playing on 1920x1080 so I have plenty VRAM. The VRAM only starts to show slightly when I go 5760x1080 triple monitor.

The final version is more optimized as beta high settings was getting as low as 50fps and final version with everything ultra never dropped below 60fps.
Score
0
October 25, 2011 1:05:19 PM

jay2tall said:
I am wondering if Nvidia and ATI did not do some testing and made general system specs, then tuned the settings. So we get pretunes settings that are close to our current systems. I've been playing since 1AM EST and It hasn't flinched.


I don't know if I'm just getting use to it but the stutter doesn't look that bad anymore. Maybe eyes just tired from 8 hr marathon, lol.
Score
0
October 25, 2011 1:19:26 PM

good news about the optimisations, looking forward to the 28th.
Score
0
October 25, 2011 1:23:04 PM

Swolern said:
I don't know if I'm just getting use to it but the stutter doesn't look that bad anymore. Maybe eyes just tired from 8 hr marathon, lol.

Haha I'm still goin. What you talkin about! I took off work for this.
Score
0
October 25, 2011 8:49:46 PM

jay2tall said:
Haha I'm still goin. What you talkin about! I took off work for this.


Haha I took off work too and told my wife don't talk to me for next couple of days, lol. I just built my first PC ever, just for this game.
Score
0
October 25, 2011 8:54:52 PM

casualcolors said:
Have to agree with this. I have a single gtx 570, the auto settings put half settings on ultra and half on high. The only change I had to make on custom was disabling motion blur because it's obnoxious. Game hasn't dipped below 60fps yet. Put it up to full ultra and couldn't really see much difference in image quality but fps were lower than what I'm willing to play a shooter with. Auto settings seem well tuned generally.


What is your resolution? Do you use the new 285.27 drivers?
Score
0
October 25, 2011 10:21:55 PM

FunSurfer said:
What is your resolution? Do you use the new 285.27 drivers?


Have played on 1680x1050 and 1900x1080 so far, about the same fps at both resolutions. I'm using the 285.62 nvidia drivers.
Score
0
October 26, 2011 6:16:30 AM

casualcolors said:
Have played on 1680x1050 and 1900x1080 so far, about the same fps at both resolutions. I'm using the 285.62 nvidia drivers.


Thank you for the reply. Yes the drivers are indeed 285.62, I checked 3 days ago on the Nvidia site and for a strange reason I saw the other version.
Score
0
October 26, 2011 6:53:24 AM

FunSurfer said:
Thank you for the reply. Yes the drivers are indeed 285.62, I checked 3 days ago on the Nvidia site and for a strange reason I saw the other version.


285.62 was released just yesterday.
Score
0
October 27, 2011 2:19:04 AM

Oh ***! I adjusted mouse sensitivity down and turned raw input to on and now it's perfectly smooth. Try it out.

Thanks for input everyone.
Score
0
October 27, 2011 2:21:34 AM

Best answer selected by Swolern.
Score
0
October 27, 2011 10:08:25 AM



Update On Stuttering - Fix Available




Concerning the CrossFireX stuttering mentioned above, AMD has informed us that the 11.9 CAP 3 that was recommended to install for BF3 is actually the culprit for the stuttering behavior with CFX in this game. AMD recommends to uninstall the CAP and only install Catalyst 11.10 Preview 3 driver. If you already have the CAP installed, your best bet is to uninstall the CAP as well as the driver, and re-install just the driver with no CAP. We have tested this by removing the CAP, and on our system the stuttering with 6970 CFX is gone. We experienced no negative impact to performance in the game by removing the CAP. The gameplay experience is much better with the CAP uninstalled.






"One note – about the stuttering for CFX, the latest CAP is causing that, once you remove it, you should be fine…we’re on it and fixing it as we speak." -AMD
Score
0
October 27, 2011 5:44:47 PM

This topic has been closed by Mousemonkey
Score
0
!