FTP problem after SP2 - HELP!!

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.perform_maintain (More info?)

Since I upgraded with SP2, I cannot connect to my web site hosting server
via FTP. Reading around this problem it seems that the Windows Firewall is
somehow involved but it's not enabled on my PC so how can it be blocking
traffic required by my FTP client !? I've played the game and added port 20
and 21 exceptions in the Firewall setup amongst other things but there's no
difference.

Does anyone have any idea about what's going on here. Any suggestions
greatly appreciated.

TIA.

Rog.
7 answers Last reply
More about problem help
  1. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.perform_maintain (More info?)

    Here's how to correct the problem after opening Port 21 via the
    SP2 firewall Exceptions tab:

    1. Open Internet Explorer >Tools > Internet Options > Advanced tab

    2. Uncheck the box: "Use passive FTP (for firewall & DSL modem capability)

    --
    Carey Frisch
    Microsoft MVP
    Windows XP - Shell/User

    Be Smart! Protect Your PC!
    http://www.microsoft.com/athome/security/protect/default.aspx

    -----------------------------------------------------------------------------------

    "Roger" wrote:

    | Since I upgraded with SP2, I cannot connect to my web site hosting server
    | via FTP. Reading around this problem it seems that the Windows Firewall is
    | somehow involved but it's not enabled on my PC so how can it be blocking
    | traffic required by my FTP client !? I've played the game and added port 20
    | and 21 exceptions in the Firewall setup amongst other things but there's no
    | difference.
    |
    | Does anyone have any idea about what's going on here. Any suggestions
    | greatly appreciated.
    |
    | TIA.
    |
    | Rog.
  2. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.perform_maintain (More info?)

    Thanks for the reply but I've done all this already and there's no change.
    The main FTP client I'm trying to use is part of a web site generation
    package (Namo Webeditor). I've altered the passive / active setting but no
    change. The behaviour is the same if I use SmartFTP as an alternative.

    The strange thing to me is that the Windows Firewall is DISABLED so how can
    it be affecting anything?

    Thanks anyway.

    Rog.

    "Carey Frisch [MVP]" <cnfrisch@nospamgmail.com> wrote in message
    news:%232u5xSHwEHA.1400@TK2MSFTNGP11.phx.gbl...
    > Here's how to correct the problem after opening Port 21 via the
    > SP2 firewall Exceptions tab:
    >
    > 1. Open Internet Explorer >Tools > Internet Options > Advanced tab
    >
    > 2. Uncheck the box: "Use passive FTP (for firewall & DSL modem
    > capability)
    >
    > --
    > Carey Frisch
    > Microsoft MVP
    > Windows XP - Shell/User
    >
    > Be Smart! Protect Your PC!
    > http://www.microsoft.com/athome/security/protect/default.aspx
    >
    > -----------------------------------------------------------------------------------
    >
    > "Roger" wrote:
    >
    > | Since I upgraded with SP2, I cannot connect to my web site hosting
    > server
    > | via FTP. Reading around this problem it seems that the Windows Firewall
    > is
    > | somehow involved but it's not enabled on my PC so how can it be blocking
    > | traffic required by my FTP client !? I've played the game and added port
    > 20
    > | and 21 exceptions in the Firewall setup amongst other things but there's
    > no
    > | difference.
    > |
    > | Does anyone have any idea about what's going on here. Any suggestions
    > | greatly appreciated.
    > |
    > | TIA.
    > |
    > | Rog.
    >
  3. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.perform_maintain (More info?)

    In Internet Explorer:

    Tools >Internet options > Advanced tab
    Put a check mark next to: Use Passive FTP
    Put a check mark next to: Enable Folder View of FTP sites.

    If this does not solve the problem, check whether there is a general
    problem with the Internet connection. Try to ping the server, etc.

    regards,
    ssg MS-MVP
    pronetworks.org

    Roger wrote:

    > Since I upgraded with SP2, I cannot connect to my web site hosting server
    > via FTP. Reading around this problem it seems that the Windows Firewall is
    > somehow involved but it's not enabled on my PC so how can it be blocking
    > traffic required by my FTP client !? I've played the game and added port 20
    > and 21 exceptions in the Firewall setup amongst other things but there's no
    > difference.
    >
    > Does anyone have any idea about what's going on here. Any suggestions
    > greatly appreciated.
    >
    > TIA.
    >
    > Rog.
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.perform_maintain (More info?)

    Thanks, but no luck with your suggestion. Pinging the server fails as well.

    Rog.


    "S.Sengupta" <ssengupta_@msn.com> wrote in message
    news:el2dOYHwEHA.3908@TK2MSFTNGP12.phx.gbl...
    > In Internet Explorer:
    >
    > Tools >Internet options > Advanced tab
    > Put a check mark next to: Use Passive FTP
    > Put a check mark next to: Enable Folder View of FTP sites.
    >
    > If this does not solve the problem, check whether there is a general
    > problem with the Internet connection. Try to ping the server, etc.
    >
    > regards,
    > ssg MS-MVP
    > pronetworks.org
    >
    > Roger wrote:
    >
    >> Since I upgraded with SP2, I cannot connect to my web site hosting server
    >> via FTP. Reading around this problem it seems that the Windows Firewall
    >> is somehow involved but it's not enabled on my PC so how can it be
    >> blocking traffic required by my FTP client !? I've played the game and
    >> added port 20 and 21 exceptions in the Firewall setup amongst other
    >> things but there's no difference.
    >>
    >> Does anyone have any idea about what's going on here. Any suggestions
    >> greatly appreciated.
    >>
    >> TIA.
    >>
    >> Rog.
  5. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.perform_maintain (More info?)

    Roger wrote:
    > Thanks, but no luck with your suggestion. Pinging the server fails as
    > well.
    > Rog.
    >
    >
    > "S.Sengupta" <ssengupta_@msn.com> wrote in message
    > news:el2dOYHwEHA.3908@TK2MSFTNGP12.phx.gbl...
    >> In Internet Explorer:
    >>
    >> Tools >Internet options > Advanced tab
    >> Put a check mark next to: Use Passive FTP
    >> Put a check mark next to: Enable Folder View of FTP sites.
    >>
    >> If this does not solve the problem, check whether there is a general
    >> problem with the Internet connection. Try to ping the server, etc.
    >>
    >> regards,
    >> ssg MS-MVP
    >> pronetworks.org
    >>
    >> Roger wrote:
    >>
    >>> Since I upgraded with SP2, I cannot connect to my web site hosting
    >>> server via FTP. Reading around this problem it seems that the
    >>> Windows Firewall is somehow involved but it's not enabled on my PC
    >>> so how can it be blocking traffic required by my FTP client !? I've
    >>> played the game and added port 20 and 21 exceptions in the Firewall
    >>> setup amongst other things but there's no difference.
    >>>
    >>> Does anyone have any idea about what's going on here. Any
    >>> suggestions greatly appreciated.
    >>>
    >>> TIA.
    >>>
    >>> Rog.

    Open TCP/IP properties of the connection, Advanced properties, Options
    tab, TCP/IP filtering. All three entries should be Permit All.

    Q
  6. Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

    Check to see if the Application Layer Gateway service in the administrative
    tools/Services section is set to either manual(default) or enabled. If your
    firewall is blocking this program (alg.exe) I can't set up a ftp server from
    personal experience.

    "Roger" <rogerwilson@hotmail.com> wrote in message
    news:%23QdnGYHwEHA.3288@TK2MSFTNGP14.phx.gbl...
    > Thanks for the reply but I've done all this already and there's no change.
    > The main FTP client I'm trying to use is part of a web site generation
    > package (Namo Webeditor). I've altered the passive / active setting but no
    > change. The behaviour is the same if I use SmartFTP as an alternative.
    >
    > The strange thing to me is that the Windows Firewall is DISABLED so how
    > can it be affecting anything?
    >
    > Thanks anyway.
    >
    > Rog.
    >
    > "Carey Frisch [MVP]" <cnfrisch@nospamgmail.com> wrote in message
    > news:%232u5xSHwEHA.1400@TK2MSFTNGP11.phx.gbl...
    >> Here's how to correct the problem after opening Port 21 via the
    >> SP2 firewall Exceptions tab:
    >>
    >> 1. Open Internet Explorer >Tools > Internet Options > Advanced tab
    >>
    >> 2. Uncheck the box: "Use passive FTP (for firewall & DSL modem
    >> capability)
    >>
    >> --
    >> Carey Frisch
    >> Microsoft MVP
    >> Windows XP - Shell/User
    >>
    >> Be Smart! Protect Your PC!
    >> http://www.microsoft.com/athome/security/protect/default.aspx
    >>
    >> -----------------------------------------------------------------------------------
    >>
    >> "Roger" wrote:
    >>
    >> | Since I upgraded with SP2, I cannot connect to my web site hosting
    >> server
    >> | via FTP. Reading around this problem it seems that the Windows Firewall
    >> is
    >> | somehow involved but it's not enabled on my PC so how can it be
    >> blocking
    >> | traffic required by my FTP client !? I've played the game and added
    >> port 20
    >> | and 21 exceptions in the Firewall setup amongst other things but
    >> there's no
    >> | difference.
    >> |
    >> | Does anyone have any idea about what's going on here. Any suggestions
    >> | greatly appreciated.
    >> |
    >> | TIA.
    >> |
    >> | Rog.
    >>
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.perform_maintain (More info?)

    Hi,

    XP SP2 has nothing to do with the FTP. FTP should work even if the firewall
    is turned on. Check with your Internet provider if they have disabled it on
    their side. Most of the ISPs disable the FTP to prevent the spreading of
    virus as well reduce the security risk. They might be able to turn it on on
    demand by permitting on a user wise basis ie. grant access to those who need
    it and deny to those who do not need it.

    Regards
    M. Rajesh
    ..Net and Windows Shell MVP
    www.winxpsolution.com.

    "Quaoar" wrote:

    > Roger wrote:
    > > Thanks, but no luck with your suggestion. Pinging the server fails as
    > > well.
    > > Rog.
    > >
    > >
    > > "S.Sengupta" <ssengupta_@msn.com> wrote in message
    > > news:el2dOYHwEHA.3908@TK2MSFTNGP12.phx.gbl...
    > >> In Internet Explorer:
    > >>
    > >> Tools >Internet options > Advanced tab
    > >> Put a check mark next to: Use Passive FTP
    > >> Put a check mark next to: Enable Folder View of FTP sites.
    > >>
    > >> If this does not solve the problem, check whether there is a general
    > >> problem with the Internet connection. Try to ping the server, etc.
    > >>
    > >> regards,
    > >> ssg MS-MVP
    > >> pronetworks.org
    > >>
    > >> Roger wrote:
    > >>
    > >>> Since I upgraded with SP2, I cannot connect to my web site hosting
    > >>> server via FTP. Reading around this problem it seems that the
    > >>> Windows Firewall is somehow involved but it's not enabled on my PC
    > >>> so how can it be blocking traffic required by my FTP client !? I've
    > >>> played the game and added port 20 and 21 exceptions in the Firewall
    > >>> setup amongst other things but there's no difference.
    > >>>
    > >>> Does anyone have any idea about what's going on here. Any
    > >>> suggestions greatly appreciated.
    > >>>
    > >>> TIA.
    > >>>
    > >>> Rog.
    >
    > Open TCP/IP properties of the connection, Advanced properties, Options
    > tab, TCP/IP filtering. All three entries should be Permit All.
    >
    > Q
    >
    >
    >
Ask a new question

Read More

FTP Firewalls Microsoft Windows XP