Sign in with
Sign up | Sign in
Your question

Impossible to choose 1080i on DX11, most games

Last response: in Video Games
Share
October 27, 2011 7:49:57 AM

Hello there,

I have scoured the internets for days and days and found no solutions for this. This is the first time I ask help directly, usually the answer is covered somewhere here.

When I choose DX11, most games only allow me 1280x760 resolution for my Toshiba 1080i capable display. DX9 works just fine in all resolutions. No amount of manual changing of config files helps. The games do not even allow any other resolution. Note that 1280x760 is the res when my display can start using progressive scan.

Games include: TW:Shogun 2, Deus Ex:HR, Metro 2033.

I have read people having the same problem with 1080i displays. My current graphics card is Geforce 560 Ti, but I had the exact same problem with an ATI 4870 (when using DX10 in this case, but DX9 was working just fine again).

My best guess is that DX11 does not like the interlacing but I don't know how to overcome this problem.

I have tried even this, with no results: http://www.sevenforums.com/tutorials/7947-force-dvi-hdm...

Thank you for reading and your help will be much appreciated.

PS I originally posted this in the peripherals/flat panels section since i'm pretty sure it has to do with 1080i resolutions, but on second thought, this section now is more appropriate.
October 27, 2011 3:43:04 PM

I'm not 100% on this but it matters between i and p. I think majority of the games put out in p format, so if your monitor supports 1080i, but only 768p, then that's all you'll be able to get.
October 27, 2011 4:42:38 PM

Thanks for the reply. That seems to be the case, but still DX9 works just fine in all resolutions for the same games. There must be some way to overcome the limitation without having to buy a new tv.
Related resources
Can't find your answer ? Ask !
October 27, 2011 6:34:04 PM

it may be due to insufficient video memory, may be dx10,11 requires more memory than 1gb at 1080i,
it also hapens to me in gta4 when i 1st set high texture quality then if i try to increase its resolution it doesn't alow me to do that(as gta4 show graphic memory usage as we change settings).
To confirm this try to use graphic card with more memory or use sli,
so Add more graphic memory to solve it.

TO CHECK GRAPHIC MEMORY USAGE USE 'MSI AFTERBURN'
October 27, 2011 10:25:10 PM

truegenius said:
it may be due to insufficient video memory, may be dx10,11 requires more memory than 1gb at 1080i,
it also hapens to me in gta4 when i 1st set high texture quality then if i try to increase its resolution it doesn't alow me to do that(as gta4 show graphic memory usage as we change settings).
To confirm this try to use graphic card with more memory or use sli,
so Add more graphic memory to solve it.

TO CHECK GRAPHIC MEMORY USAGE USE 'MSI AFTERBURN'

So you're saying the 560ti doesn't have enough video ram to run those games? LOL.
OP: what are your full system specs?
October 27, 2011 10:46:41 PM

It indeed does not seem to be a matter of lack of resources.

I have an Intel i5 750 Quad core @2.7GHz, 4 gig RAM and the 560Ti has 2gig on its own. Windows 7 64 bit.

When the games in question run at 1080i, with DX9, they are blazing fast at almost maxed out settings.

I have only found references in other forums of people with apparently the same problem, but no solutions. Thanks for giving it a shot, I still have hope. :) 
October 27, 2011 10:52:27 PM

ilikephysics said:
It indeed does not seem to be a matter of lack of resources.

I have an Intel i5 750 Quad core @2.7GHz, 4 gig RAM and the 560Ti has 2gig on its own. Windows 7 64 bit.

When the games in question run at 1080i, with DX9, they are blazing fast at almost maxed out settings.

I have only found references in other forums of people with apparently the same problem, but no solutions. Thanks for giving it a shot, I still have hope. :) 

Have you tried with a different monitor or connection?
October 28, 2011 12:15:31 AM

What DX9 game lets you select an interlaced resolution?
October 28, 2011 12:32:18 AM

I have tried on a smaller, proper computer monitor and everything works fine, all resolutions are available.

My tv (that has the problem) has only HDMI so i have tried to connect to the graphics card through HDMI and DVI. No change at all.

TW:Shogun 2, Metro 2033 and DeusEx play fine at 1080i on DX9. I've just been playing BFBC2 too, but i'm not sure it has any DX10 or 11 features.
Thanks again!
October 28, 2011 2:09:41 AM

ilikephysics said:
I have tried on a smaller, proper computer monitor and everything works fine, all resolutions are available.

My tv (that has the problem) has only HDMI so i have tried to connect to the graphics card through HDMI and DVI. No change at all.

TW:Shogun 2, Metro 2033 and DeusEx play fine at 1080i on DX9. I've just been playing BFBC2 too, but i'm not sure it has any DX10 or 11 features.
Thanks again!

Yeah its most likely the lack of support to progressive scan at that resolution. Sorry you are having those issues, g'luck
October 28, 2011 10:54:35 AM

I appreciate you giving it a shot.

Can anyone think of a workaround for this problem? Surely there must be a way other than buying a new tv.
October 28, 2011 12:08:15 PM

you could try playing in 720p no? or does it look much worse then? I'm thinking dig around in NvCP maybe the card can convert the output (i doubt it though)
October 28, 2011 3:16:37 PM

you hace went into the display settings and set them to 1080@30hz (1080i) if its set at 1080@60hz its (1080p) if your using an hdmi cable you may have the upscaling issue, where your tv is expecting a 540p image which it can then upscale to 1080i but when it actually receives a popper 1080i signal it gets confused and produces a black screen...

so give this a try go into th display options / advanced click the monitor tab. if its set to 1080@60hz set it to 1080@30hz... if this results in a black screen then you can try unpicking "hide unsupported" and select 540p or 540@6hz then let the screen upscale rather than the gfx card.
if you have an nvidia card you may want to look in its control panel for simila options that will just affect the games you play not the o.s.
October 29, 2011 11:47:46 AM

Thank you both for the help.

Well 720p on a 42 inch display looks pretty bad. A waste of good hardware plus there are scaling issues on the screen at this resolution (overscan).

The screen actually produces black screen if I try to force 1080p at any Hz. The screen is definitely set at 1080i at 30Hz. There is no option anywhere in Nvidia CP or the OS Screen Resolution panel for 1920x540p unfortunately, even in all the Advanced Settings menus.

On the good side Battlefield 3 does not have this problem luckily. It allows me to choose 1080p at 60Hz and it plays normally (even though most obviously the output is 1080i at 30Hz).

Still all those other games will not allow any high resolutions on DX10 or 11. It seems to be the way they implement DX somehow. Any further help is greatly appreciated, I don't want to give up, there must be a solution.
October 29, 2011 9:19:37 PM

540p is not ever going to be 1920 wide, what hexit was saying is the tv probably can upscale to 1080i from a 540p signal (960x540)
October 29, 2011 9:27:59 PM

ilikephysics said:
Thank you both for the help.

Well 720p on a 42 inch display looks pretty bad. A waste of good hardware plus there are scaling issues on the screen at this resolution (overscan).

The screen actually produces black screen if I try to force 1080p at any Hz. The screen is definitely set at 1080i at 30Hz. There is no option anywhere in Nvidia CP or the OS Screen Resolution panel for 1920x540p unfortunately, even in all the Advanced Settings menus.

On the good side Battlefield 3 does not have this problem luckily. It allows me to choose 1080p at 60Hz and it plays normally (even though most obviously the output is 1080i at 30Hz).

Still all those other games will not allow any high resolutions on DX10 or 11. It seems to be the way they implement DX somehow. Any further help is greatly appreciated, I don't want to give up, there must be a solution.


What is the native resolution of your screen? 1368x768 pr similar? well thats the PC resolution you shoudl use for gaming on surely? thats 1:1 pixel:p ixel mapping.
October 29, 2011 11:36:07 PM

as far as i know there is a switch in the NVIDIA control panel. im sorry i cant point you to it. as i have an ati card.
but im sure some 1 here can point you in the rite direction...
in fact im pretty sure this kind of thing has been queried b4 here.
October 30, 2011 9:57:25 AM

Thank you all.

I see about the 540p. I really couldn't play at such low resolutions anyway. The screen is too big for that.

The native resolution of the screen is 1920x1080. But it can only do interlaced at that res.

I've done my best to play around with all the control panel settings, nothing seems to work. No hits anywhere on Google as well.

Its quite hard to google for a solution because it's hard to express the problem into a simple sentence and each person I found online with similar problems expressed it differently. Very few people have suspected it has to do with interlacing and DX10/11, though I'm quite sure by now.
October 30, 2011 11:35:43 AM

If you can't set it a different resolution then your LCD is running at a higher refresh rate. Do you have a driver install for your monitor or are you using the windows default one?
October 31, 2011 9:37:23 AM

I do not have a specific driver installed, I could not find one anywhere. My monitor is a 5 year old 42'' tv so support is pretty much non-existent for PC use.

Could you explain more about my "LCD is running at a higher refresh rate"? I do not understand the implication. My tv can definitely not do 60Hz at 1080. If it could, I think I wouldn't have this problem.
February 12, 2012 1:50:36 PM

make sure window is set at resolution you want (rightclick anywhere on computer screen,then if it is click on advanced parameter,select screen tab.make sure refresh rate is set to what you need.and also make sure your screen support said intended setting.there are free software for this online.also for those saying 1080i and 1080p work differently read first they generate image the same way where it differ is 1080i will do a full pass of even,then will do a pass of odds.1080p do a full pass of ods an even BUT ON THE SAME PATTERN AS 1080I.hope this help stop urban legend from sprouting!
February 12, 2012 2:29:00 PM

this thread is 4 months old.....
!