Sign in with
Sign up | Sign in
Your question
Closed

Witcher 2 on gtx 580

Last response: in Video Games
Share
November 6, 2011 6:23:28 AM

hello all,

i installed witcher 2 last night. I was hoping I will have 60fps consistent on ultra preset. Below are my specs.

core i5 2500k @3.3ghz
g-skill ripjaws X 1600 mhz 8gb
asus gtx 580 direct cu2

During battles in open areas with lots of enemies, frame rate is averaging at 40fps.

In closed areas, frame rate is locked at 60fps.

Btw, i have ubersampling disabled.

I don't think the video card is at fault because I switched to medium preset and experienced the same framerates.

Can you confirm if what I am experiencing is normal? I have the latest drivers from nvidia.

Thanks in advance.

More about : witcher gtx 580

Best solution

November 7, 2011 8:18:25 AM

Do you have the latest and most up-to-date patch for the game installed? If not, do so first. Witcher 2 is known for it's bad PC optimization, so less-than-optimal performance have been reported on even the strongest systems.
Share
November 7, 2011 8:33:57 AM

do you have ubersampling on cause it really pulls your fps down, my GTX570 Sli gives only 39 fps on avg, with all maxed and Usamp on. if i turn usamp off i get 94 fps Avg.....

so i think you must try turning it off.
and i think you card is perfect cause occasionally dips to 40 fps are present in most cards, with such demanding games,
Score
0
Related resources
November 7, 2011 9:29:13 AM

king game said:
do you have ubersampling on cause it really pulls your fps down, my GTX570 Sli gives only 39 fps on avg, with all maxed and Usamp on. if i turn usamp off i get 94 fps Avg.....

You know of course he specifically said that Ubersampling is turned OFF, right?
Score
0
December 10, 2011 8:47:40 AM

Best answer selected by hybr33d.
Score
0
!