Sign in with
Sign up | Sign in
Your question

Skyrim and Drivers

Last response: in Video Games
Share
November 11, 2011 7:59:33 PM

Currently trying to play Skyrim but after playing for anywhere from less than a minute to 2 hours my screen goes black and my monitor says it isn't receiving a signal. I believe that this is a graphics driver problem but haven't had any luck fixing it.

This same exact problem occurs with Fallout New Vegas when entering VATS. Also, while I'm lucky to play Skyrim for 30 minutes I can play Battlefield 3 on high settings until I ragequit.

I also used Hardware Monitor to take temperature readings.
While I'm typing this my graphics card is 96F (36C).
Loading up the exterior world of Skyrim and then closing puts me at ~155F (this is also roughly the same temperature that the card runs at for Battlefield 3).
Playing in an interior cell of Skyrim was ~140F.

Specs:
i5 2400 3.1GHz
AMD Radeon HD 6870
8GB RAM
All drivers up-to-date
(Can post more if needed)

Solutions tried so far:
Putting it on low.
Disabling Steam Overlay.
Rolling back AMD drivers from 11.10 to 11.9

More about : skyrim drivers

November 11, 2011 8:11:34 PM

What is your power supply??
m
0
l
November 11, 2011 8:14:54 PM

I can't remember exactly, but I believe its is 750W or above. And in case you were wondering: no, nothing is overclocked.
m
0
l
Related resources
November 12, 2011 2:08:02 PM

mornal said:
Currently trying to play Skyrim but after playing for anywhere from less than a minute to 2 hours my screen goes black and my monitor says it isn't receiving a signal. I believe that this is a graphics driver problem but haven't had any luck fixing it.

This same exact problem occurs with Fallout New Vegas when entering VATS. Also, while I'm lucky to play Skyrim for 30 minutes I can play Battlefield 3 on high settings until I ragequit.

I also used Hardware Monitor to take temperature readings.
While I'm typing this my graphics card is 96F (36C).
Loading up the exterior world of Skyrim and then closing puts me at ~155F (this is also roughly the same temperature that the card runs at for Battlefield 3).
Playing in an interior cell of Skyrim was ~140F.

Specs:
i5 2400 3.1GHz
AMD Radeon HD 6870
8GB RAM
All drivers up-to-date
(Can post more if needed)

Solutions tried so far:
Putting it on low.
Disabling Steam Overlay.
Rolling back AMD drivers from 11.10 to 11.9



I have similar specs

i5-2500k
AMD Radeon HD 6950
8GB RAM
Current drivers (11.10)
750 watt power
Windows 7 64bit

and mine will stutter and freeze no matter what setting and res I use. Eventually the whole game crashes and I receive a notice that the video driver has crashed and been restarted or some such thing so I think the problem is simply AMD dropped the ball on releasing a performance driver for this game (like Nvidia was kind enough to do for their customers on 11/10, and from what I've heard they have no problems playing Skyrim). Now the waiting game begins for AMD's updated driver to come out...
m
0
l
November 12, 2011 9:39:07 PM

yeah AMD is behind on drivers, I think as of yesterday there was no driver for crossfire for skyrim
m
0
l
November 12, 2011 10:18:25 PM

mornal said:
Currently trying to play Skyrim but after playing for anywhere from less than a minute to 2 hours my screen goes black and my monitor says it isn't receiving a signal. I believe that this is a graphics driver problem but haven't had any luck fixing it.

This same exact problem occurs with Fallout New Vegas when entering VATS. Also, while I'm lucky to play Skyrim for 30 minutes I can play Battlefield 3 on high settings until I ragequit.

I also used Hardware Monitor to take temperature readings.
While I'm typing this my graphics card is 96F (36C).
Loading up the exterior world of Skyrim and then closing puts me at ~155F (this is also roughly the same temperature that the card runs at for Battlefield 3).
Playing in an interior cell of Skyrim was ~140F.

Specs:
i5 2400 3.1GHz
AMD Radeon HD 6870
8GB RAM
All drivers up-to-date
(Can post more if needed)

Solutions tried so far:
Putting it on low.
Disabling Steam Overlay.
Rolling back AMD drivers from 11.10 to 11.9


I am currently running on a 5770 with 11.9 drivers and the game is smooth, no artifacts, screen flickering or anything else. Game resolution is 1920x1080, 55-60 FPS, all details on High, no AF, no AA.
m
0
l
November 13, 2011 7:12:26 AM

Just a heads up here. This issue does not appear to be ATI related as I have a 9800 GTX+ and am experiencing this issue as well. It's crazy annoying to be crashing/blacking out in a game this fun. Get about 15 mins. of game time, then screen freezes, blacks out for a sec, recovers. After about 4 or 5 of these, crashes to the desktop with the driver error.
m
0
l
November 13, 2011 11:49:43 PM

i have no crash/graphical issues running 11.10 and a 6850, i dont think its the AMD drivers, maybe just an incompatability with some systems. A game dev cant account for every combination of hardware/software prior to release of their software, im surer therre will be a fix for your issues soon. There are plenty of people playing happily with AMD cards.
m
0
l
November 14, 2011 7:09:50 AM

Same problem here with a Nvidia Gforce GTS250
m
0
l
November 14, 2011 9:46:18 AM

i have the exact same problem

amd 3.1 dual core
4gigs of ram
have HD6870
650w corsair psu
150gig raptor hdd

crashes 30mins-3hours screen goes black, then hear a repeating sound and then i power off the computer.

only problem is today it seems to happen every 5 mins. it NEVER crashes when in a dungeon, ever. only in the world.

also i have tried running on High - Med - Low with same results, and it stutters a bit on all of them except when i really put it high up there it begins to lag, but it crashes the same on all settings. makes no difference.

an quite pissed am thinking of asking for a refund for the game on steam.

FYI there is a very large thread about this here:
http://www.thenexusforums.com/index.php?/topic/456889-s...
m
0
l
November 15, 2011 12:16:21 PM

Its a Bethdesia game; of course it has significant stability problems. I STILL can't play FO3 because it crashes...on three seperate PC's...

Bethdesia's code must be horrendous, because every game they put out has massive stability problems.
m
0
l
November 15, 2011 1:50:33 PM

I have a pair of 9600 gts and once in a while in the open world I will lock up, but it has always managed to recover after a minute or two.
m
0
l
November 15, 2011 5:24:52 PM

I've been playing Skyrim a lot. And following the Skyrim Bethesda forums. Lots of folks are having CTD issues, but I have not seen anyone having their monitor shut off. That doesn't scream driver error to me. Sounds more hardware.

Folks having the CTD issue generally find this fix works:
http://forums.bethsoft.com/index.php?/topic/1255753-upd...

It involves switching Window's audio settings to 24bit 44100mhz (not 48000mhz). Worked for me and my wife's system. That forum thread is a Sticky posted by Bethesda Moderators.
m
0
l
November 15, 2011 10:04:44 PM

jerreece said:
I've been playing Skyrim a lot. And following the Skyrim Bethesda forums. Lots of folks are having CTD issues, but I have not seen anyone having their monitor shut off. That doesn't scream driver error to me. Sounds more hardware.

Folks having the CTD issue generally find this fix works:
http://forums.bethsoft.com/index.php?/topic/1255753-upd...

It involves switching Window's audio settings to 24bit 44100mhz (not 48000mhz). Worked for me and my wife's system. That forum thread is a Sticky posted by Bethesda Moderators.
Interesting fix, I will have to try this. My copy runs fanstastic but only in Window mode even set to Ultra. When I try full screen it just black screens on me and crashes hard. Oddly it appears to do it right as the sound comes on so this may be the issue. I run 3 monitors in vision surround so that is another possible issue altogether. I have gotten so used to the window mode that I don't miss the full view that much anymore.
m
0
l
November 15, 2011 11:38:17 PM

jerreece said:
I've been playing Skyrim a lot. And following the Skyrim Bethesda forums. Lots of folks are having CTD issues, but I have not seen anyone having their monitor shut off. That doesn't scream driver error to me. Sounds more hardware.

Folks having the CTD issue generally find this fix works:
http://forums.bethsoft.com/index.php?/topic/1255753-upd...

It involves switching Window's audio settings to 24bit 44100mhz (not 48000mhz). Worked for me and my wife's system. That forum thread is a Sticky posted by Bethesda Moderators.

i dont have the issue, but then again, im using a dedicated sound card SB Audigy 4.
m
0
l
November 16, 2011 11:31:31 AM

I don't have that problem either, only using integrated sound (w/e comes on the hm65e)
m
0
l
November 17, 2011 12:29:02 PM

Hey i got a CF iccue, my FPS is down to 20 and up to 60.. Do anyone now where i turn Vsynk off, The game shuld run´╗┐ smoth, really smoth :)  BTW i run on High settings, CCC 11.11. 1920x1080 Thx

AMD Phenom II X4 980 Black Edition OC 4.2Ghz
Zalman CNPS9900 NT
ASUS Crosshair IV Formula, Socket-AM3
Corsair XMS3 Vengeance DDR3 PC16000/2000MHz CL10 4x2GB
XFX Radeon HD6870 HDMI Dual-DisplayPort Dual-DVI 1GB
XFX Radeon HD6870 HDMI Dual-DisplayPort Dual-DVI 1GB
Corsair CMPSU-750TX 750W
m
0
l
November 17, 2011 3:31:18 PM

if vsync is not forced thru CCC then check grphx settings in-game.
Although, I believe, you're recommended to keep vsync on for SLI/CF setups
m
0
l
November 17, 2011 8:45:38 PM

mornal said:
Currently trying to play Skyrim but after playing for anywhere from less than a minute to 2 hours my screen goes black and my monitor says it isn't receiving a signal. I believe that this is a graphics driver problem but haven't had any luck fixing it.


Could be a power management setting -- try turning off any power saving settings and see if it still happens ( I know my system was shutting down during video playback when watching movies on the system because it thought the system was sitting idle and would shut down the monitor until I turned off the setting)
m
0
l
November 17, 2011 9:53:51 PM

They don't have a "disable Vsync" setting in the settings list for the game. You have to edit the .ini config file in the Skyrim folder. Lemme find the link that explains the process...

Here we go:

"Go to your Steam Directory, then steamapps, common, skyrim and select Skyrim again. Create a backup of the SkyrimPrefs.ini file. Open the file and add iPresentInterval=0 to the bottom of the [Display] section. This can improve a sluggish framerate and eliminate instances of mouse lag."


Also, whenever you think you might be experiencing graphics problems with a new game, make sure to check your Catalyst Control Center settings (or Nvidia's equivalent, for I know not what it is called). Those settings can override the settings of game software (such as Vsync on or off, or anti-aliasing settings, etc, when you uncheck (Use application settings) checkbox. I had a problem with this in Starcraft 2. I thought my system couldn't run it on max settings, 'cause I kept having crappy framerate issues. Even when I turned the settings in-game down to low! But, it turns out it was some of my CCC settings overriding Starcraft 2's settings, and the game was not happy with them at all.

Also also, as was suggested above, there seems to be an audio setting fix in Windows for some problems with Skyrim. SOMEtimes, when you think you're having a graphics issue, it's actually an audio issue. You can always try disabling all game sound and playing the game that way to see if you have any problems. If all your issues go away, then start with trying to update your audio driver (maybe even clean install), and searching for audio-related issues on forums such as these.
m
0
l
November 17, 2011 10:06:21 PM

MundoDragon said:
Just a heads up here. This issue does not appear to be ATI related as I have a 9800 GTX+ and am experiencing this issue as well. It's crazy annoying to be crashing/blacking out in a game this fun. Get about 15 mins. of game time, then screen freezes, blacks out for a sec, recovers. After about 4 or 5 of these, crashes to the desktop with the driver error.



I have the exact same card and I'm having this issue as well. I've been minimizing it, but it still hits me once in a while.
m
0
l
November 17, 2011 11:51:52 PM

Lephys said:
They don't have a "disable Vsync" setting in the settings list for the game. You have to edit the .ini config file in the Skyrim folder. Lemme find the link that explains the process...

Here we go:

"Go to your Steam Directory, then steamapps, common, skyrim and select Skyrim again. Create a backup of the SkyrimPrefs.ini file. Open the file and add iPresentInterval=0 to the bottom of the [Display] section. This can improve a sluggish framerate and eliminate instances of mouse lag."


Also, whenever you think you might be experiencing graphics problems with a new game, make sure to check your Catalyst Control Center settings (or Nvidia's equivalent, for I know not what it is called). Those settings can override the settings of game software (such as Vsync on or off, or anti-aliasing settings, etc, when you uncheck (Use application settings) checkbox. I had a problem with this in Starcraft 2. I thought my system couldn't run it on max settings, 'cause I kept having crappy framerate issues. Even when I turned the settings in-game down to low! But, it turns out it was some of my CCC settings overriding Starcraft 2's settings, and the game was not happy with them at all.

Also also, as was suggested above, there seems to be an audio setting fix in Windows for some problems with Skyrim. SOMEtimes, when you think you're having a graphics issue, it's actually an audio issue. You can always try disabling all game sound and playing the game that way to see if you have any problems. If all your issues go away, then start with trying to update your audio driver (maybe even clean install), and searching for audio-related issues on forums such as these.


Actually that is the wrong copy of the Skyrimprefs.ini -- the one you want to edit is located in the My Documents\My Games\Skyrim\ folder ! And the setting is already there so you want to change it from =1 to =0 instead of adding it.
m
0
l
November 18, 2011 12:13:51 AM

My bad. That was an excerpt from another forum.
m
0
l
November 18, 2011 8:30:56 PM

JDFan said:
Actually that is the wrong copy of the Skyrimprefs.ini -- the one you want to edit is located in the My Documents\My Games\Skyrim\ folder ! And the setting is already there so you want to change it from =1 to =0 instead of adding it.

Thx for helping, i will test it now and replay som results :) 
m
0
l
November 18, 2011 8:33:30 PM

Lephys said:
My bad. That was an excerpt from another forum.

Np mate, almost right ;)  will try the game now and get you all the result later :-)
m
0
l
November 18, 2011 10:09:56 PM

This exact same thing is happening to me, on a 6850. Let me know if you get it fixed please :) 

dentjunk said:
I have similar specs

i5-2500k
AMD Radeon HD 6950
8GB RAM
Current drivers (11.10)
750 watt power
Windows 7 64bit

and mine will stutter and freeze no matter what setting and res I use. Eventually the whole game crashes and I receive a notice that the video driver has crashed and been restarted or some such thing so I think the problem is simply AMD dropped the ball on releasing a performance driver for this game (like Nvidia was kind enough to do for their customers on 11/10, and from what I've heard they have no problems playing Skyrim). Now the waiting game begins for AMD's updated driver to come out...

m
0
l
November 18, 2011 10:13:27 PM

I've had that problem before, in other games. I want to say Starcraft 2 did it for a little while. I think I just fixed it by completely wiping every trace of an ATI driver (and Catalyst and all that jazz) off my system, even cleaning the registry, then re-installing the newest driver. Of course, that might not be the case here, but I have had the very same crashing and that same message occur with other games.
m
0
l
November 19, 2011 8:53:17 AM

Lephys said:
I've had that problem before, in other games. I want to say Starcraft 2 did it for a little while. I think I just fixed it by completely wiping every trace of an ATI driver (and Catalyst and all that jazz) off my system, even cleaning the registry, then re-installing the newest driver. Of course, that might not be the case here, but I have had the very same crashing and that same message occur with other games.

ty i will test the thing u said :) 
The fps increace by 5-10 without Vsynk, but i still feel som lagg i the grafic :( 
m
0
l
November 19, 2011 9:05:42 AM

Eldd said:
I am currently running on a 5770 with 11.9 drivers and the game is smooth, no artifacts, screen flickering or anything else. Game resolution is 1920x1080, 55-60 FPS, all details on High, no AF, no AA.



OMG, can you PLEASE link me to the part on the site you got the drivers!? I have the same cardI believe. It is the XFX Radeon HD 5770. I THINK that my game will not play because of this very reason, crashes! I would be VERY grateful!


I tried to update drivers for my GPU, but I think that perhaps I did not install them correctly. I have version: 8.911.0.0

Sorry if I was not supposed to ask this here!
m
0
l
November 19, 2011 2:43:52 PM

lncognito said:
OMG, can you PLEASE link me to the part on the site you got the drivers!? I have the same cardI believe. It is the XFX Radeon HD 5770. I THINK that my game will not play because of this very reason, crashes! I would be VERY grateful!


I tried to update drivers for my GPU, but I think that perhaps I did not install them correctly. I have version: 8.911.0.0

Sorry if I was not supposed to ask this here!



Here's the link for video drivers previous to 11.11.


http://support.amd.com/us/gpudownload/windows/previous/...
m
0
l
November 19, 2011 3:09:48 PM

The 5770 is running the game pretty well, especially for a single slot card. I've been getting solid 40 fps performance on Ultra with the FXAA post-process injector mod and a couple other graphic enhancing mods I found. I find it funny that this generation-old card from their budget-performance line is outperforming some of the performance cards of the 6-series. :p 
m
0
l
November 19, 2011 3:54:10 PM

Ridonk said:
The 5770 is running the game pretty well, especially for a single slot card. I've been getting solid 40 fps performance on Ultra with the FXAA post-process injector mod and a couple other graphic enhancing mods I found. I find it funny that this generation-old card from their budget-performance line is outperforming some of the performance cards of the 6-series. :p 


Indeed, this card is performing so well in most games, at high resolutions. It's still amazing to me, hope the new one I'll be upgrading to (the 6950) will not be a let down. I know it shouldn't, but I've read of so many people having issues with that series.
m
0
l
November 19, 2011 9:37:04 PM

Hd6870 is great as singel card, cf is the problem :/  I upgraded from a xfx hd5770 card, and the 6870 is a stronger card i feel, but iccues with drivers is really ignoring btw... may take the second card out of the box and run singel insted ***.. :( 
m
0
l
November 19, 2011 10:17:50 PM

mornal said:
Currently trying to play Skyrim but after playing for anywhere from less than a minute to 2 hours my screen goes black and my monitor says it isn't receiving a signal. I believe that this is a graphics driver problem but haven't had any luck fixing it.

This same exact problem occurs with Fallout New Vegas when entering VATS. Also, while I'm lucky to play Skyrim for 30 minutes I can play Battlefield 3 on high settings until I ragequit.

I also used Hardware Monitor to take temperature readings.
While I'm typing this my graphics card is 96F (36C).
Loading up the exterior world of Skyrim and then closing puts me at ~155F (this is also roughly the same temperature that the card runs at for Battlefield 3).
Playing in an interior cell of Skyrim was ~140F.

Specs:
i5 2400 3.1GHz
AMD Radeon HD 6870
8GB RAM
All drivers up-to-date
(Can post more if needed)

Solutions tried so far:
Putting it on low.
Disabling Steam Overlay.
Rolling back AMD drivers from 11.10 to 11.9



I noticed that nobody has mentioned this so I will. This fix was for games that were crashing during the intro but it may work for you since it fixed my gf's computer from crashing. Adjust your sound to 44.1 khz, 24 bit in your sound settings.
m
0
l
November 19, 2011 11:06:44 PM

I found a decent fix. Download the enbseries patch for Skyrim and just extract it into the Skyrim folder in the steam directory. Link: http://enbdev.com/download_en.htm

Still have the occasional crash, but I've been able to play for hours without one.
m
0
l
November 20, 2011 12:51:53 AM

I'm not sure if the mods attribute to my stability but it certainly makes the game very nice to look at. (no more blocky faces, detailed faces v2, FXAA post process injector at preset 2, enhanced blood textures, detailed bodies, vurt's skyrim flora overhaul, and high quality eyes. All of these are available at Skyrim Nexus) I've been running these about 40 hours of the 56 hours I've put into the game. Give them a try. I run AA on 2x, AF on 8x, decals ultra, everything else on high except blur on medium.
m
0
l
November 20, 2011 9:37:06 AM

Eldd said:
Here's the link for video drivers previous to 11.11.


http://support.amd.com/us/gpudownload/windows/previous/...


Thank you! If I may ask one more question... It is not allowing me to run in full window, just windowed mode. It says something about a rendering issue ( I created a thread about it actually). Any thoughts??
m
0
l
November 20, 2011 12:03:46 PM

lncognito said:
Thank you! If I may ask one more question... It is not allowing me to run in full window, just windowed mode. It says something about a rendering issue ( I created a thread about it actually). Any thoughts??

Go to option befor you start the game and check out the window mode option :) 
m
0
l
November 20, 2011 1:09:16 PM

lncognito said:
Thank you! If I may ask one more question... It is not allowing me to run in full window, just windowed mode. It says something about a rendering issue ( I created a thread about it actually). Any thoughts??


IF it is a Failed to initialize renderer error that usually means that you set a resolution that the system thinks your monitor does not support - make sure the setting you are using is actually supported by your monitor and if you can find an .inf file (monitor driver file from the manufacturer) for you monitor so that windows has the capabilities of it (the .inf file tells windows what your monitor supports - and not using the one for your specific monitor will have windows use a generic one that may not support all of the resolutions that you monitor does - but it is getting hard to find some of them since manufacturers think the windows OS ones are useable instead of them providing specific ones for each monitor.
m
0
l
November 20, 2011 8:59:42 PM

lncognito said:
Thank you! If I may ask one more question... It is not allowing me to run in full window, just windowed mode. It says something about a rendering issue ( I created a thread about it actually). Any thoughts??


This isn't really a fix but a workaround to your issue. Hopefully this will let you play Skyrim and play in pseudo full screen mode

simple borderless window

http://www.skyrimnexus.com/downloads/file.php?id=4
m
0
l
!