Sign in with
Sign up | Sign in
Your question

auto defrag

Last response: in Windows XP
Share
Anonymous
December 11, 2004 12:51:11 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Hi
I'm not sure how it got activated but whenever I leave my PC idle for about
5 mins the hard disk starts defragmenting in the backround. I know this
because I've called up the Task Manager and can see defrag.exe running in the
list.
How can I turn this automatic defragmenting off? I've looked in scheduled
tasks etc but cannot find it anywhere.
It's strange that it has only been apparent for a couple of weeks, before
that it did not occur.
It's not a massive problem or anything - I'd just like to know how to turn
it off.

Thanks

More about : auto defrag

Anonymous
December 11, 2004 6:17:17 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

That's Windows XP doing partial defragmentation in the background. It's for
your benefit - you don't want to stop it. It doesn't get in the way of
anything you do with your computer, and it won't slow it down.

Put another way: If your hardware is so old that XP's background defrags are
hurting your performance, it's time for a new computer!

Ted Zieglar

"Panzer_Dan" <Panzer_Dan@discussions.microsoft.com> wrote in message
news:A55FB90E-F335-44D8-ADEC-1152E409BE29@microsoft.com...
> Hi
> I'm not sure how it got activated but whenever I leave my PC idle for
> about
> 5 mins the hard disk starts defragmenting in the backround. I know this
> because I've called up the Task Manager and can see defrag.exe running in
> the
> list.
> How can I turn this automatic defragmenting off? I've looked in scheduled
> tasks etc but cannot find it anywhere.
> It's strange that it has only been apparent for a couple of weeks, before
> that it did not occur.
> It's not a massive problem or anything - I'd just like to know how to turn
> it off.
>
> Thanks
Anonymous
December 12, 2004 11:53:36 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

This is part of the Prefetching process. Prefetching is a good thing.

Optimizing Startup Times by Using Defragmentation Tools
http://www.microsoft.com/resources/documentation/Window...

Idle Task Scheduling: The ProcessIdleTask API
http://www.microsoft.com/whdc/system/sysperf/benchmark....

Hard Disks Do Not Turn Off After Your Computer Has Been Idle
http://support.microsoft.com/kb/Q313300

This command, typed in a command prompt, forces the optimization:
Rundll32.exe advapi32.dll,ProcessIdleTasks

If the disk is NTFS, defrag.exe and dfrgntfs.exe run.
----

I don't know why you'd want to turn it off.

To turn it off you need TweakUI or you have to adjust a setting in the
registry.

TweakUI
[+] General
Unselect: ? Optimize hard disk when idle

Optimize hard disk when idle
[[This allows Windows to rearrange files on the hard disk when the computer
is not in use to improve performance. This is a system wide setting which
requires a restart for changes to take effect.]]
----

Download TweakUI here >>>

Microsoft PowerToys for Windows XP
http://www.microsoft.com/windowsxp/pro/downloads/powert...

Tweak UI
TweakUI.exe
===

Tweak UI for Windows XP Guide
http://www.winxpsolution.com/Tweakuixppro.aspx

----

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory
Management\PrefetchParameters

Values for EnablePrefetcher are:
0 - no prefetch
1 - prefetch applications only
2 - prefetch boot only
3 - prefetch both applications & boot (default)

How to Disable the Prefetcher Component in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;307498

--
Hope this helps. Let us know.
Wes

In news:A55FB90E-F335-44D8-ADEC-1152E409BE29@microsoft.com,
Panzer_Dan <Panzer_Dan@discussions.microsoft.com> hunted and pecked:
> Hi
> I'm not sure how it got activated but whenever I leave my PC idle for
> about 5 mins the hard disk starts defragmenting in the backround. I
> know this because I've called up the Task Manager and can see
> defrag.exe running in the list.
> How can I turn this automatic defragmenting off? I've looked in
> scheduled tasks etc but cannot find it anywhere.
> It's strange that it has only been apparent for a couple of weeks,
> before that it did not occur.
> It's not a massive problem or anything - I'd just like to know how to
> turn it off.
>
> Thanks
!