Sign in with
Sign up | Sign in
Your question

Starcraft 2 low gpu useage?

Tags:
  • PC gaming
  • GPUs
  • FPS
  • Starcraft 2
  • Video Games
Last response: in Video Games
Share
November 16, 2011 1:02:02 AM

why dos starcraft only use 50 gpu while im gaming and its only giving me 14 fps when maxed out sometimes.
i have a gtx 580 and a phenom 2 x4 at 3.8 so i think i should be getting 60 fps.
software driver issue?

More about : starcraft low gpu useage

November 16, 2011 5:26:58 AM

Which resolution are you playing at?
m
0
l
November 16, 2011 4:13:06 PM

Herr_Koos said:
Which resolution are you playing at?


1680x1050 everything turned on and maxed native res.
m
0
l
Related resources
November 16, 2011 5:36:27 PM

what do you mean by "maxed out sometimes" ? fps occasionally drops to 14? what is it the rest of the time?

what exactly is "everything turned on"?

when was last time you updated your drivers?

my guess is 580 doesn't need to go above 50% utilization to do SC2 @ 1680x1050

SC2 is a lot more intensive on the CPU when you maxing everything, so I think your phenom might be the culprit here

over here:
http://www.tomshardware.com/reviews/best-gaming-cpu-cor...
seems that cpu can only handle up to 30fps @1080p
m
0
l
November 17, 2011 12:34:15 PM

AntiZig said:
what do you mean by "maxed out sometimes" ? fps occasionally drops to 14? what is it the rest of the time?

what exactly is "everything turned on"?

when was last time you updated your drivers?

my guess is 580 doesn't need to go above 50% utilization to do SC2 @ 1680x1050

SC2 is a lot more intensive on the CPU when you maxing everything, so I think your phenom might be the culprit here

over here:
http://www.tomshardware.com/reviews/best-gaming-cpu-cor...
seems that cpu can only handle up to 30fps @1080p



+1 ...what he said.
m
0
l
November 18, 2011 8:53:37 AM

set all graphics settings to mid level. keep the resoluton as it is. then depend on the FPS count u get ,you should be able to decided which settings should be maxed and which are not.
m
0
l
!