Sign in with
Sign up | Sign in
Your question
Closed

Skyrim-stuttering in firstperson view.

Last response: in Video Games
Share
November 16, 2011 1:08:23 PM

I'm getting a consistent 60fps and everything looks great, however there are certain moments in the game when I'm looking around or fighting when the games starts to stutter a bit. There's no slowdown, just as though the screen were skipping a few frames. I'm using an Xbox 360 controller, so I know it's not my mouse. Weird thing is, when I switch to third person view, the stutter is gone, and everything runs perfectly smooth at all times.

Any fix for this?
November 16, 2011 3:46:27 PM

ive had same issue with mine - using a mouse then it randomly goes away
Score
0
November 16, 2011 3:54:01 PM

probably not, your CPU is sometimes busy with background tasks that slow its work on the game and seeing how skyrim is very picky about processor speed you see that as a slow down/stutter
Score
0
November 17, 2011 7:51:30 PM

I have the same issue and I'm trying to fix it. I'm also using a 360 controller and its butter smooth in 3rd person. I have an i7 920 overclocked to 3.8ghz too...so I don't think its my CPU at all... sigh! Maybe it's just the game?
Score
0
November 17, 2011 8:23:09 PM

Does it ever happen if you're just running straight at a cliff wall or something? Or does it only seem to happen when you're turning, or looking around, or progressing down a road (times during which a varying amount of stuff is being rendered into closer, more detailed view as you go)?

A lot of times when you seem to get little negative spikes in framerate, it's the simple fact that your graphics card and CPU are handling everything smoothly for the time being, but then they have a quick, tiny struggle when new things change (you spin completely around, or 7 bandits run out and start performing various animations, etc.). It's kind of like juggling. Once you get a few items into a rhythm, they're juggled smoothly, but if someone tossed you 3 new things all of the sudden, you might have a little difficulty catching those and keeping the rhythm going smoothly. Except, you know... with GPU's and CPU's, and pixel data and software code. 8P
Score
0
November 17, 2011 9:22:56 PM

Ya, i usualy get the stutters when i'm just looking around..

here are my specs if its any help:

XFX Radeon 6870
i5 2500k @ 3.3 Ghz
4gb rams.

I see people with the same set up as mine running the game smoothly.
Score
0
November 17, 2011 9:43:21 PM

Only other thing I know if is the anti-aliasing and anisotropic filtering problem, unless they fixed it. Basically, the game auto-detected my system at ultra settings, but when I loaded the game, it was very stuttery. WAY worse than what you're describing, though. So, I lowered it to High settings, but then I still had some pretty decent stutters going on (but a playably smooth framerate). Well, I found that that SOME people with ATI cards, at least, are experiencing some problems (it seems to vary as to the actual specifics of the problems) that are fixed by turning anti-aliasing and anisotropic filtering completely off in the game's graphics settings drop-down menus. I did that, and now I can run it on ultra without a hitch. I still get little tiny stutters here and there, but I think that's really just my slightly old and not-quite top-of-the-line PC having a tiny bit of difficulty here and there for a split second whenever it's rendering something new. I barely notice them.

How much VRAM is on that card? It MIGHT be possible that at maxed out settings, your system is running out of VRAM and having to use slower methods to swap out the graphics info. *shrug* Something along those lines. No matter how amazing your graphics card and processor are, your RAM can only store so many textures, etc, for rendering, at a time.
Score
0
November 17, 2011 10:03:50 PM

I'm not sure if it will or not. I don't know enough about that fix. I suppose it could.

I apologize if I missed it, but have you tried turning the anti-aliasing and anisotropic filtering off?


"Simply open the tool and select TESV.exe in your Skyrim folder (Steam\steamapps\common\skyrim), tick Large Address Aware Flag and then click Save.

As a final tweak, I recommend you edit Skyrim.ini (found in Documents\My Games\Skyrim) to add the following under [Papyrus]:
iMinMemoryPageSize=100000
iMaxMemoryPageSize=5000000
iMaxAllocatedMemoryBytes=1800000000"


That's totally worth a shot. Just copy that .ini file somewhere before you do it, so if it doesn't work you can just swap the original file back into the folder.
Score
0
November 17, 2011 10:08:24 PM

Lephys said:
I'm not sure if it will or not. I don't know enough about that fix. I suppose it could.

I apologize if I missed it, but have you tried turning the anti-aliasing and anisotropic filtering off?


No, i have not done that yet, i will try it and see if it works.
Score
0
November 18, 2011 8:40:22 PM

Sorry, I realize my last post was potentially quite confusing. That quoted bit was me referencing that link you posted (to that specific solution). I was just saying that that was probably quick and easy to try.

Turning off anti-aliasing and anisotropic filtering is simply done in the Options/Settings in the main menu (after you launch Skyrim but haven't actually clicked "Play").

And sorry if you knew all that already and weren't at all confused. I just wanted to correct my post.
Score
0
November 19, 2011 5:14:45 PM

I have the same issues. I am beeting that everyone with this issue is also running an ATI video card. I say this because other games that I play have a setting to fix "ATI stuttering" and since this game does not have this setting it's my (very uneducated) guess that this is our problem. Please let me know if there are any people running Nvidia cards with this stuttering in Skyrim. Or if there is a fix for it...

Rig: i5 2500k/ ATI 6970/ 8GB ram/ Logitech G500 mouse set to highest sensitivity on the actual mouse (level 3 of 3)

Oh yeah it only happens to me in first person view as well.
Score
0
November 20, 2011 5:18:19 PM

try this. http://www.techpowerup.com/forums/showthread.php?t=1125...
Large address aware

If you are using a mouse, use this.

Here's the fix:

Launch a Windows Explorer window (win key + e)
Navigate to \Program Files\Steam\steamapps\common\skyrim\Skyrim
Open SkyrimPrefs.ini in Notepad.
Locate [Controls] and then find 'bMouseAcceleration=1'
Change bMouseAcceleration=1 to bMouseAcceleration=0 instead; this will disable "mouse smoothing" and "mouse acceleration" in Skyrim.
Score
0
November 20, 2011 7:58:49 PM

Tekmage, you're a wizzard! That did it. Cheers man!
Score
0
November 20, 2011 11:30:16 PM

can you tell me what this mouse acceleration do? I haven't had problems but I'm thinking it might help since the mouse feels a bit laggy
Score
0
November 20, 2011 11:41:03 PM

AntiZig said:
can you tell me what this mouse acceleration do? I haven't had problems but I'm thinking it might help since the mouse feels a bit laggy


The degree it affects you is going to depend on your mouse as all mice act differently. I have a Razor Diamondback and it is very responsive so I have a tendency to drop down the speed of it. Acceleration is something that a lot of gamers aren't even aware of and they need to be because it can result in inconsistent behaviour with their mouse. Put simply, acceleration increases the speed of your mouse cursor based on the speed you move your mouse. This might sound like a good idea but it causes problems - if you move your mouse from point A to point B then you'd expect your cursor to do the same thing each time you move the mouse between those two points; with acceleration enabled it won't because you'll vary the speed that you move the mouse between those two points and end up with inconsistent aiming. Good example of this is something that you see in the mouse control panel. It's called "pointer precision". This is essentially Microsoft's version of mouse acceleration and can cause problems in games. It's handy for use in windows when you are flipping through your apps but not for gaming for the above reason given.

Score
0
November 21, 2011 3:19:02 PM

mouses act differently with this because of the different polling rates. ok, this helps, thanks.
Score
0
November 21, 2011 10:20:35 PM

space oddity said:
I'm getting a consistent 60fps and everything looks great, however there are certain moments in the game when I'm looking around or fighting when the games starts to stutter a bit. There's no slowdown, just as though the screen were skipping a few frames. I'm using an Xbox 360 controller, so I know it's not my mouse. Weird thing is, when I switch to third person view, the stutter is gone, and everything runs perfectly smooth at all times.

Any fix for this?


Strange, I could swear that I wrote this same exact thing on another forum... :o 

Anyway, the fix I found was to run it in windowed mode. There is a mod that actually will remove the tool bar from the window and force Skyrim to play in fullscreen while windowed.
Score
0
November 21, 2011 10:27:50 PM

That's really odd... Windowed mode is usually MORE taxing, since, even if it's maximized, it's treating the game as a mere object in the desktop space rather than a dedicated full usage of ALL the desktop space like in fullscreen mode.

I'm not denying that it works. I just think that's weird. 8P
Score
0
November 21, 2011 10:47:38 PM

Lephys said:
That's really odd... Windowed mode is usually MORE taxing, since, even if it's maximized, it's treating the game as a mere object in the desktop space rather than a dedicated full usage of ALL the desktop space like in fullscreen mode.

I'm not denying that it works. I just think that's weird. 8P


Yeah it's not a performance issue. It's just a strange optimization issue.

And by the way thanks for copying and pasting my original post: http://www.overclock.net/t/1167717/skyrim-stuttering-in... ;) 

Anyway, try it out. The strange stutter in first person view goes away when I implemented windowed mode.
Score
0
November 23, 2011 2:15:31 PM

Im having a similar issue. Im running the game on a desktop and a laptop (using the XBOX controller on both). The desktop runs it perfectly. It has an SB i5 2500k @ 4.2 Ghz, GTX 570, and 8GB or DDR3 Ram. The laptop is a brand new XPS 17 (l702x) with SB i7 2670qm @ 3.2 Ghz with turbo boost, GT 555 GPU, and 8GB of DDR3 ram. The laptop can run it near max but I get the stuttering issue as discribed here only when im inside buildings, castles, dungeons ect. Out in the open is smooth. Weird huh?
Score
0
December 7, 2011 4:38:45 AM

If you are having this mouse stutter issue but it doesn't effect 3rd person view, IT DOES NOT HAVE ANYTHING TO DO WITH PERFORMANCE. You're rendering more in 3rd person than 1st so there's nothing logical about the performance association that's been theorized. Don't bother tweaking your game settings or throwing the 4GB switch unless you've extinguished the options below first.

a) Seems plenty of people were able to solve this problem by changing bMouseAcceleration=1 to bMouseAcceleration=0 in SkyrimPrefs.ini, so try that first. Even if that doesn't help, just leave it that way because mouse acceleration sucks anyway (it makes your cursor move faster the further you move it, which means you're not getting 1:1 transference of movement between your hand and avatar). Also you might as well go to Control Panel > Mouse > Pointer Options and uncheck 'Enhanced Point Precision', which is the same thing but applied to the OS.

b) If that doesn't work to fix the stutter, change the game to Windowed mode and test it again; this is what fixed it for me. Don't worry about the off-center window until you've tested to see if that helps. If it fixes it, download the Simple Borderless Window mod which has the fringe benefit of making alt-tab work better:

http://skyrimnexus.com/downloads/file.php?id=4#content

If those two things don't fix it then you don't have the same problem this thread is referring to. But to help with perf, turn down shadows and anti-aliasing for the biggest initial gains (you can completely disable AA and check the FXAA box for alternative anti-aliasing that looks just fine). You may also want to tweak various viewing distance options, but honestly that's an awful way to gain frames.

My final tip, which I haven't seen anywhere else so I claim it it's mine mine!, is to adjust the particles a bit. Go into SkyrimPrefs.ini and find the [Particles] section:

You will see iMaxDesired=750. This adjusts the quantity of particles, which have an immense effect on performance especially with high light, shadow, or AA settings enabled. Examples of particle effects include smoke from torches and firepits, the fire from shouts or magic spells like Flames and Frostbite, dragon breath, and the fog around swamps/bogs or inside dungeons.
If you change the value to 0, you will no longer see the flames from your Fire Breath shout or dragons breath and only a single tuft of smoke will occasionally emit from torches. So, change this value to either 500 or 250 for an immense perf boost without losing the particles themselves (they will just be less voluminous). I went with 250 and actually prefer the less voluminous fog, as Dwemer ruins no longer look like they've been hot-boxed.

I know I sound like a dick, but there are way too many wasted posts about perf issues and I'm trying to save everyone else's time.
Score
0
December 7, 2011 4:47:13 AM

Oh, one last note:

I already beat this game once and put in over a 100 hours on that play through, and I DID NOT have this problem until I reformatted my computer yesterday and reinstalled the game. I honestly don't know if that has anything to do with it, but it might help someone out so I thought I'd mention it.
Score
0
December 12, 2011 3:19:14 PM

for me this was fixed by going into the settings before loading the game and dropping shadows from ultra to high

since doing this i have had no slow downs, hope it helps someone
Score
0
January 5, 2012 2:23:43 AM

space oddity said:
I'm getting a consistent 60fps and everything looks great, however there are certain moments in the game when I'm looking around or fighting when the games starts to stutter a bit. There's no slowdown, just as though the screen were skipping a few frames. I'm using an Xbox 360 controller, so I know it's not my mouse. Weird thing is, when I switch to third person view, the stutter is gone, and everything runs perfectly smooth at all times.

Any fix for this?


I don't know if this will help but I got my old 4870 1gb to run the game on high. I was having stuttering after a short time playing the game regardless of what my framerate was. Eventually I disabled the AA and anisotropic filtering options in the Skyrim launcher and proceeded to use ATI Tray tools to manage my graphics driver. The settings that worked for me were 2X adaptive antialiasing and 2X anisotropic filtering with Trilinear filtering. I also made sure that AA and Trilinear filtering optimization were enabled to help with my frame rate. Finally I enabled 2X temporal AA with a default frame threshold to increase the image quality. The end result for me was a smooth Skyrim experience that looks great with no more stutter! I do have some fps issues in cities with lots of NPCs around but even when my framerate falters, there is no trace of that maddening stutter.
Score
0
January 28, 2012 12:05:47 PM

I was getting this as well, especially outside of towns. For me it was because of a Dragon corpse. I don't know if it was because it was constantly trying to spawn it or what. I randomly mapped to Morthal and it spawned in front of a house and the stuttering stopped. So I saved, found a command to delete the corpse, stuttering is gone. So I figure maybe this is the problem for some others too.

To delete a corpse when it spawns, take all items off of it then enter the Command console with the Tilda key ~ and Select the corpse then type MarkForDelete and press enter. Might have to enter it a couple times and when you go back into game it should disappear.

I still get stuttering indoors, and I'm assuming it's because of the same issue, just have to be patient and wait for the others to spawn I guess. Hope this helps.
Score
0
January 28, 2012 12:38:09 PM

hi
i have hp pavilon dv6:
cpu: core i7
ram: 8 gig
win7
good vga with directX11
....
at first i had problem about run skyrim fullscreen
and i can solve it here>> My Games\Skyrim\SkyrimPrefs.ini
i change fullscreen num to 1 and problem solved
...
now my problem is amazing
the game run in very very low resolution, so i have see details. i can read game messages and etc.
please please please HELP ME
...
Score
0
January 28, 2012 12:39:24 PM

*i have see no details
Score
0
January 28, 2012 12:41:07 PM

*i can't read game massages
Score
0
January 29, 2012 12:08:18 PM

halktx1 said:
hi
i have hp pavilon dv6:
cpu: core i7
ram: 8 gig
win7
good vga with directX11
....
at first i had problem about run skyrim fullscreen
and i can solve it here>> My Games\Skyrim\SkyrimPrefs.ini
i change fullscreen num to 1 and problem solved
...
now my problem is amazing
the game run in very very low resolution, so i have see details. i can read game messages and etc.
please please please HELP ME
...


halktx1 said:
*i have see no details


halktx1 said:
*i can't read game massages


Start your own thread instead of hijacking this one.
Score
0
!