Sign in with
Sign up | Sign in
Your question

Virtual Memory Stuck at 0 MB

Last response: in Windows XP
Share
Anonymous
January 23, 2005 8:09:02 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Hello,

I'm unable to change my virtual memory settings. When I attempt to enter a
custom setting and click "set", nothing happens. The virtual memory remains
at 0. I've also tried setting it to Windows Manage, and that has no affect
also. I'm using XP Pro.

I've tried a few suggestions from Microsofts Support site. I verified the
drive permissions are set to Full Control, and I've updated my Norton
Anitvirus for a possible registry bug.

Does anyone have any other idea? I'm at my wits end!

Thanks.
-dr

More about : virtual memory stuck

Anonymous
January 24, 2005 1:15:44 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Try logging in as Administrator despite your Full Rights and see if you can
set it from there.
Michael
"DR" <DR@discussions.microsoft.com> wrote in message
news:9DF6A471-EF46-4CCD-91DE-792782AEB474@microsoft.com...
> Hello,
>
> I'm unable to change my virtual memory settings. When I attempt to enter
> a
> custom setting and click "set", nothing happens. The virtual memory
> remains
> at 0. I've also tried setting it to Windows Manage, and that has no
> affect
> also. I'm using XP Pro.
>
> I've tried a few suggestions from Microsofts Support site. I verified the
> drive permissions are set to Full Control, and I've updated my Norton
> Anitvirus for a possible registry bug.
>
> Does anyone have any other idea? I'm at my wits end!
>
> Thanks.
> -dr
Anonymous
January 24, 2005 9:29:01 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Thanks, but I've tried that already. It doesn't work even when I log in as
administrator. Correct me if I'm wrong, but if things are working
correctly, I shouldn't have to log on differently just to change virtual
memory.

-dr


"Phillips" wrote:

> Try logging in as Administrator despite your Full Rights and see if you can
> set it from there.
> Michael
> "DR" <DR@discussions.microsoft.com> wrote in message
> news:9DF6A471-EF46-4CCD-91DE-792782AEB474@microsoft.com...
> > Hello,
> >
> > I'm unable to change my virtual memory settings. When I attempt to enter
> > a
> > custom setting and click "set", nothing happens. The virtual memory
> > remains
> > at 0. I've also tried setting it to Windows Manage, and that has no
> > affect
> > also. I'm using XP Pro.
> >
> > I've tried a few suggestions from Microsofts Support site. I verified the
> > drive permissions are set to Full Control, and I've updated my Norton
> > Anitvirus for a possible registry bug.
> >
> > Does anyone have any other idea? I'm at my wits end!
> >
> > Thanks.
> > -dr
>
>
>
Anonymous
January 26, 2005 10:03:03 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Thanks a lot for your detailed response. So far no luch...

A question regarding step 2. from the registry fix suggestion:

On my system the memort management registry key ends with
/ClearPageFileAtShutDown, and does not contain a PagingFiles entry. So there
is nothing for me to click to verify the initial values are correct. Do I
need to add a new key and/or string value?

Also, the link to the page file defragger utility did not work. Can you
provide the website?

Thanks again!
-dr



"Phillips" wrote:

> Yup,
> in theory it should not make any difference... but not when it comes to XP
> :) 
> How many partitions do you have and how much space available on each? If you
> have more partitions (or HDD's) you can set the page file on another
> partition or HDD.
> My wild guess is that some registry setting is preventing you to change the
> sige of the page file.
> Try these from http://www.petri.co.il/pagefile_optimization.htm
> Even when you set the values properly, some systems don't retain your
> settings. If this happens, perform the following steps:
>
> 1.. Start regedt32.exe (not regedit.exe)
>
> 2.. Go to
>
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ControlSession Manager\Memory
> Management
>
> 3.. Double-click PagingFiles. The entry will appear as
>
> D:\pagefile.sys 700 700
>
> 4.. The first value is the location; the second is the minimum size; and
> the third is the maximum size.
>
> 5.. Ensure the values are correct and click OK.
>
> 6.. Reboot the machine.
>
> Remotely changing pagefile size and location:
> You can also change the value of the pagefile remotely by manipulating
> registry values.
>
> pagefile information is stored in the registry as a multi_string (so you
> HAVE to use regedt32.exe) and can be changed locally as follows:
>
> 1.. Start the registry editor (regedt32.exe)
>
> 2.. Move to
>
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory
> Management
>
> 3.. Double click PagingFiles
>
> 4.. There is one line for each pagefile, the format is:
>
> <location> <initial size> <maximum size>
>
> (e.g. C:\pagefile.sys 700 700)
>
> 5.. Click OK
>
> 6.. Close the registry editor
>
> 7.. Reboot the machine
>
> To change on another machine you should use the resource kit REG.EXE utility
> but the command below will replace the current pagefile and will NOT check
> you have enough disk space so you may want to create a script that does
> check. Make sure the machine is rebooted after the change.
>
> C:\> reg update "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
> Manager\Memory Management\PagingFiles"="<location> <initial size> <max
> size>" \\<remote machine>
>
> For example:
>
> C:\> reg update "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
> Manager\Memory Management\PagingFiles"="C:\pagefile.sys 700 700"
> \\london.nwtraders.msft
>
> Make sure you test this before trying to use on live machines.
>
> Pagefile Fragmentation
> If the pagefile gets fragmented your system's performance will decrease.
> System Internals has released PageDefrag, a free utility that shows
> fragmentation in the pagefile and then offers the option of defragmentation
> at boot time.
>
> The utility can be downloaded from HERE
>
> Once you download just unzip the file and run pagedfrg.exe. Below is a
> sample output:
>
>
>
> Group Policy Settings
> There are a few Group Policy settings available for use.
>
> Create a pagefile:
>
> Computer Configuration\Windows Settings\Security Settings\Local
> Policies\User Rights Assignment
>
> This setting determines which users and groups can create and change the
> size of a pagefile. You can create a pagefile by specifying a paging file
> size for a given drive in System Properties Performance Options.
>
> Default: Administrators
>
>
>
> *****************
>
> M
>
> "DR" <DR@discussions.microsoft.com> wrote in message
> news:E5DE67C7-4AD8-4FD3-A9AC-49F9171C3CAD@microsoft.com...
> >
> > Thanks, but I've tried that already. It doesn't work even when I log in
> > as
> > administrator. Correct me if I'm wrong, but if things are working
> > correctly, I shouldn't have to log on differently just to change virtual
> > memory.
> >
> > -dr
> >
> >
> > "Phillips" wrote:
> >
> >> Try logging in as Administrator despite your Full Rights and see if you
> >> can
> >> set it from there.
> >> Michael
> >> "DR" <DR@discussions.microsoft.com> wrote in message
> >> news:9DF6A471-EF46-4CCD-91DE-792782AEB474@microsoft.com...
> >> > Hello,
> >> >
> >> > I'm unable to change my virtual memory settings. When I attempt to
> >> > enter
> >> > a
> >> > custom setting and click "set", nothing happens. The virtual memory
> >> > remains
> >> > at 0. I've also tried setting it to Windows Manage, and that has no
> >> > affect
> >> > also. I'm using XP Pro.
> >> >
> >> > I've tried a few suggestions from Microsofts Support site. I verified
> >> > the
> >> > drive permissions are set to Full Control, and I've updated my Norton
> >> > Anitvirus for a possible registry bug.
> >> >
> >> > Does anyone have any other idea? I'm at my wits end!
> >> >
> >> > Thanks.
> >> > -dr
> >>
> >>
> >>
>
>
>
!