Sign in with
Sign up | Sign in
Your question

When playing start craft i get lag

Last response: in Video Games
Share
December 4, 2011 9:41:31 PM

I have a Gigabyte Ma78lm-s2h motherboard with AMD x4 640 CPU Radeon HD6870 video card. When I play star craft I will get down to 0-6 fps. I don’t think it’s the video card that the bottle neck. Not sure what the issue is because I had an Nvidia 9600gt and received the same performance. When looking at my CPU I am only using like 25-30% so I don’t think that is the issue If I would upgrade the Motherboard to an AM3+ which has ddr3 would that make much of a difference? I am not sure what the issue is anyone has any idea how to make it run better?
a b U Graphics card
a b V Motherboard
December 4, 2011 10:19:39 PM

what settings are you trying to run at?

as in resolution and details AA, AF etc.
m
0
l
a b U Graphics card
a b V Motherboard
December 4, 2011 10:20:11 PM

Are you using and integrated GPU?
m
0
l
Related resources
December 4, 2011 10:40:40 PM

No the GPU is not integrated and my settings are on normal. Starcraft does not have any AA, AF settings. Resolution is set at 1685 x 1050
m
0
l
December 5, 2011 10:38:38 AM

Last night I Reinstalled windows and installed the latest drivers just to make sure there was nothing wrong with my system. When and played starcarft and received still received low FPS 0-6. Any recommendation there has to be something that is bottlenecking causing me to get such low FPS
m
0
l
December 5, 2011 12:30:56 PM

How much ram do you have?
m
0
l
a b U Graphics card
December 5, 2011 12:55:35 PM

Is this happening only with SC2 or other games as well?

that resolution is a really weird number unless it's a typo
m
0
l
December 5, 2011 12:58:52 PM

joedastudd said:
How much ram do you have?

4gb of DDR 800 I use 2.8 GB when playing the game.
m
0
l
December 5, 2011 1:00:35 PM

Have you tried disabling your antivirus?
m
0
l
December 5, 2011 1:12:07 PM

joedastudd said:
Have you tried disabling your antivirus?

I don't have one installed i just did a clean install of Windows 7 with the latest drivers and just SC2 installed.
m
0
l
December 5, 2011 1:17:54 PM

AntiZig said:
Is this happening only with SC2 or other games as well?

that resolution is a really weird number unless it's a typo


The only game I play is SC2 and the resolution is 1680x1050. the game just slows down a so much. My Brother is right next to me and everything is running just fine on his system. So I know it is something with my system.
m
0
l
a b U Graphics card
a b V Motherboard
December 5, 2011 1:34:15 PM

SC2 that is not starcraft.

Your CPU is not good enough.

Please read this article, they are benching with a GTX 480 at 1024x768 with NO AA/AF

With a athlonx4 635 @ 2.9 (vs. your 3.0) they go down to 12FPS. at much lower res. than you are trying to run.

here is the link.

http://www.pcgameshardware.com/aid,766589/Starcraft-2-C...
m
0
l
a b U Graphics card
a b V Motherboard
December 5, 2011 1:39:08 PM

Apparently it only uses 2 cores max. and LOVES L3 cache. You have no L3 cache. Is suspect your brother has a different CPU.
m
0
l
December 5, 2011 1:54:28 PM

americanbrian said:
Apparently it only uses 2 cores max. and LOVES L3 cache. You have no L3 cache. Is suspect your brother has a different CPU.

Yes he has a I7 920 clocked at 4GHz. So I need to upgrade my CPU would AMD Phenom II X4 970 Black Edition Deneb 3.5GHz work better
m
0
l
a b U Graphics card
a b V Motherboard
December 5, 2011 3:21:47 PM

if you look at the article, yes a lot better. They only have the 965 tested but that yields a near 50% increase in minimum frames. Keep in mind that this is with max details, so you hopefully can find some balance that is pleasing if you choose to upgrade your CPU.
m
0
l
December 5, 2011 4:11:23 PM

americanbrian said:
if you look at the article, yes a lot better. They only have the 965 tested but that yields a near 50% increase in minimum frames. Keep in mind that this is with max details, so you hopefully can find some balance that is pleasing if you choose to upgrade your CPU.

Thanks now i know what i need to change to get better performance.
m
0
l
December 5, 2011 9:54:53 PM

AMD FX-4100 Zambezi 3.6GHz or AMD Phenom II X4 970 Black Edition Deneb 3.5GHz work better
m
0
l
a b U Graphics card
a b V Motherboard
December 5, 2011 10:36:05 PM

Are you getting 0-6 fps all the time or like just in battles in big games? If it's all the time then something is very wrong.
m
0
l
December 5, 2011 11:05:38 PM

benski said:
Are you getting 0-6 fps all the time or like just in battles in big games? If it's all the time then something is very wrong.

It’s in battles but I play a lot of marine arena and after 10 mins there are tons of big battles so it’s like the rest of the game until some people die
m
0
l
a b U Graphics card
a b V Motherboard
December 6, 2011 9:24:43 AM

Deneb all the way. It is better for gaming. It stands toe to toe with the 8 core bulldozers.

@benski, read the article I posted to see that no, nothing is wrong.
m
0
l
!