Sign in with
Sign up | Sign in
Your question

IDE I AND II INVISIBLE

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
December 12, 2001 6:20:35 AM

Hi, I have a promise ultra 100 card to which my hd is hooked up, this works fine as does my floppy drive which sits in the floppy ide connector of the mb. Since two days however, neither my cdwriter (master on ide 1) nor my cdrom and zip drive ( master and slave on ide 2) are visible in Windows. I think they are not accessible in Dos either. Windows works ok with my harddisk and floppy. Norton Antivirus has given me info that boot record and master boot record have changed and would I agree with that? I said to ignore it for the moment. I have scanned and scanned but have not found any virus! Yet I suspect my boot record and mbr have been affected somehow. I have tried fdisk /mbr; no luck. Any ideas how to restore (master) boot records or maybe a suggestion as to what else may be the cause of this problem and to correct it? Thanks in advance!
Hans

More about : ide invisible

December 12, 2001 6:40:19 AM

Are the drivers of the promise card running properly? Otherwise you'll have to reinstall them.
What are you other components (mobo, cards)?

My case has so many fans that it hovers above the ground :eek:  .
December 12, 2001 6:52:00 AM

the only way i can think to REPAIR/REWRITE the MBR is the way you said, but that apparently didnt work.
very odd problem, but something had to have changed...
no software was downloaded, installed, or any hardware added????????
if not, then maybe there is actually some corruption going on.

-DAvid

-Live, Learn, then build your own computer!-
Related resources
Can't find your answer ? Ask !
December 12, 2001 6:52:34 AM

check in your bios, sometimes on an older board, when the card is detected it will automatically disable the onboard ide channels. should be somewhere under "CHIPSET" i think. if they are enabled, flash to the latest bios there is for the mobo.

[insert philosophical statement here]
Anonymous
a b V Motherboard
December 12, 2001 6:57:20 AM

No problems with the Promise drivers, everything's fine there. MB is an "old" Intel AL440LX. Got a Celery 400 on it. And sound card, network adapter card, capture card and agp vid tnt1. However, they have never given me any problems in this config and Windows System Configuration does not give me any exclamation marks. The only thing there is the absence of the icon and content: cdrom drives (or similar). By the way: I have tried to see if I could "add new hardware". No luck, Windows just doesn't see ide 1 and 2, does not recognize the peripherals cdrom and writer and zip drive......
Anonymous
a b V Motherboard
December 12, 2001 7:05:01 AM

No new software or hardware installed lately. Have checked the Bios too; nothing's changed there. There is no primary master/slave nor secondary chosen nor mentioned there. Only in the boot sequence part is the Promise card and the hd mentioned. Has worked flawlessly...well, until two days ago anyway. The Bios is the latest version (P14).
December 12, 2001 11:24:19 AM

Are the other drives attached to the mobo or to the promise controller?

My case has so many fans that it hovers above the ground :eek:  .
Anonymous
a b V Motherboard
December 12, 2001 1:23:45 PM

Only the harddisk (one) is attached to the Promise card; the cdwriter is attached to ide 1 on the mb as master and the cdrom and zipdrive are attached to ide 2 on the mb as master and slave respectively. Floppy drive is on the floppy connector of the mb. Promise card (and hd on it) and floppy drive work just fine, the rest is invisible; IDE 1 and IDE 2 are NOT recognized by the system.
December 12, 2001 4:44:18 PM

Now I see that the problem is the onboard IDE controllor, this wasn't clear for me before.
It's very strange that your onboard IDE controller suddenly drops, it could be that the mobo somehow got damaged which causes the IDE ports to malfunction. But often the IDE controller is intergrated in the Southbridge (I think on your mobo too) so I think it can't be a totaly failing Southbridge because otherwise your PCI slots also won't work.
You can try to connect the CDROM to the Promise control (if it supports ATAPI dives) to see if they components attached to the IDE 1&2 port cause the malfunction. If they work on the Promise card I think your onboard IDE connector is broken.

My case has so many fans that it hovers above the ground :eek:  .
Anonymous
a b V Motherboard
December 12, 2001 5:52:02 PM

I like your suggestion. I'm going to try that out asap...which could be tomorrow or day after. By the way, in Windows system control panel, under system, properties, device manager, system devices, there is nothing out of the common. No exclamation marks or question or similar. I'll post again here when I've tried your suggestion. Plz have a look here over the next few days or so. Regards. And if anyone has any other ideas, you're still welcome..:-)
Anonymous
a b V Motherboard
December 16, 2001 5:23:57 PM

Problems are solved!!! No virus, no faulty ide connector, but missing device manager items with the object Hard disk controllers. No idea what made them disappear but both the Standard IDE/ESDI HD Controller and the primary IDE controller (dual fifo) were gone. No wonder I had these problems you say? Right. Thing is - no excuse :-) - that Windooz gave absolutely no warnings or messages or exclamation marks in Device Manager. Yesterday I took out the writer and put cdrom and zip drive as m and s on ide 1. After that, in Windows, I again did a search for new hardware and YES, finally Billy found sth. Thanks for your ideas and help!! Much appreciated. Regards, Hans.
!