Sign in with
Sign up | Sign in
Your question

Older PC games vs. Windows 7 64bit

Last response: in Video Games
Share
December 7, 2011 8:51:44 PM

If anyone has any ideas on how to fix this, I would greatly, GREATLY appreciate it.

I've got some older games that just do display correctly at all on Windows 7.
Actually, its so blurry it goes beyond frustration and borders on hilarity.

Here's a few examples.

Serious Sam 1 main menu


Serious Sam 2 main menu


Doom 3 (I clicked "something" and it pulled up this menu which displays as well as the something I clicked.)


Keep in mind, those screenshots are 1440x900 resolution in Windows 7 64bit.

Before I have people come here and tell me to switch the compatibility to XP, I've already done that. Actually, I've tried every compatibility, even Windows 95.
I tried running the games on and off of disable visual themes, disable desktop composition, disable display scaling on high DPI settings.
I've already updated my ALL drivers to the newest they could be. Sounds counter productive since its older games, but I still did it.
I have the newest version of Direct X installed.
I have the most recent patch of Doom 3 installed which is supposed to have Vista/7 support.

All of this, it and these games still look like ***. I can't even play them because I can't even read them.
I've already started and ended these games probably 100 times between settings.

I will try anything else. ANYTHING.

Please help. Anyone out there, please.
;_;

For the record, my graphics video card is a Intel(R) G41 Express Chipset.
Serious Sam are GOG.com games, Doom 3, PCDVD.
December 7, 2011 9:33:59 PM

May be its because most of the old game does'nt support Resolution greater than 1024x768
m
0
l
December 7, 2011 11:55:56 PM

It also depends on how old the games are. If they came out around Win 98 or so they could be 16 bit which won't work with 64 bit.

I am not for sure on this but you direct X 11 and what your game requires a lesser direct X. Don't quote me on that I am not 100% sure.

I remember reading something about it but I could have it backwards. One more thing. Did you up date your graphic card with the latest drivers?
m
0
l
Related resources
December 8, 2011 1:26:52 AM

Yes. As I mentioned in my first post, my drivers are all up to date.

Serious Sam The First Encounter (the green screenshot) was released 2001.
Serious Sam The Second Encounter was released 2002.
Doom 3 was released 2004.

I currently play Descent 3, which was released in 2000, doesn't even have Windows 7 support (other than a few settings tweaked) and have no graphic display problems like I do with the aforementioned games.

I don't think the issue has to do with the games being outdated.

I appreciate the input from you guys though.
Please offer other suggestions.
m
0
l
December 8, 2011 4:40:53 AM

Windowed mode its your friend, fullscreen mode its out of the question. Try that. There are going to be some graphic artifacts aswell, research more the web, usualy older games have a conflict with windows Aero and explorer of W vista /7, so some games needed to be runned via a Batch file witch kills windows explorer when you run the specific game, and when you exit the game, the same batch, will start windows explorer.
m
0
l
December 8, 2011 4:46:23 AM

i.e
First, open notepad and copy and paste this tex
taskkill /f /im explorer.exe
fallout2.exe
pause
start explorer.exe

Save it as fallout2.bat and make sure under the "save as type" selection to pick "all files" and not text. Save it in the same folder where fallout2.exe is located. Set a shortcut on the desktop or wherever to this file. That way you can change the icon and avoid having to look at ugly.

this is how i can run Fallout 2 without graphic artifacts. And sorry, its not a Batch file, its .BAT
m
0
l
December 8, 2011 5:21:33 AM

crisan_tiberiu said:
i.e
First, open notepad and copy and paste this tex
taskkill /f /im explorer.exe
fallout2.exe
pause
start explorer.exe

Save it as fallout2.bat and make sure under the "save as type" selection to pick "all files" and not text. Save it in the same folder where fallout2.exe is located. Set a shortcut on the desktop or wherever to this file. That way you can change the icon and avoid having to look at ugly.

this is how i can run Fallout 2 without graphic artifacts. And sorry, its not a Batch file, its .BAT


.bat file type is a batch-type file extension.
m
0
l
a b $ Windows 7
December 8, 2011 10:29:56 AM

I'd be more inclined to blame the crappy on-board Intel GPU than Windows 7. I would suggest you try and borrow a dedicated GPU card from someone and see if that fixes the problem. If so, get one for yourself.
m
0
l
December 8, 2011 10:52:33 AM

Herr_Koos said:
I'd be more inclined to blame the crappy on-board Intel GPU than Windows 7. I would suggest you try and borrow a dedicated GPU card from someone and see if that fixes the problem. If so, get one for yourself.


+1, ive played doom 3 on w7 64-bit in ultra quality without a problem (with a dedicated GPU (9800GX2))
m
0
l
December 8, 2011 5:10:45 PM

crisan_tiberiu said:
i.e
First, open notepad and copy and paste this tex
taskkill /f /im explorer.exe
fallout2.exe
pause
start explorer.exe

Save it as fallout2.bat and make sure under the "save as type" selection to pick "all files" and not text. Save it in the same folder where fallout2.exe is located. Set a shortcut on the desktop or wherever to this file. That way you can change the icon and avoid having to look at ugly.

this is how i can run Fallout 2 without graphic artifacts. And sorry, its not a Batch file, its .BAT


Thank you very much for this. The BAT file executed beautifully, but unfortunately, this did not solve the problem.
You can see this on a new screenshot I made for Doom 3.

Herr_Koos said:
I'd be more inclined to blame the crappy on-board Intel GPU than Windows 7. I would suggest you try and borrow a dedicated GPU card from someone and see if that fixes the problem. If so, get one for yourself.


I would too. I certainly considered that to be a factor,
but I want you to consider something else.

I play The Witcher on my computer too with my current setup. It displays beautifully, and its a newer game then the Serious Sam games I mentioned and Doom 3. (released October 2007).

Being that I can play newer, graphically better games than the first two Serious Sam's and Doom 3 (The Witcher) and older games (Descent 3), I'm inclined to believe that its a compatibility issue, and not a performance one.

Wishful thinking says that its just a matter of figuring out how to attune my video card to be more compatible with the games I'm having trouble with.
m
0
l
a b $ Windows 7
December 8, 2011 5:54:54 PM

...I note all those titles are OpenGL. Crappy OGL drivers? I know for a fact Doom3 works on Vista 64...
m
0
l
December 8, 2011 10:55:25 PM




Do you have the Nvidias controll panel? If so have you tried to match the resolution with the game? Just a thought.

You know what it's going to be is something very simple and right in front of you. I will look on other forums to see if a related ishue can be found.
m
0
l
December 9, 2011 1:51:25 AM

I don't have an Nvidia card.... I didn't think I could use the control panel?

?

It would be nice if it was a fix that's right under my nose. I'd like that.
I appreciate the effort in trying to find a fix....

m
0
l
December 17, 2011 12:40:37 AM

You're right. The answer was right under my nose.
Another forum member pointed it out.

In my graphics properties, they were set to Performance. The other options to choose from are Balanced and Quality. Either one of those displays the game smoothly, and crystal clear!

Freaky weird, but I'll take it!
m
0
l
a b $ Windows 7
December 17, 2011 9:13:04 AM

i found on some titles i had to turn off amd overdrive and set all my gfx options to default in the ccc pannel or i would get blured out text .

edit* doom 3 worked pretty much out the box for me. i just updated dx files and it worked...
so i would suggest going back to the disks and see if you have installed all the needed redistro files. like vcredist, direct x and so on.

then your on to gfx drivers...
m
0
l
December 20, 2011 1:06:50 AM

Why would I do all that when I got it working great by just changing my 3D card to something besides "Performance"?

._.
m
0
l
!