Soyo Dragon+ Screen freezing

Last week I bought a Soyo Dragon+ (Via266a), and a Athlon XP 1800 to replace the old mobo and chip. The issue now is that every time I run a graphic intensive program, such as 3dmark 2001, Dark Age of Camelot, or Everquest, the screen freezes. Almost always it freezes in under 3 minutes, and locks up the computer. I have to restart by powering down, and restarting the computer. Here are the computer specs:

Soyo Dragon + mobo
Athlon 1800+ (noise control silverado)
Geforce 3 8200 asus
WD 40gig 7200 RPM HD
768 meg crucial 2100 DDR
Soundblaster 5.1
HP 9100 cd burner
Powmax 400w power supply
Windoze XP Pro

Please keep in mind all components worked flawlessly with my old mobo/cpu, which were a Shuttle AK31 ver 3.1, athlon 1.4 tbird... Gave that combo to my wife. Anyway, I thought it may be the new Athlon XP, but I swapped in the 1.4 Tbird with the XP, and still get the freezes. Following are the troubleshooting steps I have tried...

* Swapped power supply with a known good 300 watt
* Swapped video card with a Geforce 2 MX
* Swapped XP 1800 with TBIRD 1.4
* Tried Windows XP driver for Geforce 3, as well as the newest Detonators, and the ASUS drivers that came with the card
* Tried using just 256 meg of current Ram, and also swapped with known good DDR 2100 from wife's machine.
* Formatted primary partition, and loaded a fresh OS- XP Pro
* Did not load any of the mobo software included with the Soyo
* Watched CPU temps through this ordeal- around 42C under load

Everything I swapped still locked up, same as with the original components. Then I tried something that gave some results. I had noticed that I could not overclock the FSB at all, or the system would be completely unstable. Even 135mhz would prevent windows from loading. With all the same components, I could easily get 150mhz out of the old Shuttle board. So, instead of the default 133 mhz FSB, as that is the default for the Athlon XP, I switched the FSB to 100. After that, it runs solid as all getup. No crashes, freezes, or anything. I ran 3DMark 2001 benchmark in a loop for over an hour, twice! I couldn't get 3 minutes out of it at the default 133 mhz. I could also play DAoC, and Everquest unmolested for as long as I want. But I didn't buy this board so that I could run it SLOWER than the last. I'd like it to run at least as fast.

So, what am I missing here? Is it just a bad board? Do I need to send it back to where I got it? Or is there something I am missing here? Any responses appreciated!
5 answers Last reply
More about soyo dragon screen freezing
  1. I would take and unhook everything except the essientals ( video card, cdrom, hard drive)...and boot up and see if you still get lock ups....some components just wont work as well with others in some instances and you got to start from the bottom and work you way up.....just make sure you get the latest bios and ide drivers for xp etc to insure stabiblity for xp and the xp processor.....and that xp chip is sucking more power than the last along with that geforce 3 so i would suggest getting at least a 400w power supply....i am running a sparkle 400w on my xp1900....good luck man
  2. Try removing the soundblaster 5.1 and using onboard sound. If that doesn't suite you, I would load the generic nvidia driver off their website, and remove your old driver in device manager before installing the generic driver. I couldn't get one game to run at all, and the generic driver worked for me.
  3. First flash your BIOS with the latest version.
    Then set the FSB to 133 and check if the PCI speed is set to 1/4 of the FSB speed, otherise you will OC yoyr PCI speed to 133/3=44,33 MHz which is 11 MHz higher then the normal speed (33 MHz).

    My case has so many fans that it hovers above the ground :eek: .
  4. i am having the exact same problem with this system....ive flashed the bios as was reccomended by alot of people, and it didnt help. my screen freezes within minutes of being in windows. ive rearranges cards and freed up some irq's but the agp video and nic share an irq, as does the tv tuner and usb. i have no clue how i this can be fixed, if i cant solve it soon, ill get a new board
  5. Thanks to everyone for the advice! I figured out what it was, and in hindsight feel pretty foolish about this one. All that was needed was a BIOS flash to the newest BIOS. It works fine now. Ran 3dmark 2k1 bench 5 times with no freezes.

    I hwent to the soyo website yesterday, it was like the 3rd thing I had checked, and somehow got the impression I had the newest BIOS installed. (Soyo's BIOS page seems a bit more confusing than it should have to be) After the flash, it worked great.

    Once again, thank you all. I am ecstatic that I didn't have to RMA this one.
Ask a new question

Read More

Motherboards Soyo Windows XP