Sign in with
Sign up | Sign in
Your question

hal.dll error on non-booting partition

Last response: in Windows XP
Share
Anonymous
February 21, 2005 7:24:07 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

I can no longer boot to my FAT32 WinXP partition, although my folders
seem intact and accessible from recovery console. I recently upgraded
hard drives and cloned my partition, which seemed to work fine, until I
started getting the "missing or corrupt" hal.dll message whenever I try
to boot.

If I boot to the WinXP CD I am not offered the repair option to do a
repair installation. Out of desperation I tried 'fixboot /rebuild' and
later 'fixmbr' commands from the repair console which did not help.
Still the hal.dll message.

In case it's helpful, here are the results of partinfo.exe on the
problem hard drive:


================================================
PARTINFO 1.09
Copyright (C) 1996-2003, TeraByte Unlimited. All rights reserved.


Run date: 02/20/2005 14:07


============================================================­========
MBR Partition Information (HD0):
+====+====+=============+====+=============+===========+====­=======+
| 0: | 80 | 0 1 1 | c | 1023 254 63 | 63 | 312576642 |
| 1: | 0 | 0 0 0 | 0 | 0 0 0 | 0 | 0 |
| 2: | 0 | 0 0 0 | 0 | 0 0 0 | 0 | 0 |
| 3: | 0 | 0 0 0 | 0 | 0 0 0 | 0 | 0 |
+====+====+=============+====+=============+===========+====­=======+


============================================================­===================

EMBR Found (HD0)
------------------------------------------------------------­-------------------

Revsion: 2 Min SPT: 9 Sectors: 1 SSize: 512
Last Cyl: 1023 Last Hd: 254 SPT: 63
------------------------------------------------------------­-------------------

MPT Found: Revision: 5, Number of Entries: 1 Flag: 1
------------------------------------------------------------­-------------------

0: LOCAL DISK-0 Flag: 4000 Start: 63 End: 312576704 FS: C

ID: 1
------------------------------------------------------------­-------------------

MBFT Found: Revision: 2, Number of Entries: 0
------------------------------------------------------------­-------------------

------------------------------------------------------------­-------------------

MDT Found: Revision: 2, Number of Entries: 1
------------------------------------------------------------­-------------------

0: Bootit EMBRL Flag: 20 Start: 0 NumSecs: 7 Alloc: 50
ID: 0
============================================================­===================

BOOT SECTOR INFORMATION
------------------------------------------------------------­-------------------

File System ID: 0xC LBA: 63 Total Sectors: 312576642 ID: 0x1
Jump: EB 58 90 (EB 58 90)
OEM Name: MSWIN4.1 (MSWIN4.1)
Bytes Per Sec: 512 (512)
Sec Per Clust: 64 (64)
Res Sectors: 32 (32)
Num FATs: 2 (2)
Root Dir Ents: 0 (0)
Sectors: 0 (0)
Media: 0xF8 (0xF8)
Secs Per FAT: 0 (0)
Sec Per Track: 63 (63)
Heads: 255 (255)
Hidden Secs: 63 (63)
Huge Sectors: 312576642 (312576642)
Huge Secs Per FAT: 38149 (38149)
Flags: 0x0 (0x0)
Version: 0 (0)
Root Dir Clust: 14043 (14043)
FS Info Sec: 1 (1)
FS Bkup Sec: 6 (6)
Reserved: 0 0 0 0 0 0
Drive Num: 0x80 (0x80)
Res: 0x0 (0x0)
Boot Sig: 0x29 (0x29)
Vol ID: 0x1A330EDF (0x1A330EDF)
Volume Label: LOCAL DISK (LOCAL DISK)
FS Type: FAT32 (FAT32 )
Boot Flag: 0xAA55 (0xAA55)
------------------------------------------------------------­-------------------
Anonymous
February 21, 2005 8:16:19 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

As a follow up, my boot.ini reads as follows:

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=""
!