Sign in with
Sign up | Sign in
Your question
Closed

Choppy Mouse Movements

Last response: in Video Games
Share
December 15, 2011 8:12:02 PM

It almost seems as if my cursor is moving along a grid. The problem is virtually unnoticeable unless I'm playing a FPS. Up and down movements are perfectly smooth, but diagonal movements are choppy. I don't think it is a hardware problem because I have an Xbox controller that works beautifully. I don't think it's a problem with the mouse either because if the sensor was obscured, movements would be jumpy and unpredictable. I don't have another mouse to try and I'd like to try and get this figured out before I go out and buy a new one.

I've adjusted the Razer settings multiple times. I've turned off "enhance pointer precision", which helped a little bit. I've updated drivers. I'm running out of options.

The problem may or may not have existed before. I've never noticed because the mouse hasn't been used for gaming for a few years.

I have a Razer Deathadder 1800dpi mouse. It's about 4 years old, if that makes a difference.

Specs:
i5 2500k
Radeon HD 6850
ASUS P8Z68
Kingston HyperX 8GB
WD Caviar Black 1tb HDD
Crucial 64GB SSD

More about : choppy mouse movements

December 15, 2011 11:12:11 PM

try using it on a different surface--i never use a mouse mat--the best thing i have found is a 12 inch square linoleum tile--really smooth and hard wearing been using it 5 years now and its still good as new
Score
0
December 16, 2011 2:21:35 AM

the reason its choppy is because your settings do not match your screen. it shows up easily if you use paint. and set the image size to the same as the screen.
scroll diagonal and you will see a stair like jaggy line. this is normal for lazer mice.
if you buy a mouse that uses a ball the motion is smooth the problem with them is they poll at 125ms which is to slow for gaming.
it wont be any different until mouse makers give us single dpi increments. all you can do is match the mouses dpi as close as you can to screen size or set it to the same aspect ratio/as close as you can get it..

Score
0
Related resources
December 16, 2011 6:31:01 AM

HEXiT said:
the reason its choppy is because your settings do not match your screen. it shows up easily if you use paint. and set the image size to the same as the screen.
scroll diagonal and you will see a stair like jaggy line. this is normal for lazer mice.
if you buy a mouse that uses a ball the motion is smooth the problem with them is they poll at 125ms which is to slow for gaming.
it wont be any different until mouse makers give us single dpi increments. all you can do is match the mouses dpi as close as you can to screen size or set it to the same aspect ratio/as close as you can get it..

No matter what settings I use, the mouse movements are still choppy. 450dpi, 900dpi, or 1800dpi. Do I need a 3200dpi mouse?? My resolution is 1600x1200. The settings don't change a thing.

My mouse surface is a Func industries gaming mat. I've tried multiple surfaces, doesn't make a difference either.
Score
0
December 16, 2011 8:11:26 AM

if it have then use mouse filter or somewhat like this
Score
0
December 16, 2011 9:31:36 AM

This choppy aiming used to happen in "IGI David Jones" in the sewer level fine aiming could be gotten by moving your "body" a little. I think this was deliberately programed as it only happened in this low light environment level.

Which FPS and which level are you at.

Score
0
December 16, 2011 5:38:52 PM

HippyMitch said:
This choppy aiming used to happen in "IGI David Jones" in the sewer level fine aiming could be gotten by moving your "body" a little. I think this was deliberately programed as it only happened in this low light environment level.

Which FPS and which level are you at.

Which FPS? Every single one I play, no matter what level. Borderlands, TF2, BF3...
Score
0
December 16, 2011 5:45:10 PM

truegenius said:
if it have then use mouse filter or somewhat like this

Mouse filter?
Score
0
December 17, 2011 5:53:06 AM

mousd filter
a setting in game to smooth out mouse movement when using mouse to look
in left4dead it is present in keyboard/mouse settings
Score
0
December 17, 2011 9:08:24 AM

check your mouse settings and make sure acceleration is off. and in the windows mouse settings smoothing is on.
Score
0
December 18, 2011 2:07:23 AM

HEXiT said:
check your mouse settings and make sure acceleration is off. and in the windows mouse settings smoothing is on.

I can't find any of these options under the Windows mouse options. I'm using Windows 7 and it only gives me the options for pointer speed and "enhance pointer precision", which I turned off.
Score
0
December 18, 2011 5:36:36 AM

mouse smoothing is enhanced pointer precision so it needs to be on..
acceleration will be an option in your razer mouse panel. not the windows mouse panel.
Score
0
December 18, 2011 4:45:46 PM

I find that in BF3 the mouse movements are horrible. It is very very choppy. Doing a quick Google search found tons of peope complaining of the same thing. I am getting 60 FPS constant yet I feel like the game is super choppy to play, unlike other games. L4D L4D2 COD4 etc etc, all are smooth but BF3.
Score
0
December 18, 2011 8:01:04 PM

tydalwave said:
I find that in BF3 the mouse movements are horrible. It is very very choppy. Doing a quick Google search found tons of peope complaining of the same thing. I am getting 60 FPS constant yet I feel like the game is super choppy to play, unlike other games. L4D L4D2 COD4 etc etc, all are smooth but BF3.

L4D is just as bad for me. :( 
Score
0
December 18, 2011 8:02:05 PM

HEXiT said:
mouse smoothing is enhanced pointer precision so it needs to be on..
acceleration will be an option in your razer mouse panel. not the windows mouse panel.

"Enhance pointer precision" was on before. I turned it off and it made the movements smoother.
Score
0
December 19, 2011 10:20:13 PM

hmmm very odd. i would look at my mouse surface then.
Score
0
January 27, 2012 6:15:34 PM

mate you problem is same as mine i have thought my gfx was issue so atm i sent it back to be looked at and it was faulty... mabey a good idea to check if this is same issue.. the game would run fine (bf3) untill i touched the mouse then look all distorted and if i use scope it would flicker builet holes and other none background items... i thought it was my mouse to so i brought a logitec gaming mouse didnt help at all i lent a few mice nd same result ....hope my problem help you sort your own
Score
0
January 27, 2012 7:58:50 PM

seriously, unless you live in a desert, loan another mouse from someone for 10 mins or 1 day and check if it's mouse of something else
Score
0
May 26, 2012 6:49:33 AM

hey! this happens to me a lot, never in game, always in desktop, and if I fire a game, plays nice, but still, from time on time, sitting in desktop under not a single workload, starts the choppy mice, I know is not the mouse...

Motherboard Asus M5A99X EVO
Phenom II X4 965BE
8 Gb Corsair Vengeance
Sidewinder X8 Mouse
800 watt Delta electronics PSU


Score
0
May 26, 2012 1:15:01 PM

have you installed the razer mouse manager? go to razers site and see if theres a 1 available for that model. there is 1 for the lachesis as i have that mouse but i dont have a death adder so i dont know...
it should be in the driver /update section and is likely to be 13-60+mb.
i had it wrong when i said turn mouse smoothing on. its only for low dpi mice with high polling rates.
also check the mouse poll rate poll rate can affect prediction if its to high you get more noticeable prediction and the mouse will want to move in straight lines. to low it will draw a line with steps in it.

so set windows pointer speed to about halfway in win7 mouse handler and adjust the rest from razers app if you get 1...
http://www.nextlevelgamer.com/tweaks/optimizing-your-us... <-- try this site
download these and use as instructed in the above link.
http://www.nextlevelgamer.com/downloads/tweaks/mouserat...

http://www.nextlevelgamer.com/downloads/tweaks/usbmrs11...

Score
0
July 17, 2012 11:51:43 AM

I just bought a new mouse and had the same problem. Every time I move cursor diagonally it moves like climbing or going down stairs and not smoothly. The way I solved it is to go to Control Panel, Mouse Settings, Pointer Option, and in Motion part where it says Select a pointer speed move the bar close to the the middle or even further left. I did that and now pointer moves very smoothly.
Score
0
August 1, 2012 3:51:12 PM


mcnumpty23 said:
try using it on a different surface--i never use a mouse mat--the best thing i have found is a 12 inch square linoleum tile--really smooth and hard wearing been using it 5 years now and its still good as new


This little tip solved my mouse problem. I should have thought of that on my own since it's such a simple thing to try.

Thanks for fixing my mouse. :-)
Score
0
August 1, 2012 7:45:03 PM

This topic has been closed by Mousemonkey
Score
0
!