Sign in with
Sign up | Sign in
Your question

This is the last ditch effort of a desperate man... witcher 2, steam

Last response: in Video Games
Share
December 21, 2011 5:20:25 AM

Alright...

I've done everything I can think of to fix it, but after updating via Steam my Witcher 2 game to patch 2.1, my game still won't launch. The launcher shows up, but after a bit it goes to "The application was unable to start correctly (0xc0000005)."

I know it has something to do with .NET Framework 4, at least according to CDProjekt Red, the makers of the game.

Any help would be much appreciated. BTW, I'm computer stupid, so try to be thorough with your answers.

My drivers and such are all updated...

Here's the specs:

System
--------------------------------------------------------------------------------

Manufacturer HP-Pavilion
Model NY558AA-ABA
Total amount of system memory 9.00 GB RAM
System type 64-bit operating system
Number of processor cores 4

Storage
--------------------------------------------------------------------------------

Total size of hard disk(s) 931 GB
Disk partition (C:)  454 GB Free (919 GB Total)
Disk partition (D:)  2 GB Free (12 GB Total)
Media drive (E:)  CD/DVD

Graphics
--------------------------------------------------------------------------------

Display adapter type AMD Radeon HD 6800 Series
Total available graphics memory 5371 MB
Dedicated graphics memory 1024 MB
Dedicated system memory 0 MB
Shared system memory 4347 MB
Display adapter driver version 8.920.0.0
Primary monitor resolution 1920x1080
Secondary monitor resolution 1920x1080
DirectX version DirectX 10

December 21, 2011 6:59:16 AM

Do you have windows set to automatically update? When available windows will have updates for .net framework.
m
0
l
December 21, 2011 7:27:11 AM

Right click on the game in the Steam Library -> Properties -> Local files, click Verify.
It should find any missing files and redownload them.
Its best to run it until no more files are found.
m
0
l
December 21, 2011 12:27:05 PM

What joedastudd said is the best advice available--whenever Steam can't launch a game, right-click it and go into the properties and repair/verify the local game files to ensure they are corrupted.

At the extreme end, if you cannot get the game to launch, delete all the Witcher 2 files via Steam and redownload the game (*groan* I know, the entire game is around 23 GB iirc).

I have a similar problem, although not a show-stopper: Whenever I launch Witcher 2, it reinstalls the .NET framework every time the Witcher 2 launcher opens, even though everything is up to date.
m
0
l
December 21, 2011 1:09:10 PM

are you using msi afterburner? does it work if this is not running, try evga precision instead. I could run nothing on steam with afterburner running had a similar error. Precision works ok.
m
0
l
December 21, 2011 7:30:28 PM

I tried the verify local game files thing and that didn't work. Tried the uninstall and reinstall thing and that didn't work. I'm not using afterburner. I don't know what else to do.
m
0
l
December 21, 2011 7:54:35 PM

Is it an authenticator issue? As in when you install the game did you make sure to right click and install as administrator?
m
0
l
December 21, 2011 8:15:34 PM

I run Steam as administrator. I don't see any option to install a game as administrator. I think Steam automatically handles some things like installation to dumb things down for customers. Don't know for sure.
m
0
l
December 22, 2011 1:37:50 PM

I don't have witcher 2 yet but I know from the first witcher I had issues with their tages and administrator rights access. I had the disk for a manual install so I'm also not sure if steam handles all of that. I just remember witcher being a mess with admin rights.
m
0
l
December 22, 2011 6:06:48 PM

c05 is typically an access violation error. So as someone said above, check that you're logged in as admin
m
0
l
February 3, 2012 3:07:47 PM

Having the same problem now..
m
0
l
February 3, 2012 3:24:00 PM

Don't know if it might help but the problem I had with the witcher 2 assassin of kings were the patches were not up to date. I had to go to there forums and download the patch pack from there website as the game does not come with the new patches but I had the disk version not steam.
m
0
l
March 8, 2012 12:45:02 PM

Make sure your drivers are compatible - my problem was solved by rolling back my graphics drivers
m
0
l
March 8, 2012 2:46:11 PM

lol ok just try this cause ive been trying this out with steam games recently

go to your programs folder and open up were you installed witcher2

then open (explore) the cd

copy and paste all the cd contents into the witcher 2 folder

it sounds stupid but it worked for me on skyrim (it completely cut the game from steam no more updates, no logging in, just works straight of the hard drive) :p 

hope this helped
m
0
l
!