Sign in with
Sign up | Sign in
Your question

Some DX11 games running at low res

Last response: in Video Games
Share
December 23, 2011 8:14:04 PM

Hello,

I've been having a problem where certain games, when run in DirectX 11 (but NOT DirectX 9), set themselves to a very low, unacceptable resolution despite whatever I set them to run at myself.

I own four games capable of running in DX11: Civilization V, Crysis 2, Total War: Shogun 2, and Batman: Arkham City.

Of these four, the only one that will actually run in 1920x1080 (or anything above 1280x1024) is Total War: Shogun 2, with which there are no issues whatsoever.

But Crysis 2, Civ 5, and B:AC all refuse to run in anything but either 1280x1024 or as low as 800x600. Once again, this is ONLY when the games are run in DX11 mode. I have tried changing the resolution manually, in the .ini's, but it just sets itself back no matter what I do.

In Crysis 2 and Civ 5, the resolution field in the game's settings (NOT the .ini) is left blank when in DirectX 11 mode, and I can't change it at all. It doesn't show up as anything, and runs at the same low resolutions I mentioned before. Only when I revert to DX9 are the games able to run at 1920x1080.

My system has:

- i5-2500K OC'd to 4.5 GHz
- 8GB of RAM @ 1333 MHz
- Sapphire 6950 flashed to 6970 and OC'd to 900/1375 (this is NOT the problem, I've tried flashing it back and setting the clocks to stock settings to no avail)
- Windows 7 Ultimate 64-bit

PLEASE, somebody help me!!! I want to run games in DX11 and I just can't. I've searched all over for answers, and haven't been able to find anyone with the same problem. ANY advice would be such a help.

Thanks!
December 23, 2011 10:32:50 PM

Man that sucks I know how you feel. When I first got Shogun 2 It would not let me run in DX11 plus a lot of freezing plus CTD's. They finally put out a patch and now It works just like you no problems.

I don't know what you go into on the ATI cards properties menu. But with Nvidia we can change the resolution on the card it self plus set it to performance.

I don't know why your cards change automatic back to the other resolution. You will get help from somebody on here don't give up. and Good luck
m
0
l
December 24, 2011 3:35:40 AM

DM186 said:
Man that sucks I know how you feel. When I first got Shogun 2 It would not let me run in DX11 plus a lot of freezing plus CTD's. They finally put out a patch and now It works just like you no problems.

I don't know what you go into on the ATI cards properties menu. But with Nvidia we can change the resolution on the card it self plus set it to performance.

I don't know why your cards change automatic back to the other resolution. You will get help from somebody on here don't give up. and Good luck

Huh. Should've gone with Nvidia, haha. But honestly I don't know that that would have changed it, no matter where I try to change the resolution, it never actually changes.

Thanks, though. I'll keep trying.
m
0
l
Related resources
December 25, 2011 2:10:51 AM

One more thought. I have the option to either let the game control the settings or my card controls the settings. Again I don't know If that would be in your controll settings.

If anybody who reads this step in and help this person.
m
0
l
January 9, 2012 12:37:16 AM

I just wanted to say I've been having exactly the same issue. When every I try to run any games in Directx 11 they only have low res options. With Directx 9 they all work fine. The games include Batman:AC, Deus EX, Saints Row the Third and Crysis 2. I have A Geforce GTX 560TI Card. Also, it doesn't matter if I let my card or the games control resolution.
m
0
l
January 9, 2012 1:56:17 AM

have you tried running the game as administrator?. reason? if you dont then the game wont have enough privs to write to the system folder where you installed the game...
if thats not the reason then try manually editing the games cfg files. C:\Users\your account name\Saved Games\Crysis2
you want the config to read as follows... (you can cut and paste it if you wish)
--------------------------------------------cut here------------------------------------
-- [Game-Configuration]
-- Attention: This file is re-generated by the system! Editing is not recommended!

r_Driver = "DX9"
r_fullscreen = 1
r_Height = 1080
r_Width = 1920
sys_spec = 4
---------------------------------------------- cut here----------------------------------
you can change dx9 to dx11 but only if you have the dx11 patch installed.
width and hight can be any legit screen size you want as long as your monitor supports it...
save the file into the above user folder calling it game.cfg
m
0
l
January 9, 2012 2:02:11 AM

if its happening with more than 1 game then your either not giving your game exe files the right privs or you have a driver issue. the driver may be crashing when you start the game so the system reverts back to the standard vga driver that all card support. the system will only do this if it cant restart the driver which is something it should do on a fail...
to check if this is an issue go to ctrlpannel/admin tools eventviewer/system, or application. look for red fails related to the games boot time...
m
0
l
January 9, 2012 8:22:39 PM

^+1
You can go that route but if you do make sure you back up everything before making any changes in the configuration. Hexit is good when it comes to this type of stuff.
m
0
l
January 9, 2012 10:29:27 PM

An update, I tried unplugging the hdmi cable from my t.v and plugging it into a monitor without restarting my pc. When I ran a game I had all resolutions to choose from with DX 11. So, I sat the resolution to 1920 x 1080, then I switched the HDMI cable again. I then had HD running with DX 11 enabled on my t.v. However, when I restarted the game I had the original problem again (no hi res in DX 111280 x 720 was the highest. ). This must be an issue between the display reporting it's resolutions. For the record I have a 32'' sylvania t.v with a max res of 1080i .
m
0
l
January 11, 2012 12:07:33 AM

When you hook up your computer through the HDMI to your TV Are you still leaving the your cable or Direct tv box still hooked up? This is a long shot maybe your TV on the first channel is 1080i and second input is 720i. Anything is worth a try at this point.
m
0
l
January 11, 2012 1:17:14 AM

your getting close. there is an issue with hdmi and not selecting the right outputs fo tv's its gonna take a little hunting down but i am gonna look for the fix. i know for sure it has something to do with the gfx control panel on nvidia cards. im not so sure about a solution to amd's
m
0
l
January 11, 2012 12:10:55 PM

Alright, I tried Dm's solution, that didn't work. Which follows because in dx 9 I can select any resolution I want. I called Nvidia, the guy said he had never heard of this problem and blamed my T.V. Of course when I called my T.V people they blamed Nvidia. Nither one offered a solution. I also tryed tweeking every setting in the control panel, no luck there, but I may have missed something, I'll keep looking. Thanks for the help so far guys.
m
0
l
January 11, 2012 11:31:17 PM

cskoler said:
Huh. Should've gone with Nvidia, haha. But honestly I don't know that that would have changed it, no matter where I try to change the resolution, it never actually changes.

Thanks, though. I'll keep trying.



Hey did you get your problem taken care of? We were helping you and kinda got side track sorry for that.
m
0
l
January 13, 2012 12:49:56 AM

Hey again guys, after doing some more reading, I believe the issue is that dx 11 just doesn't support interlaced resolutions. I still haven't been able to find a way around it. I think I might be in the market for a new t.v. Until then I need to figure out if games are better in 720p and dx 11 or 1080i and dx 9...
I think I'll be3 getting that new t.v very soon. If you guys come across anything that might be able to help let me know plz.

P.S I wasnt able to figure out a way to remove Nvidia control panel without uninstalling my driver.
m
0
l
January 13, 2012 2:47:17 AM

Ok if I hear anything I will look this thread up and post. Good luck to you on the TV
m
0
l
March 16, 2012 7:05:36 PM

Sorry for late reply guys, but i jsut got a new game machine and a new tv: Samsung UA-40D6000 .
i got the same problem and was wondering if there is any solution to this problem:(  i just spend 1000 bucks on the tv and 1500 bucks on the pc, i dont wanne buy a seperate pc monitor now, and they also dont sell any reasonably pc monitors here in cambodia. :( 
I know this is an old thread but i hope someone can help me out.

i got an AMD radeon Powercolor 7950HD Pci.|

Thanks alot in advance!
m
0
l
March 16, 2012 7:32:27 PM

paas said:
Sorry for late reply guys, but i jsut got a new game machine and a new tv: Samsung UA-40D6000 .
i got the same problem and was wondering if there is any solution to this problem:(  i just spend 1000 bucks on the tv and 1500 bucks on the pc, i dont wanne buy a seperate pc monitor now, and they also dont sell any reasonably pc monitors here in cambodia. :( 
I know this is an old thread but i hope someone can help me out.

i got an AMD radeon Powercolor 7950HD Pci.|

Thanks alot in advance!

Well, for me it actually turned out that the problem was the 1080i monitor I was using. DX11 and many games' resolution settings just don't play nice in general with 1080i. I'm not sure if that TV is 1080i, but when I switched to a normal 1080p monitor, everything was fixed. Unfortunately, it doesn't seem like there's any fix except to get yourself a 1080p monitor. Unless that TV already is 1080p, in which case I have no idea, sorry.
m
0
l
March 16, 2012 8:23:09 PM

I am confused. Did the OP change his name or is someone trying to take over this thread? Is paas the OP cskoler? And is ssjbud the OP cskoler? This is weird. They all act like they are the OP.
m
0
l
March 16, 2012 8:58:29 PM

DM186 said:
I am confused. Did the OP change his name or is someone trying to take over this thread? Is paas the OP cskoler? And is ssjbud the OP cskoler? This is weird. They all act like they are the OP.

lol i'm the OP, I had just solved the problem a while ago and so hadn't been back to this thread.
m
0
l
March 16, 2012 9:24:55 PM

Well that is good to hear and Hat's off to you for fixing your problem. I knew you were the OP but who are the other two people acting like this was there thread that is what had me confused. I was thinking you changed your name a couple of times. LOL Any way Good luck to you.
m
0
l
!