Sign in with
Sign up | Sign in
Your question

StarCraft II Black Screen With Sound Crash!!?? HELP

Last response: in Video Games
Share
January 5, 2012 11:42:23 AM

Hi Guys,

A couple times a night while playing sc2 the game will crash with a totally black screen but the sound will still be playing. I cannot alt-tab/ctrl-alt-del and the only solution is too hard reset the computer. It seems to only happen when loading a level/multi player match. eg:

I'm playing a 3v3 online, a match is found and and I'm in the loading screen. Everyone finishes loading and when the game starts the screen goes black with the lobby music sound still playing. Hard reset.

Same happens after a match ends. When game finishes and loads the score screen, it crashes exactly the same way.

This also happened while playing the single player mode with the loading screens.

I looked up Google but couldn't find a thread with a similar problem/solution. It almost seems like my SSD is hanging but it only happens during sc2.

Please Help!

Build:

Win 7 Pro 64
i7 2600k
Asus Maximus Extreme Z
GTX 590
corsair vengeance LP 1600
corsair 1050W HX Pro
OCZ Agility 3 120GB
WD 1TB Caviar Black

January 5, 2012 8:23:03 PM

Sounds like unstable overclock or voltage too low on the gpu. Blizzard games are pretty touchy with gpu speeds.
m
0
l
January 5, 2012 8:56:05 PM

It is possible, I will monitor for that over the next few days, although I do not have my GPU overclocked.

I tried the frameratecap = 60, frameratecapglue = 30 tweak and so far it hasn't crashed in a few games, will update this post when verified.
m
0
l
Related resources
January 7, 2012 6:56:34 PM

So far this fix seems to have worked!
m
0
l
May 11, 2012 7:21:29 PM

Ehm im not good at this so please try to be as basic as you can please explain where and how you changed "I tried the frameratecap = 60, frameratecapglue = 30 tweak and so far it hasn't crashed in a few games, will update this post when verified."
m
0
l
!