Sign in with
Sign up | Sign in
Your question

Crysis 2 multiplayer very choppy

Last response: in Video Games
Share
January 6, 2012 2:11:33 AM

Quite simple. Getting HORRENDOUSLY low frame rates in multiplayer on Crysis 2.

Single player is fine. 1080p using Very High getting solid 35-40 FPS with no motion blur.

Multiplayer is a whole different boat. I get 9 FPS if the server population is over about 9 or 10 players. Reduced my game to 800 x 600 and set graphics down to High (lowest). Framerates rose to only rose 12-15 and i was still getting really bad mouse lag. Unacceptable.

So WTF is up here? Single player works just fine on Very High but multiplayer is a slideshow even on lowest res and graphics setting? waste of $60.
Can someone help without immediately jumping to buying new hardware unless it really comes to that? If Crytek did their benchmarks and research and put the right minimum requirements on the game then how come my multiplayer framerates are so bad?

Crysis 2 Min Reqs:
-Intel Core 2 Duo or AMD Athlon 64 X2 4000+ @ 2ghz
-ATI Radeon HD 3850 or NVIDIA GeForce 8800 GT with 512 mb
-2gb RAM (XP) or 3gb (Vista/7)

My System:
-Windows 7 Pro 64 bit
-AMD Athlon 64 X2 7550 @ 2.5ghz
-EVGA GeForce 550 Ti 1024mb
-4 gb DDR2 800 mhz memory
-system on an MSI K9N6PGM2-V mobo

I might also add that framerates tended to drop when i was looking towards the mass of players. If i stay on the edges of a map and never look towards the middle or play in an empty or low population server it stays playable but thats bullshit. I should not have to do this.
January 6, 2012 7:08:36 AM

your rite there is an issue there. update your gfx drivers... if that doesnt help run the game in dx9 mode (i think you right click on the icon and select it from there)...
turn your rez up as you have a 1 gig card so running at max rez wont really affect over all system performance. but turn the quality settings down to minimum as your gfx card is only just better than minimum requirements as far as shaders and rops go..
finaly if your memory has heatsyncs on it try bumping it to 900mhz. this should give a little extra bandwidth. if it wont let you oc the ram then try reducing its latency
m
0
l
January 7, 2012 3:45:44 AM

graphics drivers are already up to date. using forceware 285.62

OCd processor up to 2.85ghz with nTune and brought the RAM up to 912mhz. Changed HT Bus multiplier from 2.0x to 3.0x. Graphics card is OCd to 1005mhz on core and 2000 on shaders.

still seeing slideshows on populated servers. Also the GPU use is a rollercoaster ride on Afterburner. CPU is 100% constantly. This is definitely a CPU thing.

this just proves it:
http://www.techspot.com/review/379-crysis-2-performance...

If a GTX 590 was playing at crappy framerates on dual cores then just imagine what a 550 Ti would be like with only a 6th the pipelines.

They either really botched the minimum requirements or have the most terribly optimized network and physics of all time. Dammit Crytek if it takes a quad core to run things smoothly then just post that is the requirement.
m
0
l
January 7, 2012 9:53:02 AM

ah i just noticed your on a dual core. your gfx is bottlenecking on the cpu... there is little you can do except upgrade it. running in dx9 will help a little but you want the settings turned up as far as they will go in order to offload from the cpu... or you can turn on vsnc. uninstall the high rez textures if you have em and run the game at minimum quality forcing 30fps max... this will smooth out the gamplay...
in order to limit the game to 30 fps you will have to go into the desktop display options and select 30hz from the rez dropdown. if your monitor will support it... most 60hz
lcd models do. so hopefully it will help
m
0
l
!