Sign in with
Sign up | Sign in
Your question

WinXP Prof-SP2 shows Linux Partition as a RAW Drive (I i..

Last response: in Windows XP
Share
May 7, 2005 12:49:14 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

PROBLEM:
1. My Win XP Professional (SP2) installation shows my Linux Ext2FS
partition (logical drive) after installation of Roxio Easy CD Creator
6.0. I had a stable system without any problems prior to this install.
2. Computer Management->Disk Management does not list drive letters for
any of my partitions except the CD/DVD Drive. Neither does it list the
drive when individually selected.
3. The above problems occur only in my WinXP installation. My Win2000
Prof installation does not have this problem. Problem occured post
instal of Roxio Easy CD Creator 6.0 in my XP installation.

SYSTEM CONFIG:
1. Stable Triple boot WinXP_Prof(SP2)/Win2000_Prof(Sp4)/Fedora Core 3.0
Linux installed on my 80GB IDE (Seagate) HDD. The system config is: AMD
Athlon XP 2600+ on ASUS A7V400-MX Motherboard using VIA KM400A Chipset.
512 MB RAM, LG 16x DvD ROM/CD Writer.
2. No Viruses/Spyware, system running automatic updates with Win XP SP2
installed with latest patches, ant virus updates and up to date
Zonealam Firewall.

TRIED:
1. Removing HKLM\System\MountedDevices (All entries except default)
2. FDISK /MBR
3. Removing Logical drive.

DETAILED PROBLEM DESCRIPTION:
The following is the partitioning scheme in disk order:
1. Primary Partition C: NTFS (WindowsXP) - 9.75 GB (System)
2. Primary Partition F: NTFS (Windows2000) - 9.00 GB
3. Primary Partition G: NTFS (Music) - 25.00 GB
4. Extended Partition
5. Logical Drive D: NTFS (Dumps) - 14.75 GB
6. Logical Drive ext2fs (Linux) - 5.25 GB
7. Logical Drive E: FAT32 (Setup) - 10.75 GB.

(Please note that I installed Linux by shrinking my logical drive
(partition no.5 in my table) from 20 GB to 15 GB. I used qpartd from a
Linux Live CD. I've installed Fedora Core 3 on the new partition, which
has been running fine for the past 2 months)

The following is the dump from Partition Info (Powerquest Software):
====================================================================================================
Partition Information for Disk 1: 76,316.6 Megabytes
Volume PartType Status Size MB PartSect # StartSect
TotalSects
====================================================================================================
C: NTFS Pri,Boot 10,001.4 0 0 63
20,482,812
F: NTFS Pri 9,217.0 0 1 20,482,875
18,876,375
G: NTFS Pri 25,603.6 0 2 39,359,250
52,436,160
ExtendedX Pri 31,494.6 0 3 91,795,410
64,500,975
EPBR Log 15,100.2 None -- 91,795,410
30,925,125
D: NTFS Log 15,100.1 91,795,410 0 91,795,473
30,925,062
EPBR Log 5,381.1 133,741,125 1 122,720,535
11,020,590
I: Linux Ext3 Log 5,381.1 122,720,535 0 122,720,598
11,020,527
EPBR Log 11,013.3 91,795,410 1 133,741,125
22,555,260
E:NO NAME FAT32 Log 11,013.3 133,741,125 0 133,741,188
22,555,197
====================================================================================================

My XP installation is Win XP Professional with SP2 and up to date
patches. I recently installed Roxio Easy CD Creator 6.0 on my XP
installation. To my dismay, Post install I found my partitions driver
letters changed. More importantly, I suddenly found my Linux (ext2fs)
partition displayed as drive I: i.e.: 6th partition in the above tale.
On right clicking the drive (I) and checking properties, it displayed
the following:

Type: Local Disk
File System: RAW
Used Space: 0 bytes
Free Space: 0 bytes

To make matters worse, Easy CD Creator setup - post install operation
entered into an infinite install loop stating changes need to be
merged. Hence I cancelled the dialog and uninstalled Easy CD Creator.

However the drive assignment changes persist and more importantly, my
explorer windows continue to show drive I: (which on checking turns out
to be my Linux ext2fs partition). Moreover on running Disk Management,
I see that drive letters are not listed for any of my partitions except
my CD/DVD Drive. Neither does it display any drive letter when I try to
change the drive letters. The "Add" button is enabled but "Change" and
"Remove" buttons are disabled.

I have tried removing deleting all entries except default entry in
HKLM\SYSTEM\MountedDevices key but was unsuccessful. I have tried FDISK
/mbr from dos prompt which fails as well. On booting with my Windows
2000 professional installation however, I do not have any of the above
problems.

Now am at a loss trying to fix this problem. I do not want to reinstall
XP as it is running with all the latest patches with latest antivir and
firewall updates. I can confirm that there are no viruses/spyware
installed as I use only Firefox and Thunderbird and have automatic
updates turned on for Windows, the firewall as well as my Antivirus. I
have searched all over the Internet for solution was not able to find
any.


Your inputs/help would be appreciated.

Thanks.
Anonymous
May 10, 2005 3:06:51 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

You may wish to consult the Roxio web site on a failed installation.

Note: to correct the issue with changes needing to be merged, you need to
download and install all the latest patches "AND" most importantly the
ENGINE and DRIVER FILE updates from the Roxio Site. Yes it will keep giving
you the message until you do this - it is because the CD-RW and/or DVD-RW
you have installed is newer that the DRIVER INF file originally package with
EZCD 6.0 - BTDT (Been There Done That), as I too still use EZCD 6.0, but
when I replaced my DVD-RW with a new, state of the art DVD-+RW double layer,
EZCD just went crazy as it didn't have any information on it - as soon as I
installed the ENGINE and DRIVE FILE updates - poof - it all works again.

--

Star Fleet Admiral Q @ your Service!

http://www.google.com
Google is your "Friend"

"SK" <skramachandran@gmail.com> wrote in message
news:1115480954.635439.13140@z14g2000cwz.googlegroups.com...
> PROBLEM:
> 1. My Win XP Professional (SP2) installation shows my Linux Ext2FS
> partition (logical drive) after installation of Roxio Easy CD Creator
> 6.0. I had a stable system without any problems prior to this install.
> 2. Computer Management->Disk Management does not list drive letters for
> any of my partitions except the CD/DVD Drive. Neither does it list the
> drive when individually selected.
> 3. The above problems occur only in my WinXP installation. My Win2000
> Prof installation does not have this problem. Problem occured post
> instal of Roxio Easy CD Creator 6.0 in my XP installation.
>
> SYSTEM CONFIG:
> 1. Stable Triple boot WinXP_Prof(SP2)/Win2000_Prof(Sp4)/Fedora Core 3.0
> Linux installed on my 80GB IDE (Seagate) HDD. The system config is: AMD
> Athlon XP 2600+ on ASUS A7V400-MX Motherboard using VIA KM400A Chipset.
> 512 MB RAM, LG 16x DvD ROM/CD Writer.
> 2. No Viruses/Spyware, system running automatic updates with Win XP SP2
> installed with latest patches, ant virus updates and up to date
> Zonealam Firewall.
>
> TRIED:
> 1. Removing HKLM\System\MountedDevices (All entries except default)
> 2. FDISK /MBR
> 3. Removing Logical drive.
>
> DETAILED PROBLEM DESCRIPTION:
> The following is the partitioning scheme in disk order:
> 1. Primary Partition C: NTFS (WindowsXP) - 9.75 GB (System)
> 2. Primary Partition F: NTFS (Windows2000) - 9.00 GB
> 3. Primary Partition G: NTFS (Music) - 25.00 GB
> 4. Extended Partition
> 5. Logical Drive D: NTFS (Dumps) - 14.75 GB
> 6. Logical Drive ext2fs (Linux) - 5.25 GB
> 7. Logical Drive E: FAT32 (Setup) - 10.75 GB.
>
> (Please note that I installed Linux by shrinking my logical drive
> (partition no.5 in my table) from 20 GB to 15 GB. I used qpartd from a
> Linux Live CD. I've installed Fedora Core 3 on the new partition, which
> has been running fine for the past 2 months)
>
> The following is the dump from Partition Info (Powerquest Software):
> ====================================================================================================
> Partition Information for Disk 1: 76,316.6 Megabytes
> Volume PartType Status Size MB PartSect # StartSect
> TotalSects
> ====================================================================================================
> C: NTFS Pri,Boot 10,001.4 0 0 63
> 20,482,812
> F: NTFS Pri 9,217.0 0 1 20,482,875
> 18,876,375
> G: NTFS Pri 25,603.6 0 2 39,359,250
> 52,436,160
> ExtendedX Pri 31,494.6 0 3 91,795,410
> 64,500,975
> EPBR Log 15,100.2 None -- 91,795,410
> 30,925,125
> D: NTFS Log 15,100.1 91,795,410 0 91,795,473
> 30,925,062
> EPBR Log 5,381.1 133,741,125 1 122,720,535
> 11,020,590
> I: Linux Ext3 Log 5,381.1 122,720,535 0 122,720,598
> 11,020,527
> EPBR Log 11,013.3 91,795,410 1 133,741,125
> 22,555,260
> E:NO NAME FAT32 Log 11,013.3 133,741,125 0 133,741,188
> 22,555,197
> ====================================================================================================
>
> My XP installation is Win XP Professional with SP2 and up to date
> patches. I recently installed Roxio Easy CD Creator 6.0 on my XP
> installation. To my dismay, Post install I found my partitions driver
> letters changed. More importantly, I suddenly found my Linux (ext2fs)
> partition displayed as drive I: i.e.: 6th partition in the above tale.
> On right clicking the drive (I) and checking properties, it displayed
> the following:
>
> Type: Local Disk
> File System: RAW
> Used Space: 0 bytes
> Free Space: 0 bytes
>
> To make matters worse, Easy CD Creator setup - post install operation
> entered into an infinite install loop stating changes need to be
> merged. Hence I cancelled the dialog and uninstalled Easy CD Creator.
>
> However the drive assignment changes persist and more importantly, my
> explorer windows continue to show drive I: (which on checking turns out
> to be my Linux ext2fs partition). Moreover on running Disk Management,
> I see that drive letters are not listed for any of my partitions except
> my CD/DVD Drive. Neither does it display any drive letter when I try to
> change the drive letters. The "Add" button is enabled but "Change" and
> "Remove" buttons are disabled.
>
> I have tried removing deleting all entries except default entry in
> HKLM\SYSTEM\MountedDevices key but was unsuccessful. I have tried FDISK
> /mbr from dos prompt which fails as well. On booting with my Windows
> 2000 professional installation however, I do not have any of the above
> problems.
>
> Now am at a loss trying to fix this problem. I do not want to reinstall
> XP as it is running with all the latest patches with latest antivir and
> firewall updates. I can confirm that there are no viruses/spyware
> installed as I use only Firefox and Thunderbird and have automatic
> updates turned on for Windows, the firewall as well as my Antivirus. I
> have searched all over the Internet for solution was not able to find
> any.
>
>
> Your inputs/help would be appreciated.
>
> Thanks.
>
!