Crysis running ridiculously low on high end system

I recently started playing around with the Crysis mods in order to improve performance and graphics, and I used the CCC v 2.21 mod at level 6 (the highest setting possible). I'm more than a little annoyed when I figured that the game is running much slower than it should on my system.

My Specs:

i5 2500k OC'ed to 4.4 ghz
MSI twin frozr ii 6950 2gb OC'ed to 840mhz
8 gb kingston hyperx 1600 ram
MSI P67A C43 mobo

playing on CCC 2.21 mod level 6, 2xAA 1680X1050 resolution

I'm only getting around 25-30ish frames on the first level and I've read a lot of posts online of people reporting 40-60 fps with the same settings I'm using but much lower specs, and I'm sure my GPU and CPU should be able to run this game no matter what setting or mod/configuration I use. I know Crysis is still a very demanding game despite the fact that its about 5 years old, but its ridiculous that I can run BF3 Skyrim and Crysis 2 all on Ultra stably but this game stutters so much.

Can anyone help me figure out what the problem may be, I don't think its a bottleneck issue and I checked for latest AMD drivers from the official website and it said everything was up to date. I appreciate any help I can get.
20 answers Last reply
More about crysis running ridiculously high system
  1. Cryis runs lilke crap on any computer! I get around 40 fps maxed out at 1920 x 1080 with dual gtx 570's and an i7 950

    Direct x 10 is well known for poor performance.
  2. Well I changed my settings in the CCC mod to level 5 which is still more demanding than very high vanilla settings (from what I understand) and its actually running decently between 45-70 fps. I still don't understand how others with less powerful CPU's and GPU's than mine are able to run level 6 with smoother framerates however, if anyone has any idea please don't hesitate to inform me.
  3. lawilahd said:
    I recently started playing around with the Crysis mods in order to improve performance and graphics, and I used the CCC v 2.21 mod at level 6 (the highest setting possible). I'm more than a little annoyed when I figured that the game is running much slower than it should on my system.

    My Specs:

    i5 2500k OC'ed to 4.4 ghz
    MSI twin frozr ii 6950 2gb OC'ed to 840mhz
    8 gb kingston hyperx 1600 ram
    MSI P67A C43 mobo

    playing on CCC 2.21 mod level 6, 2xAA 1680X1050 resolution

    I'm only getting around 25-30ish frames on the first level and I've read a lot of posts online of people reporting 40-60 fps with the same settings I'm using but much lower specs, and I'm sure my GPU and CPU should be able to run this game no matter what setting or mod/configuration I use. I know Crysis is still a very demanding game despite the fact that its about 5 years old, but its ridiculous that I can run BF3 Skyrim and Crysis 2 all on Ultra stably but this game stutters so much.

    Can anyone help me figure out what the problem may be, I don't think its a bottleneck issue and I checked for latest AMD drivers from the official website and it said everything was up to date. I appreciate any help I can get.



    Turn your in-game menu AA off......EdgeAA is specified in the CCC autoexec, and if you turn on the Crysis AA it overrides it. Since you're only running 2x it shouldn't really be killing your framerate that badly though.

    Those are kind of numbers I get with CCC lvl6 (in the heavy veggied areas) with my antiquated old 5850, so I would definitely think you should be doing much better.

    FWIW, I prefer the Maximum Quality V1.00 autoexec. I like the way it looks and it runs much better for me. If you want to try it out I can paste it up for you.
  4. Stringjam said:


    FWIW, I prefer the Maximum Quality V1.00 autoexec. I like the way it looks and it runs much better for me. If you want to try it out I can paste it up for you.


    Throw it up, I might give it a try with my 2 5870's.
  5. Turning off the in game AA still gives me around the same FPS so thats not the issue. BTW throw up that mod your talking about. So I guess this is just a really wierd problem or bad coding? I just expected it to run better on my computer than on lower hardware and like you said, you get the same numbers as me but with much older/lower specs.
  6. Here's Maximum Quality autoexec for anyone who wants:


    _____ ______ __ _ ______ _____ ______ Maximum Quality
    | |_____/ \_/ |_____ | |_____
    |_______| \___ | ________| __|__ ______| v 1.00
    |
    7 and vista
    _______________________________________________________________________
    _______________________________________________________________________
    con_restricted=0
    sys_spec_Full=4
    __________________________________________<AF&Filtering>_______________
    r_TexMaxAnisotropy=8
    r_UseEdgeAA=2
    __________________________________________________<Misc.>______________
    e_screenshot_file_format=jpg
    e_screenshot_height=2880
    e_screenshot_quality=100
    e_screenshot_width=5376
    r_displayinfo=0
    r_MultiGPU=2
    v_sync=0
    ______________________________________________<ObjectDetails>__________
    e_detail_materials_view_dist_xy=4096
    e_detail_materials_view_dist_z=256
    e_lods=1
    e_lod_ratio=10
    e_terrain_occlusion_culling_max_dist=1000
    e_vegetation_sprites_distance_ratio=1.7
    e_view_dist_ratio=80
    e_view_dist_ratio_detail=60
    e_view_dist_ratio_vegetation=50
    sys_flash_curve_tess_error=1
    ________________________________________________<Particles>____________
    e_particles_lod=1
    e_particles_max_emitter_draw_screen=48
    e_particles_thread=1
    e_particles_quality=4
    e_max_entity_lights=20
    e_water_ocean_soft_particles=1
    r_UseSoftParticles=1
    _________________________________________________<Physics>_____________
    e_cull_veg_activation=70
    e_foliage_wind_activation_dist=30
    e_phys_ocean_cell=0.2
    es_MaxPhysDist=100
    es_MaxPhysDistInvisible=25
    p_max_MC_iters=7000
    sys_physics_CPU=1
    ___________________________________________<PostProcessingEffects>_____
    cl_hitblur=0
    g_battleDust_enable=1
    g_battleRange=100
    r_ColorGrading=1
    r_ColorGradingFilters=1
    r_Coronas=1
    r_DepthOfField=2
    r_Flares=1
    r_MotionBlur=1
    r_sunshafts=1
    r_UsePom=1
    _____________________________________________<Shaders&Lighting>________
    r_HDRBrightOffset=8
    r_HDRlevel=0.75
    r_HDRRendering=2
    r_SSAO=1
    r_SSAO_amount=0.4
    r_SSAO_blur=4
    r_SSAO_blurriness=1
    r_SSAO_darkening=1.1
    r_SSAO_quality=2
    r_SSAO_radius=2
    _________________________________________________<Shadows>_____________
    e_shadows_cast_view_dist_ratio=0.8
    e_shadows_from_terrain_in_all_lods=1
    e_shadows_max_texture_size=1024
    e_shadows_on_alpha_blended=0
    r_ShadowBlur=3
    r_ShadowJittering=1.5
    r_TerrainAO_FadeDist=3
    _________________________________________________<Textures>____________
    r_DetailDistance=20
    r_DynTexMaxSize=100
    r_EnvCMResolution=2
    r_EnvTexResolution=3
    r_EnvTexUpdateInterval=0.025
    r_TexAtlasSize=2048
    r_TexResolution=0
    r_TextureLodDistanceRatio=0
    r_TextureLodMaxLod=0
    r_TexturesFilteringQuality=0
    r_ReflectionsQuality=3
    r_VegetationSpritesTexRes=128
    _____________________________________________<VolumetricEffects>_______
    r_Beams=3
    r_BeamsDistFactor=0.1
    r_BeamsMaxSlices=250
    _______________________________________________<WaterEffects>__________
    e_recursion_view_dist_ratio=0.15
    e_water_ocean_fft=1
    q_ShaderWater=3
    r_WaterCaustics=1
    r_WaterReflections=1
    r_WaterReflectionsMinVisiblePixelsUpdate=3
    r_WaterReflectionsQuality=3
    r_WaterRefractions=1
    r_WaterUpdateDistance=-1
    r_WaterUpdateFactor=0.01
    ________________________________________________<Mountains>____________
    e_terrain_lod_ratio=1
    e_terrain_normal_map=0
    e_terrain_texture_lod_ratio=1
    r_TexturesStreaming=0
    _______________________________________________________________________
    _______________________________________________________________________
  7. Also, since we're talking about autoexecs here, another one worth trying is Lavizh's CrySwitcher.

    I can't run it worth a darn with my 5850, but it looks pretty (a few weird things here and there....like some blue sand and rocks(?) )

    It's good if you like dramatic lighting....which I do (screw realism ;) ). Also seems to make the distance views look better than most of the custom configs I've tried.

    Here's a screen with CrySwitcher's autoexec:




    Another one with a long distance draw:

  8. Trialsking said:
    Throw it up, I might give it a try with my 2 5870's.

    Sorry to derail, where you been king?

    Anyhow crysis runs better than that on my single 570. No mods but ya AA is a killer in that game
  9. Well a 570 is better than a single 6950 so it should run better than mine (unless you were referring to someone else's post). Anyone know of any mods I can try which are equivelent to the CCC v2.21 level 6 in terms of graphics, performance and demand?? I'm starting to think it may be a problem with my install of the mod or the install of the crysis game itself.
  10. where can you get the ccc2.21 mod all the links i found seem to point to mycrysis which is pretty much closed down now.
  11. I'll host these in case anyone wants to give them a try. Hexit: my CCC lvl6 I believe has a few tweaks in it (I got it from the RealLoaded mod) but it should be very close.

    CrySwitcher is the most demanding of the three....moreso than CCC.


    (just right-click and save these, and don't forget to rename the file to just "autoexec" or it won't load)

    Helder Pinto

    CCC-lvl6

    CrySwitcher
  12. Is your game patched to the latest version?
  13. FlintIronStagg said:
    Sorry to derail, where you been king?



    Right here.

    Thanks for the config file.
  14. ah rite i get you... i thought it was an app going by what else i found...

    thanx for the links... any 1 else wants em just right click on the link and save as, to your destination folder... rename then as autoexec.bat and run there icons as admin.

    now i know what your doing im not suprised... make sure you turn fsaa off or you want get past 35fpf minimum even with x2 fsaa you will drop down to 20 on the beach after your second fire fight where you turn off the transmitter... i would say your settings are so high and the game is so badly optomized... you could try the LAA patch that was issued on the nexus forums and make sure the game is large address aware...(gonna try this 1 myself)
  15. Even when my AA is off from the game menu, I still get much lower than expected framerates. Ill try Cryswitcher and see if its better, even though apparently its more demanding.
  16. I got a question for those autoexecs, when I save them and rename to autoexec.bat the black window opens up that looks like the command prompt window and it goes through a bunch of really fast words but when I go in game to crysis all the settings are set to low. Are they supposed to be set to custom after running that autoexec?? I used the Crysis Switcher one btw
  17. you nwwd to open the properties of the bat file icon and set it to run as admin... if your game is installed on the primary drive... if its not then you may not have to...
    but no the game should accept the settings as is and work from the bat file...
    ie, click autoexec.bat. the game should start... go into settings and they should be maxed out. if you picked the max settings...


    in the bat file make sure your console is active or the bat file may not work properly...

    if it doesnt work try adding this to the filespec in the properties of the game exe
    you will see similar to this...
    "c: programfiles/rockstar/gta4/gta.exe"
    make it look like this
    "c: programfiles/rockstar/gta4/gta.exe" +con_restricted=0

    it may or maynot work but worth a try...
  18. lawilahd said:
    I got a question for those autoexecs, when I save them and rename to autoexec.bat the black window opens up that looks like the command prompt window and it goes through a bunch of really fast words but when I go in game to crysis all the settings are set to low. Are they supposed to be set to custom after running that autoexec?? I used the Crysis Switcher one btw



    ....Or you can just name the file autoexec.cfg and place it in the ../Crytek/Crysis/ folder. Probably the easiest method.

    Start up your game like normal - to see if it loaded, just hit the tilde key (~) when you get to the Crysis menu and the console will open.....you'll see a bunch of the console commands on the screen because the program executed them.


    Out of all these, I still recommend giving the one I pasted a try (Maximum Quality v.1.00). It runs better than any of these for me, and I really like the way it looks. Worth a try, anyway. I think CrySwitcher looks the best if you have a card that will run it (still trying to figure out how to get rid of some of the blue rocks and sand, though.)
  19. I did what you said with the Cryswitcher one and renamed the file to autoexec.cfg and placed in my crysis folder. It looks and runs the same as vanilla high so maybe I did something wrong. I saved the file, renamed it and placed it where you told me too. Nothing special pops up when I hit the tild key either so I think it didn't execute the cfg file. Anyway for the time being I'm sticking with the CCC level 5 as it is giving me between 50-90 fps but I do have one problem. No matter what I do, set r_vsync 1 ingame console, write it into system.cfg file or force vsync and triple buffering in my cards catalyst control center and I still get a lot of vertical tearing
  20. tripple buffering only works on opengl as far as i know... vsync should be an option in the games own options... my guess is your not running it with enough privs.
Ask a new question

Read More

PC gaming Crysis Video Games