Sign in with
Sign up | Sign in
Your question

Prob w/ Fast User Switching

Last response: in Windows XP
Share
Anonymous
May 31, 2005 10:23:23 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Searched newsgroups and KB, but can't find solution to my problem.

Windows XP Home has been "corrupted" and fast user switching no longer works.
When I try to switch and go back to the welcome screen -- if I select second
user the screen blinks and shows the desktop of the first logged in user,
then blinks back to welcome screen. Only way to switch is to log out from
first user then log on just one user at a time.

Terminal services is running, and I've tried unchecking fast user switching
in user profile, restarting, switching back, restarting, etc.
I'm at my wit's end -- Any help????
Anonymous
June 1, 2005 11:25:48 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Have you played with your pagefile settings?

--
Regards,

Richard Urban

aka Crusty (-: Old B@stard :-)

If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!


"Matt J" <Matt J@discussions.microsoft.com> wrote in message
news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> Searched newsgroups and KB, but can't find solution to my problem.
>
> Windows XP Home has been "corrupted" and fast user switching no longer
> works.
> When I try to switch and go back to the welcome screen -- if I select
> second
> user the screen blinks and shows the desktop of the first logged in user,
> then blinks back to welcome screen. Only way to switch is to log out from
> first user then log on just one user at a time.
>
> Terminal services is running, and I've tried unchecking fast user
> switching
> in user profile, restarting, switching back, restarting, etc.
> I'm at my wit's end -- Any help????
Anonymous
June 4, 2005 5:03:01 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Not recently. Keep it set at a fixed 1000MB.

"Richard Urban" wrote:

> Have you played with your pagefile settings?
>
> --
> Regards,
>
> Richard Urban
>
> aka Crusty (-: Old B@stard :-)
>
> If you knew as much as you think you know,
> You would realize that you don't know what you thought you knew!
>
>
> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > Searched newsgroups and KB, but can't find solution to my problem.
> >
> > Windows XP Home has been "corrupted" and fast user switching no longer
> > works.
> > When I try to switch and go back to the welcome screen -- if I select
> > second
> > user the screen blinks and shows the desktop of the first logged in user,
> > then blinks back to welcome screen. Only way to switch is to log out from
> > first user then log on just one user at a time.
> >
> > Terminal services is running, and I've tried unchecking fast user
> > switching
> > in user profile, restarting, switching back, restarting, etc.
> > I'm at my wit's end -- Any help????
>
>
>
Related resources
Anonymous
June 4, 2005 8:19:28 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Set it for "system managed" and try again! (-:

--
Regards,

Richard Urban

aka Crusty (-: Old B@stard :-)

If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!


"Matt J" <Matt J@discussions.microsoft.com> wrote in message
news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> Not recently. Keep it set at a fixed 1000MB.
>
> "Richard Urban" wrote:
>
>> Have you played with your pagefile settings?
>>
>> --
>> Regards,
>>
>> Richard Urban
>>
>> aka Crusty (-: Old B@stard :-)
>>
>> If you knew as much as you think you know,
>> You would realize that you don't know what you thought you knew!
>>
>>
>> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
>> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
>> > Searched newsgroups and KB, but can't find solution to my problem.
>> >
>> > Windows XP Home has been "corrupted" and fast user switching no longer
>> > works.
>> > When I try to switch and go back to the welcome screen -- if I select
>> > second
>> > user the screen blinks and shows the desktop of the first logged in
>> > user,
>> > then blinks back to welcome screen. Only way to switch is to log out
>> > from
>> > first user then log on just one user at a time.
>> >
>> > Terminal services is running, and I've tried unchecking fast user
>> > switching
>> > in user profile, restarting, switching back, restarting, etc.
>> > I'm at my wit's end -- Any help????
>>
>>
>>
Anonymous
June 4, 2005 8:19:29 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

What's your thinking in terms of potential solution? Page file is contiguous
now -- won't resetting chunk it up?

"Richard Urban" wrote:

> Set it for "system managed" and try again! (-:
>
> --
> Regards,
>
> Richard Urban
>
> aka Crusty (-: Old B@stard :-)
>
> If you knew as much as you think you know,
> You would realize that you don't know what you thought you knew!
>
>
> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > Not recently. Keep it set at a fixed 1000MB.
> >
> > "Richard Urban" wrote:
> >
> >> Have you played with your pagefile settings?
> >>
> >> --
> >> Regards,
> >>
> >> Richard Urban
> >>
> >> aka Crusty (-: Old B@stard :-)
> >>
> >> If you knew as much as you think you know,
> >> You would realize that you don't know what you thought you knew!
> >>
> >>
> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> >> > Searched newsgroups and KB, but can't find solution to my problem.
> >> >
> >> > Windows XP Home has been "corrupted" and fast user switching no longer
> >> > works.
> >> > When I try to switch and go back to the welcome screen -- if I select
> >> > second
> >> > user the screen blinks and shows the desktop of the first logged in
> >> > user,
> >> > then blinks back to welcome screen. Only way to switch is to log out
> >> > from
> >> > first user then log on just one user at a time.
> >> >
> >> > Terminal services is running, and I've tried unchecking fast user
> >> > switching
> >> > in user profile, restarting, switching back, restarting, etc.
> >> > I'm at my wit's end -- Any help????
> >>
> >>
> >>
>
>
>
Anonymous
June 5, 2005 2:57:31 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

If the pagefile can not grow to what is ultimately required for fast user
switching, you may crash the system or cause it to hang. I have found that
some users who have altered their pagefile from what was the defaults have
had this problem.

First things first. Did you try as I suggested with the pagefile? Pagefile
fragmentation can always be dealt with later!

--
Regards,

Richard Urban

aka Crusty (-: Old B@stard :-)

If you knew as much as you think you know,
You would realize that you don't know what you thought you knew!


"Matt J" <MattJ@discussions.microsoft.com> wrote in message
news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> What's your thinking in terms of potential solution? Page file is
> contiguous
> now -- won't resetting chunk it up?
>
> "Richard Urban" wrote:
>
>> Set it for "system managed" and try again! (-:
>>
>> --
>> Regards,
>>
>> Richard Urban
>>
>> aka Crusty (-: Old B@stard :-)
>>
>> If you knew as much as you think you know,
>> You would realize that you don't know what you thought you knew!
>>
>>
>> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
>> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
>> > Not recently. Keep it set at a fixed 1000MB.
>> >
>> > "Richard Urban" wrote:
>> >
>> >> Have you played with your pagefile settings?
>> >>
>> >> --
>> >> Regards,
>> >>
>> >> Richard Urban
>> >>
>> >> aka Crusty (-: Old B@stard :-)
>> >>
>> >> If you knew as much as you think you know,
>> >> You would realize that you don't know what you thought you knew!
>> >>
>> >>
>> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
>> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
>> >> > Searched newsgroups and KB, but can't find solution to my problem.
>> >> >
>> >> > Windows XP Home has been "corrupted" and fast user switching no
>> >> > longer
>> >> > works.
>> >> > When I try to switch and go back to the welcome screen -- if I
>> >> > select
>> >> > second
>> >> > user the screen blinks and shows the desktop of the first logged in
>> >> > user,
>> >> > then blinks back to welcome screen. Only way to switch is to log
>> >> > out
>> >> > from
>> >> > first user then log on just one user at a time.
>> >> >
>> >> > Terminal services is running, and I've tried unchecking fast user
>> >> > switching
>> >> > in user profile, restarting, switching back, restarting, etc.
>> >> > I'm at my wit's end -- Any help????
>> >>
>> >>
>> >>
>>
>>
>>
Anonymous
June 8, 2005 10:50:02 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
improvement.

Interesting sidebar -- also tried changing settings for Processor Scheduling
to "Background Services" and Memory usage to "System Cache." System failed
repatedly at start-up until I rolled back changed settings.

Any additional suggestions?

"Richard Urban" wrote:

> If the pagefile can not grow to what is ultimately required for fast user
> switching, you may crash the system or cause it to hang. I have found that
> some users who have altered their pagefile from what was the defaults have
> had this problem.
>
> First things first. Did you try as I suggested with the pagefile? Pagefile
> fragmentation can always be dealt with later!
>
> --
> Regards,
>
> Richard Urban
>
> aka Crusty (-: Old B@stard :-)
>
> If you knew as much as you think you know,
> You would realize that you don't know what you thought you knew!
>
>
> "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > What's your thinking in terms of potential solution? Page file is
> > contiguous
> > now -- won't resetting chunk it up?
> >
> > "Richard Urban" wrote:
> >
> >> Set it for "system managed" and try again! (-:
> >>
> >> --
> >> Regards,
> >>
> >> Richard Urban
> >>
> >> aka Crusty (-: Old B@stard :-)
> >>
> >> If you knew as much as you think you know,
> >> You would realize that you don't know what you thought you knew!
> >>
> >>
> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> >> > Not recently. Keep it set at a fixed 1000MB.
> >> >
> >> > "Richard Urban" wrote:
> >> >
> >> >> Have you played with your pagefile settings?
> >> >>
> >> >> --
> >> >> Regards,
> >> >>
> >> >> Richard Urban
> >> >>
> >> >> aka Crusty (-: Old B@stard :-)
> >> >>
> >> >> If you knew as much as you think you know,
> >> >> You would realize that you don't know what you thought you knew!
> >> >>
> >> >>
> >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> >> >> >
> >> >> > Windows XP Home has been "corrupted" and fast user switching no
> >> >> > longer
> >> >> > works.
> >> >> > When I try to switch and go back to the welcome screen -- if I
> >> >> > select
> >> >> > second
> >> >> > user the screen blinks and shows the desktop of the first logged in
> >> >> > user,
> >> >> > then blinks back to welcome screen. Only way to switch is to log
> >> >> > out
> >> >> > from
> >> >> > first user then log on just one user at a time.
> >> >> >
> >> >> > Terminal services is running, and I've tried unchecking fast user
> >> >> > switching
> >> >> > in user profile, restarting, switching back, restarting, etc.
> >> >> > I'm at my wit's end -- Any help????
> >> >>
> >> >>
> >> >>
> >>
> >>
> >>
>
>
>
Anonymous
June 9, 2005 1:09:06 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Use the default Virtual memory settings and your problem will
go away.

--
Carey Frisch
Microsoft MVP
Windows XP - Shell/User
Microsoft Newsgroups

Get Windows XP Service Pack 2 with Advanced Security Technologies:
http://www.microsoft.com/athome/security/protect/window...

-------------------------------------------------------------------------------------------

"Matt J" wrote in:

| Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
| improvement.
|
| Interesting sidebar -- also tried changing settings for Processor Scheduling
| to "Background Services" and Memory usage to "System Cache." System failed
| repatedly at start-up until I rolled back changed settings.
|
| Any additional suggestions?
|
| "Richard Urban" wrote:
|
| > If the pagefile can not grow to what is ultimately required for fast user
| > switching, you may crash the system or cause it to hang. I have found that
| > some users who have altered their pagefile from what was the defaults have
| > had this problem.
| >
| > First things first. Did you try as I suggested with the pagefile? Pagefile
| > fragmentation can always be dealt with later!
| >
| > --
| > Regards,
| >
| > Richard Urban
| >
| > aka Crusty (-: Old B@stard :-)
| >
| > If you knew as much as you think you know,
| > You would realize that you don't know what you thought you knew!
| >
| >
| > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
| > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
| > > What's your thinking in terms of potential solution? Page file is
| > > contiguous
| > > now -- won't resetting chunk it up?
| > >
| > > "Richard Urban" wrote:
| > >
| > >> Set it for "system managed" and try again! (-:
| > >>
| > >> --
| > >> Regards,
| > >>
| > >> Richard Urban
| > >>
| > >> aka Crusty (-: Old B@stard :-)
| > >>
| > >> If you knew as much as you think you know,
| > >> You would realize that you don't know what you thought you knew!
| > >>
| > >>
| > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
| > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
| > >> > Not recently. Keep it set at a fixed 1000MB.
| > >> >
| > >> > "Richard Urban" wrote:
| > >> >
| > >> >> Have you played with your pagefile settings?
| > >> >>
| > >> >> --
| > >> >> Regards,
| > >> >>
| > >> >> Richard Urban
| > >> >>
| > >> >> aka Crusty (-: Old B@stard :-)
| > >> >>
| > >> >> If you knew as much as you think you know,
| > >> >> You would realize that you don't know what you thought you knew!
| > >> >>
| > >> >>
| > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
| > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
| > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
| > >> >> >
| > >> >> > Windows XP Home has been "corrupted" and fast user switching no
| > >> >> > longer
| > >> >> > works.
| > >> >> > When I try to switch and go back to the welcome screen -- if I
| > >> >> > select
| > >> >> > second
| > >> >> > user the screen blinks and shows the desktop of the first logged in
| > >> >> > user,
| > >> >> > then blinks back to welcome screen. Only way to switch is to log
| > >> >> > out
| > >> >> > from
| > >> >> > first user then log on just one user at a time.
| > >> >> >
| > >> >> > Terminal services is running, and I've tried unchecking fast user
| > >> >> > switching
| > >> >> > in user profile, restarting, switching back, restarting, etc.
| > >> >> > I'm at my wit's end -- Any help????
| > >> >>
| > >> >>
| > >> >>
| > >>
| > >>
| > >>
| >
| >
| >
Anonymous
June 10, 2005 6:37:02 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

By default do you mean system managed? That's what I just did -- no
improvement.

"Carey Frisch [MVP]" wrote:

> Use the default Virtual memory settings and your problem will
> go away.
>
> --
> Carey Frisch
> Microsoft MVP
> Windows XP - Shell/User
> Microsoft Newsgroups
>
> Get Windows XP Service Pack 2 with Advanced Security Technologies:
> http://www.microsoft.com/athome/security/protect/window...
>
> -------------------------------------------------------------------------------------------
>
> "Matt J" wrote in:
>
> | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> | improvement.
> |
> | Interesting sidebar -- also tried changing settings for Processor Scheduling
> | to "Background Services" and Memory usage to "System Cache." System failed
> | repatedly at start-up until I rolled back changed settings.
> |
> | Any additional suggestions?
> |
> | "Richard Urban" wrote:
> |
> | > If the pagefile can not grow to what is ultimately required for fast user
> | > switching, you may crash the system or cause it to hang. I have found that
> | > some users who have altered their pagefile from what was the defaults have
> | > had this problem.
> | >
> | > First things first. Did you try as I suggested with the pagefile? Pagefile
> | > fragmentation can always be dealt with later!
> | >
> | > --
> | > Regards,
> | >
> | > Richard Urban
> | >
> | > aka Crusty (-: Old B@stard :-)
> | >
> | > If you knew as much as you think you know,
> | > You would realize that you don't know what you thought you knew!
> | >
> | >
> | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> | > > What's your thinking in terms of potential solution? Page file is
> | > > contiguous
> | > > now -- won't resetting chunk it up?
> | > >
> | > > "Richard Urban" wrote:
> | > >
> | > >> Set it for "system managed" and try again! (-:
> | > >>
> | > >> --
> | > >> Regards,
> | > >>
> | > >> Richard Urban
> | > >>
> | > >> aka Crusty (-: Old B@stard :-)
> | > >>
> | > >> If you knew as much as you think you know,
> | > >> You would realize that you don't know what you thought you knew!
> | > >>
> | > >>
> | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> | > >> > Not recently. Keep it set at a fixed 1000MB.
> | > >> >
> | > >> > "Richard Urban" wrote:
> | > >> >
> | > >> >> Have you played with your pagefile settings?
> | > >> >>
> | > >> >> --
> | > >> >> Regards,
> | > >> >>
> | > >> >> Richard Urban
> | > >> >>
> | > >> >> aka Crusty (-: Old B@stard :-)
> | > >> >>
> | > >> >> If you knew as much as you think you know,
> | > >> >> You would realize that you don't know what you thought you knew!
> | > >> >>
> | > >> >>
> | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> | > >> >> >
> | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> | > >> >> > longer
> | > >> >> > works.
> | > >> >> > When I try to switch and go back to the welcome screen -- if I
> | > >> >> > select
> | > >> >> > second
> | > >> >> > user the screen blinks and shows the desktop of the first logged in
> | > >> >> > user,
> | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> | > >> >> > out
> | > >> >> > from
> | > >> >> > first user then log on just one user at a time.
> | > >> >> >
> | > >> >> > Terminal services is running, and I've tried unchecking fast user
> | > >> >> > switching
> | > >> >> > in user profile, restarting, switching back, restarting, etc.
> | > >> >> > I'm at my wit's end -- Any help????
> | > >> >>
> | > >> >>
> | > >> >>
> | > >>
> | > >>
> | > >>
> | >
> | >
> | >
>
Anonymous
June 10, 2005 11:48:28 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

C:\WINDOWS\Debug\UserMode\userenv.log

Many failures are normal, it's how it checks what to do.
--
--------------------------------------------------------------------------------------------------
http://webdiary.smh.com.au/archives/_comment/001075.htm...
=================================================
"Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> By default do you mean system managed? That's what I just did -- no
> improvement.
>
> "Carey Frisch [MVP]" wrote:
>
> > Use the default Virtual memory settings and your problem will
> > go away.
> >
> > --
> > Carey Frisch
> > Microsoft MVP
> > Windows XP - Shell/User
> > Microsoft Newsgroups
> >
> > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > http://www.microsoft.com/athome/security/protect/window...
> >
> > -------------------------------------------------------------------------------------------
> >
> > "Matt J" wrote in:
> >
> > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > | improvement.
> > |
> > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > | to "Background Services" and Memory usage to "System Cache." System failed
> > | repatedly at start-up until I rolled back changed settings.
> > |
> > | Any additional suggestions?
> > |
> > | "Richard Urban" wrote:
> > |
> > | > If the pagefile can not grow to what is ultimately required for fast user
> > | > switching, you may crash the system or cause it to hang. I have found that
> > | > some users who have altered their pagefile from what was the defaults have
> > | > had this problem.
> > | >
> > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > | > fragmentation can always be dealt with later!
> > | >
> > | > --
> > | > Regards,
> > | >
> > | > Richard Urban
> > | >
> > | > aka Crusty (-: Old B@stard :-)
> > | >
> > | > If you knew as much as you think you know,
> > | > You would realize that you don't know what you thought you knew!
> > | >
> > | >
> > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > | > > What's your thinking in terms of potential solution? Page file is
> > | > > contiguous
> > | > > now -- won't resetting chunk it up?
> > | > >
> > | > > "Richard Urban" wrote:
> > | > >
> > | > >> Set it for "system managed" and try again! (-:
> > | > >>
> > | > >> --
> > | > >> Regards,
> > | > >>
> > | > >> Richard Urban
> > | > >>
> > | > >> aka Crusty (-: Old B@stard :-)
> > | > >>
> > | > >> If you knew as much as you think you know,
> > | > >> You would realize that you don't know what you thought you knew!
> > | > >>
> > | > >>
> > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > | > >> >
> > | > >> > "Richard Urban" wrote:
> > | > >> >
> > | > >> >> Have you played with your pagefile settings?
> > | > >> >>
> > | > >> >> --
> > | > >> >> Regards,
> > | > >> >>
> > | > >> >> Richard Urban
> > | > >> >>
> > | > >> >> aka Crusty (-: Old B@stard :-)
> > | > >> >>
> > | > >> >> If you knew as much as you think you know,
> > | > >> >> You would realize that you don't know what you thought you knew!
> > | > >> >>
> > | > >> >>
> > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > | > >> >> >
> > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > | > >> >> > longer
> > | > >> >> > works.
> > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > | > >> >> > select
> > | > >> >> > second
> > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > | > >> >> > user,
> > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > | > >> >> > out
> > | > >> >> > from
> > | > >> >> > first user then log on just one user at a time.
> > | > >> >> >
> > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > | > >> >> > switching
> > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > | > >> >> > I'm at my wit's end -- Any help????
> > | > >> >>
> > | > >> >>
> > | > >> >>
> > | > >>
> > | > >>
> > | > >>
> > | >
> > | >
> > | >
> >
Anonymous
June 10, 2005 11:48:29 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

David -- not sure I understand. C:\WINDOWS\Debug\UserMode\ is empty -- no
hidden files, nothing.

"David Candy" wrote:

> C:\WINDOWS\Debug\UserMode\userenv.log
>
> Many failures are normal, it's how it checks what to do.
> --
> --------------------------------------------------------------------------------------------------
> http://webdiary.smh.com.au/archives/_comment/001075.htm...
> =================================================
> "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> > By default do you mean system managed? That's what I just did -- no
> > improvement.
> >
> > "Carey Frisch [MVP]" wrote:
> >
> > > Use the default Virtual memory settings and your problem will
> > > go away.
> > >
> > > --
> > > Carey Frisch
> > > Microsoft MVP
> > > Windows XP - Shell/User
> > > Microsoft Newsgroups
> > >
> > > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > > http://www.microsoft.com/athome/security/protect/window...
> > >
> > > -------------------------------------------------------------------------------------------
> > >
> > > "Matt J" wrote in:
> > >
> > > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > > | improvement.
> > > |
> > > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > > | to "Background Services" and Memory usage to "System Cache." System failed
> > > | repatedly at start-up until I rolled back changed settings.
> > > |
> > > | Any additional suggestions?
> > > |
> > > | "Richard Urban" wrote:
> > > |
> > > | > If the pagefile can not grow to what is ultimately required for fast user
> > > | > switching, you may crash the system or cause it to hang. I have found that
> > > | > some users who have altered their pagefile from what was the defaults have
> > > | > had this problem.
> > > | >
> > > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > > | > fragmentation can always be dealt with later!
> > > | >
> > > | > --
> > > | > Regards,
> > > | >
> > > | > Richard Urban
> > > | >
> > > | > aka Crusty (-: Old B@stard :-)
> > > | >
> > > | > If you knew as much as you think you know,
> > > | > You would realize that you don't know what you thought you knew!
> > > | >
> > > | >
> > > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > > | > > What's your thinking in terms of potential solution? Page file is
> > > | > > contiguous
> > > | > > now -- won't resetting chunk it up?
> > > | > >
> > > | > > "Richard Urban" wrote:
> > > | > >
> > > | > >> Set it for "system managed" and try again! (-:
> > > | > >>
> > > | > >> --
> > > | > >> Regards,
> > > | > >>
> > > | > >> Richard Urban
> > > | > >>
> > > | > >> aka Crusty (-: Old B@stard :-)
> > > | > >>
> > > | > >> If you knew as much as you think you know,
> > > | > >> You would realize that you don't know what you thought you knew!
> > > | > >>
> > > | > >>
> > > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > > | > >> >
> > > | > >> > "Richard Urban" wrote:
> > > | > >> >
> > > | > >> >> Have you played with your pagefile settings?
> > > | > >> >>
> > > | > >> >> --
> > > | > >> >> Regards,
> > > | > >> >>
> > > | > >> >> Richard Urban
> > > | > >> >>
> > > | > >> >> aka Crusty (-: Old B@stard :-)
> > > | > >> >>
> > > | > >> >> If you knew as much as you think you know,
> > > | > >> >> You would realize that you don't know what you thought you knew!
> > > | > >> >>
> > > | > >> >>
> > > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > > | > >> >> >
> > > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > > | > >> >> > longer
> > > | > >> >> > works.
> > > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > > | > >> >> > select
> > > | > >> >> > second
> > > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > > | > >> >> > user,
> > > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > > | > >> >> > out
> > > | > >> >> > from
> > > | > >> >> > first user then log on just one user at a time.
> > > | > >> >> >
> > > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > > | > >> >> > switching
> > > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > > | > >> >> > I'm at my wit's end -- Any help????
> > > | > >> >>
> > > | > >> >>
> > > | > >> >>
> > > | > >>
> > > | > >>
> > > | > >>
> > > | >
> > > | >
> > > | >
> > >
>
>
Anonymous
June 11, 2005 3:46:32 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Though it should be logging by default.
Knowledge Base

How to Enable User Environment Debug Logging in Retail Builds of WindowsPSS ID Number: 221833
Article Last Modified on 1/24/2003


The information in this article applies to:


Microsoft Windows XP Professional
Microsoft Windows 2000 Datacenter Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Server
Microsoft Windows 2000 Professional



This article was previously published under Q221833
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SUMMARY
The versions of Microsoft Windows listed at the beginning of this article include debug logging of the user profile and the Windows system policy processes. To turn on debug logging, modify the registry on the computer on which the logging occurs. The debug logging functionality is also available with Microsoft Windows NT 4.0, but the functionality requires a checked (debug) build of the Userenv.dll file on Windows NT 4.0.
For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
154120 Debugging User Profiles and System Policies in Windows NT 4.0
You can use the output of this logging to troubleshoot problems with user profiles and Group Policy processing.
MORE INFORMATION
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Use Registry Editor to add the following registry value (or modify it, if the value already exists):
Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
Value: UserEnvDebugLevel
Value Type: REG_DWORD
Value Data: 10002 (Hex)
UserEnvDebugLevel can have the following values:
NONE 0x00000000
NORMAL 0x00000001
VERBOSE 0x00000002
LOGFILE 0x00010000
DEBUGGER 0x00020000
The default value is NORMAL (0x00010000). NOTE: To disable logging, select NONE (where the value would be [0X0000000000000]).

You can also combine the values. For example, you can combine VERBOSE 0x00000002 and LOGFILE 0x00010000 to get 0x00010002. So if UserEnvDebugLevel is set with a value of 0x00010002, this turns on both LOGFILE and VERBOSE. Combining these values is the same as using an AND statement:
0x00010000 AND 0x00000002 = 0x00010002
The log file is written to the %SystemRoot%\Debug\UserMode\Userenv.log file.


Additional query words: userenv.log enable
Keywords: kbhowto KB221833
Technology: kbwin2000AdvServ kbwin2000AdvServSearch kbwin2000DataServ kbwin2000DataServSearch kbwin2000Pro kbwin2000ProSearch kbwin2000Search kbwin2000Serv kbwin2000ServSearch kbWinAdvServSearch kbWinDataServSearch kbWinXPPro kbWinXPProSearch kbWinXPSearch




Send feedback to Microsoft
© 2003 Microsoft Corporation. All rights reserved.
--
--------------------------------------------------------------------------------------------------
http://webdiary.smh.com.au/archives/_comment/001075.htm...
=================================================
"Matt J" <MattJ@discussions.microsoft.com> wrote in message news:3F582E62-457F-41BD-BBEF-CDB45EF806C4@microsoft.com...
> David -- not sure I understand. C:\WINDOWS\Debug\UserMode\ is empty -- no
> hidden files, nothing.
>
> "David Candy" wrote:
>
> > C:\WINDOWS\Debug\UserMode\userenv.log
> >
> > Many failures are normal, it's how it checks what to do.
> > --
> > --------------------------------------------------------------------------------------------------
> > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > =================================================
> > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> > > By default do you mean system managed? That's what I just did -- no
> > > improvement.
> > >
> > > "Carey Frisch [MVP]" wrote:
> > >
> > > > Use the default Virtual memory settings and your problem will
> > > > go away.
> > > >
> > > > --
> > > > Carey Frisch
> > > > Microsoft MVP
> > > > Windows XP - Shell/User
> > > > Microsoft Newsgroups
> > > >
> > > > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > > > http://www.microsoft.com/athome/security/protect/window...
> > > >
> > > > -------------------------------------------------------------------------------------------
> > > >
> > > > "Matt J" wrote in:
> > > >
> > > > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > > > | improvement.
> > > > |
> > > > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > > > | to "Background Services" and Memory usage to "System Cache." System failed
> > > > | repatedly at start-up until I rolled back changed settings.
> > > > |
> > > > | Any additional suggestions?
> > > > |
> > > > | "Richard Urban" wrote:
> > > > |
> > > > | > If the pagefile can not grow to what is ultimately required for fast user
> > > > | > switching, you may crash the system or cause it to hang. I have found that
> > > > | > some users who have altered their pagefile from what was the defaults have
> > > > | > had this problem.
> > > > | >
> > > > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > > > | > fragmentation can always be dealt with later!
> > > > | >
> > > > | > --
> > > > | > Regards,
> > > > | >
> > > > | > Richard Urban
> > > > | >
> > > > | > aka Crusty (-: Old B@stard :-)
> > > > | >
> > > > | > If you knew as much as you think you know,
> > > > | > You would realize that you don't know what you thought you knew!
> > > > | >
> > > > | >
> > > > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > > > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > > > | > > What's your thinking in terms of potential solution? Page file is
> > > > | > > contiguous
> > > > | > > now -- won't resetting chunk it up?
> > > > | > >
> > > > | > > "Richard Urban" wrote:
> > > > | > >
> > > > | > >> Set it for "system managed" and try again! (-:
> > > > | > >>
> > > > | > >> --
> > > > | > >> Regards,
> > > > | > >>
> > > > | > >> Richard Urban
> > > > | > >>
> > > > | > >> aka Crusty (-: Old B@stard :-)
> > > > | > >>
> > > > | > >> If you knew as much as you think you know,
> > > > | > >> You would realize that you don't know what you thought you knew!
> > > > | > >>
> > > > | > >>
> > > > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > > > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > > > | > >> >
> > > > | > >> > "Richard Urban" wrote:
> > > > | > >> >
> > > > | > >> >> Have you played with your pagefile settings?
> > > > | > >> >>
> > > > | > >> >> --
> > > > | > >> >> Regards,
> > > > | > >> >>
> > > > | > >> >> Richard Urban
> > > > | > >> >>
> > > > | > >> >> aka Crusty (-: Old B@stard :-)
> > > > | > >> >>
> > > > | > >> >> If you knew as much as you think you know,
> > > > | > >> >> You would realize that you don't know what you thought you knew!
> > > > | > >> >>
> > > > | > >> >>
> > > > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > > > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > > > | > >> >> >
> > > > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > > > | > >> >> > longer
> > > > | > >> >> > works.
> > > > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > > > | > >> >> > select
> > > > | > >> >> > second
> > > > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > > > | > >> >> > user,
> > > > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > > > | > >> >> > out
> > > > | > >> >> > from
> > > > | > >> >> > first user then log on just one user at a time.
> > > > | > >> >> >
> > > > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > > > | > >> >> > switching
> > > > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > > > | > >> >> > I'm at my wit's end -- Any help????
> > > > | > >> >>
> > > > | > >> >>
> > > > | > >> >>
> > > > | > >>
> > > > | > >>
> > > > | > >>
> > > > | >
> > > > | >
> > > > | >
> > > >
> >
> >
Anonymous
June 11, 2005 3:46:33 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Thanks -- I have Win XP Home Edition, not listed in the KB article. Doesn't
appear I can set it for debug logging. Thoughts?

"David Candy" wrote:

> Though it should be logging by default.
> Knowledge Base
>
> How to Enable User Environment Debug Logging in Retail Builds of WindowsPSS ID Number: 221833
> Article Last Modified on 1/24/2003
>
>
> The information in this article applies to:
>
>
> Microsoft Windows XP Professional
> Microsoft Windows 2000 Datacenter Server
> Microsoft Windows 2000 Advanced Server
> Microsoft Windows 2000 Server
> Microsoft Windows 2000 Professional
>
>
>
> This article was previously published under Q221833
> IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
> 256986 Description of the Microsoft Windows Registry
> SUMMARY
> The versions of Microsoft Windows listed at the beginning of this article include debug logging of the user profile and the Windows system policy processes. To turn on debug logging, modify the registry on the computer on which the logging occurs. The debug logging functionality is also available with Microsoft Windows NT 4.0, but the functionality requires a checked (debug) build of the Userenv.dll file on Windows NT 4.0.
> For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
> 154120 Debugging User Profiles and System Policies in Windows NT 4.0
> You can use the output of this logging to troubleshoot problems with user profiles and Group Policy processing.
> MORE INFORMATION
> WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
>
> Use Registry Editor to add the following registry value (or modify it, if the value already exists):
> Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
> Value: UserEnvDebugLevel
> Value Type: REG_DWORD
> Value Data: 10002 (Hex)
> UserEnvDebugLevel can have the following values:
> NONE 0x00000000
> NORMAL 0x00000001
> VERBOSE 0x00000002
> LOGFILE 0x00010000
> DEBUGGER 0x00020000
> The default value is NORMAL (0x00010000). NOTE: To disable logging, select NONE (where the value would be [0X0000000000000]).
>
> You can also combine the values. For example, you can combine VERBOSE 0x00000002 and LOGFILE 0x00010000 to get 0x00010002. So if UserEnvDebugLevel is set with a value of 0x00010002, this turns on both LOGFILE and VERBOSE. Combining these values is the same as using an AND statement:
> 0x00010000 AND 0x00000002 = 0x00010002
> The log file is written to the %SystemRoot%\Debug\UserMode\Userenv.log file.
>
>
> Additional query words: userenv.log enable
> Keywords: kbhowto KB221833
> Technology: kbwin2000AdvServ kbwin2000AdvServSearch kbwin2000DataServ kbwin2000DataServSearch kbwin2000Pro kbwin2000ProSearch kbwin2000Search kbwin2000Serv kbwin2000ServSearch kbWinAdvServSearch kbWinDataServSearch kbWinXPPro kbWinXPProSearch kbWinXPSearch
>
>
>
>
> Send feedback to Microsoft
> © 2003 Microsoft Corporation. All rights reserved.
> --
> --------------------------------------------------------------------------------------------------
> http://webdiary.smh.com.au/archives/_comment/001075.htm...
> =================================================
> "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:3F582E62-457F-41BD-BBEF-CDB45EF806C4@microsoft.com...
> > David -- not sure I understand. C:\WINDOWS\Debug\UserMode\ is empty -- no
> > hidden files, nothing.
> >
> > "David Candy" wrote:
> >
> > > C:\WINDOWS\Debug\UserMode\userenv.log
> > >
> > > Many failures are normal, it's how it checks what to do.
> > > --
> > > --------------------------------------------------------------------------------------------------
> > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > =================================================
> > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> > > > By default do you mean system managed? That's what I just did -- no
> > > > improvement.
> > > >
> > > > "Carey Frisch [MVP]" wrote:
> > > >
> > > > > Use the default Virtual memory settings and your problem will
> > > > > go away.
> > > > >
> > > > > --
> > > > > Carey Frisch
> > > > > Microsoft MVP
> > > > > Windows XP - Shell/User
> > > > > Microsoft Newsgroups
> > > > >
> > > > > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > > > > http://www.microsoft.com/athome/security/protect/window...
> > > > >
> > > > > -------------------------------------------------------------------------------------------
> > > > >
> > > > > "Matt J" wrote in:
> > > > >
> > > > > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > > > > | improvement.
> > > > > |
> > > > > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > > > > | to "Background Services" and Memory usage to "System Cache." System failed
> > > > > | repatedly at start-up until I rolled back changed settings.
> > > > > |
> > > > > | Any additional suggestions?
> > > > > |
> > > > > | "Richard Urban" wrote:
> > > > > |
> > > > > | > If the pagefile can not grow to what is ultimately required for fast user
> > > > > | > switching, you may crash the system or cause it to hang. I have found that
> > > > > | > some users who have altered their pagefile from what was the defaults have
> > > > > | > had this problem.
> > > > > | >
> > > > > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > > > > | > fragmentation can always be dealt with later!
> > > > > | >
> > > > > | > --
> > > > > | > Regards,
> > > > > | >
> > > > > | > Richard Urban
> > > > > | >
> > > > > | > aka Crusty (-: Old B@stard :-)
> > > > > | >
> > > > > | > If you knew as much as you think you know,
> > > > > | > You would realize that you don't know what you thought you knew!
> > > > > | >
> > > > > | >
> > > > > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > > > > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > > > > | > > What's your thinking in terms of potential solution? Page file is
> > > > > | > > contiguous
> > > > > | > > now -- won't resetting chunk it up?
> > > > > | > >
> > > > > | > > "Richard Urban" wrote:
> > > > > | > >
> > > > > | > >> Set it for "system managed" and try again! (-:
> > > > > | > >>
> > > > > | > >> --
> > > > > | > >> Regards,
> > > > > | > >>
> > > > > | > >> Richard Urban
> > > > > | > >>
> > > > > | > >> aka Crusty (-: Old B@stard :-)
> > > > > | > >>
> > > > > | > >> If you knew as much as you think you know,
> > > > > | > >> You would realize that you don't know what you thought you knew!
> > > > > | > >>
> > > > > | > >>
> > > > > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > > > > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > > > > | > >> >
> > > > > | > >> > "Richard Urban" wrote:
> > > > > | > >> >
> > > > > | > >> >> Have you played with your pagefile settings?
> > > > > | > >> >>
> > > > > | > >> >> --
> > > > > | > >> >> Regards,
> > > > > | > >> >>
> > > > > | > >> >> Richard Urban
> > > > > | > >> >>
> > > > > | > >> >> aka Crusty (-: Old B@stard :-)
> > > > > | > >> >>
> > > > > | > >> >> If you knew as much as you think you know,
> > > > > | > >> >> You would realize that you don't know what you thought you knew!
> > > > > | > >> >>
> > > > > | > >> >>
> > > > > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > > > > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > > > > | > >> >> >
> > > > > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > > > > | > >> >> > longer
> > > > > | > >> >> > works.
> > > > > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > > > > | > >> >> > select
> > > > > | > >> >> > second
> > > > > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > > > > | > >> >> > user,
> > > > > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > > > > | > >> >> > out
> > > > > | > >> >> > from
> > > > > | > >> >> > first user then log on just one user at a time.
> > > > > | > >> >> >
> > > > > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > > > > | > >> >> > switching
> > > > > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > > > > | > >> >> > I'm at my wit's end -- Any help????
> > > > > | > >> >>
> > > > > | > >> >>
> > > > > | > >> >>
> > > > > | > >>
> > > > > | > >>
> > > > > | > >>
> > > > > | >
> > > > > | >
> > > > > | >
> > > > >
> > >
> > >
>
>
Anonymous
June 11, 2005 4:08:46 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Nope. Pro has the troubleshooting tools. Home doesn't. Have you looked in Event Viewer for hints.

--
--------------------------------------------------------------------------------------------------
http://webdiary.smh.com.au/archives/_comment/001075.htm...
=================================================
"Matt J" <MattJ@discussions.microsoft.com> wrote in message news:E0B721CA-8E88-4366-9D33-1D85AC184855@microsoft.com...
> Thanks -- I have Win XP Home Edition, not listed in the KB article. Doesn't
> appear I can set it for debug logging. Thoughts?
>
> "David Candy" wrote:
>
> > Though it should be logging by default.
> > Knowledge Base
> >
> > How to Enable User Environment Debug Logging in Retail Builds of WindowsPSS ID Number: 221833
> > Article Last Modified on 1/24/2003
> >
> >
> > The information in this article applies to:
> >
> >
> > Microsoft Windows XP Professional
> > Microsoft Windows 2000 Datacenter Server
> > Microsoft Windows 2000 Advanced Server
> > Microsoft Windows 2000 Server
> > Microsoft Windows 2000 Professional
> >
> >
> >
> > This article was previously published under Q221833
> > IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
> > 256986 Description of the Microsoft Windows Registry
> > SUMMARY
> > The versions of Microsoft Windows listed at the beginning of this article include debug logging of the user profile and the Windows system policy processes. To turn on debug logging, modify the registry on the computer on which the logging occurs. The debug logging functionality is also available with Microsoft Windows NT 4.0, but the functionality requires a checked (debug) build of the Userenv.dll file on Windows NT 4.0.
> > For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
> > 154120 Debugging User Profiles and System Policies in Windows NT 4.0
> > You can use the output of this logging to troubleshoot problems with user profiles and Group Policy processing.
> > MORE INFORMATION
> > WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
> >
> > Use Registry Editor to add the following registry value (or modify it, if the value already exists):
> > Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
> > Value: UserEnvDebugLevel
> > Value Type: REG_DWORD
> > Value Data: 10002 (Hex)
> > UserEnvDebugLevel can have the following values:
> > NONE 0x00000000
> > NORMAL 0x00000001
> > VERBOSE 0x00000002
> > LOGFILE 0x00010000
> > DEBUGGER 0x00020000
> > The default value is NORMAL (0x00010000). NOTE: To disable logging, select NONE (where the value would be [0X0000000000000]).
> >
> > You can also combine the values. For example, you can combine VERBOSE 0x00000002 and LOGFILE 0x00010000 to get 0x00010002. So if UserEnvDebugLevel is set with a value of 0x00010002, this turns on both LOGFILE and VERBOSE. Combining these values is the same as using an AND statement:
> > 0x00010000 AND 0x00000002 = 0x00010002
> > The log file is written to the %SystemRoot%\Debug\UserMode\Userenv.log file.
> >
> >
> > Additional query words: userenv.log enable
> > Keywords: kbhowto KB221833
> > Technology: kbwin2000AdvServ kbwin2000AdvServSearch kbwin2000DataServ kbwin2000DataServSearch kbwin2000Pro kbwin2000ProSearch kbwin2000Search kbwin2000Serv kbwin2000ServSearch kbWinAdvServSearch kbWinDataServSearch kbWinXPPro kbWinXPProSearch kbWinXPSearch
> >
> >
> >
> >
> > Send feedback to Microsoft
> > © 2003 Microsoft Corporation. All rights reserved.
> > --
> > --------------------------------------------------------------------------------------------------
> > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > =================================================
> > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:3F582E62-457F-41BD-BBEF-CDB45EF806C4@microsoft.com...
> > > David -- not sure I understand. C:\WINDOWS\Debug\UserMode\ is empty -- no
> > > hidden files, nothing.
> > >
> > > "David Candy" wrote:
> > >
> > > > C:\WINDOWS\Debug\UserMode\userenv.log
> > > >
> > > > Many failures are normal, it's how it checks what to do.
> > > > --
> > > > --------------------------------------------------------------------------------------------------
> > > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > > =================================================
> > > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> > > > > By default do you mean system managed? That's what I just did -- no
> > > > > improvement.
> > > > >
> > > > > "Carey Frisch [MVP]" wrote:
> > > > >
> > > > > > Use the default Virtual memory settings and your problem will
> > > > > > go away.
> > > > > >
> > > > > > --
> > > > > > Carey Frisch
> > > > > > Microsoft MVP
> > > > > > Windows XP - Shell/User
> > > > > > Microsoft Newsgroups
> > > > > >
> > > > > > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > > > > > http://www.microsoft.com/athome/security/protect/window...
> > > > > >
> > > > > > -------------------------------------------------------------------------------------------
> > > > > >
> > > > > > "Matt J" wrote in:
> > > > > >
> > > > > > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > > > > > | improvement.
> > > > > > |
> > > > > > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > > > > > | to "Background Services" and Memory usage to "System Cache." System failed
> > > > > > | repatedly at start-up until I rolled back changed settings.
> > > > > > |
> > > > > > | Any additional suggestions?
> > > > > > |
> > > > > > | "Richard Urban" wrote:
> > > > > > |
> > > > > > | > If the pagefile can not grow to what is ultimately required for fast user
> > > > > > | > switching, you may crash the system or cause it to hang. I have found that
> > > > > > | > some users who have altered their pagefile from what was the defaults have
> > > > > > | > had this problem.
> > > > > > | >
> > > > > > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > > > > > | > fragmentation can always be dealt with later!
> > > > > > | >
> > > > > > | > --
> > > > > > | > Regards,
> > > > > > | >
> > > > > > | > Richard Urban
> > > > > > | >
> > > > > > | > aka Crusty (-: Old B@stard :-)
> > > > > > | >
> > > > > > | > If you knew as much as you think you know,
> > > > > > | > You would realize that you don't know what you thought you knew!
> > > > > > | >
> > > > > > | >
> > > > > > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > > > > > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > > > > > | > > What's your thinking in terms of potential solution? Page file is
> > > > > > | > > contiguous
> > > > > > | > > now -- won't resetting chunk it up?
> > > > > > | > >
> > > > > > | > > "Richard Urban" wrote:
> > > > > > | > >
> > > > > > | > >> Set it for "system managed" and try again! (-:
> > > > > > | > >>
> > > > > > | > >> --
> > > > > > | > >> Regards,
> > > > > > | > >>
> > > > > > | > >> Richard Urban
> > > > > > | > >>
> > > > > > | > >> aka Crusty (-: Old B@stard :-)
> > > > > > | > >>
> > > > > > | > >> If you knew as much as you think you know,
> > > > > > | > >> You would realize that you don't know what you thought you knew!
> > > > > > | > >>
> > > > > > | > >>
> > > > > > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > > > > > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > > > > > | > >> >
> > > > > > | > >> > "Richard Urban" wrote:
> > > > > > | > >> >
> > > > > > | > >> >> Have you played with your pagefile settings?
> > > > > > | > >> >>
> > > > > > | > >> >> --
> > > > > > | > >> >> Regards,
> > > > > > | > >> >>
> > > > > > | > >> >> Richard Urban
> > > > > > | > >> >>
> > > > > > | > >> >> aka Crusty (-: Old B@stard :-)
> > > > > > | > >> >>
> > > > > > | > >> >> If you knew as much as you think you know,
> > > > > > | > >> >> You would realize that you don't know what you thought you knew!
> > > > > > | > >> >>
> > > > > > | > >> >>
> > > > > > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > > > > > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > > > > > | > >> >> >
> > > > > > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > > > > > | > >> >> > longer
> > > > > > | > >> >> > works.
> > > > > > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > > > > > | > >> >> > select
> > > > > > | > >> >> > second
> > > > > > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > > > > > | > >> >> > user,
> > > > > > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > > > > > | > >> >> > out
> > > > > > | > >> >> > from
> > > > > > | > >> >> > first user then log on just one user at a time.
> > > > > > | > >> >> >
> > > > > > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > > > > > | > >> >> > switching
> > > > > > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > > > > > | > >> >> > I'm at my wit's end -- Any help????
> > > > > > | > >> >>
> > > > > > | > >> >>
> > > > > > | > >> >>
> > > > > > | > >>
> > > > > > | > >>
> > > > > > | > >>
> > > > > > | >
> > > > > > | >
> > > > > > | >
> > > > > >
> > > >
> > > >
> >
> >
Anonymous
June 11, 2005 4:08:47 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Can't find anything -- but not confident that I know what I'm looking for.
tried to switch userts again -- but no post to event viewer for that event
time.

"David Candy" wrote:

> Nope. Pro has the troubleshooting tools. Home doesn't. Have you looked in Event Viewer for hints.
>
> --
> --------------------------------------------------------------------------------------------------
> http://webdiary.smh.com.au/archives/_comment/001075.htm...
> =================================================
> "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:E0B721CA-8E88-4366-9D33-1D85AC184855@microsoft.com...
> > Thanks -- I have Win XP Home Edition, not listed in the KB article. Doesn't
> > appear I can set it for debug logging. Thoughts?
> >
> > "David Candy" wrote:
> >
> > > Though it should be logging by default.
> > > Knowledge Base
> > >
> > > How to Enable User Environment Debug Logging in Retail Builds of WindowsPSS ID Number: 221833
> > > Article Last Modified on 1/24/2003
> > >
> > >
> > > The information in this article applies to:
> > >
> > >
> > > Microsoft Windows XP Professional
> > > Microsoft Windows 2000 Datacenter Server
> > > Microsoft Windows 2000 Advanced Server
> > > Microsoft Windows 2000 Server
> > > Microsoft Windows 2000 Professional
> > >
> > >
> > >
> > > This article was previously published under Q221833
> > > IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
> > > 256986 Description of the Microsoft Windows Registry
> > > SUMMARY
> > > The versions of Microsoft Windows listed at the beginning of this article include debug logging of the user profile and the Windows system policy processes. To turn on debug logging, modify the registry on the computer on which the logging occurs. The debug logging functionality is also available with Microsoft Windows NT 4.0, but the functionality requires a checked (debug) build of the Userenv.dll file on Windows NT 4.0.
> > > For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
> > > 154120 Debugging User Profiles and System Policies in Windows NT 4.0
> > > You can use the output of this logging to troubleshoot problems with user profiles and Group Policy processing.
> > > MORE INFORMATION
> > > WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
> > >
> > > Use Registry Editor to add the following registry value (or modify it, if the value already exists):
> > > Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
> > > Value: UserEnvDebugLevel
> > > Value Type: REG_DWORD
> > > Value Data: 10002 (Hex)
> > > UserEnvDebugLevel can have the following values:
> > > NONE 0x00000000
> > > NORMAL 0x00000001
> > > VERBOSE 0x00000002
> > > LOGFILE 0x00010000
> > > DEBUGGER 0x00020000
> > > The default value is NORMAL (0x00010000). NOTE: To disable logging, select NONE (where the value would be [0X0000000000000]).
> > >
> > > You can also combine the values. For example, you can combine VERBOSE 0x00000002 and LOGFILE 0x00010000 to get 0x00010002. So if UserEnvDebugLevel is set with a value of 0x00010002, this turns on both LOGFILE and VERBOSE. Combining these values is the same as using an AND statement:
> > > 0x00010000 AND 0x00000002 = 0x00010002
> > > The log file is written to the %SystemRoot%\Debug\UserMode\Userenv.log file.
> > >
> > >
> > > Additional query words: userenv.log enable
> > > Keywords: kbhowto KB221833
> > > Technology: kbwin2000AdvServ kbwin2000AdvServSearch kbwin2000DataServ kbwin2000DataServSearch kbwin2000Pro kbwin2000ProSearch kbwin2000Search kbwin2000Serv kbwin2000ServSearch kbWinAdvServSearch kbWinDataServSearch kbWinXPPro kbWinXPProSearch kbWinXPSearch
> > >
> > >
> > >
> > >
> > > Send feedback to Microsoft
> > > © 2003 Microsoft Corporation. All rights reserved.
> > > --
> > > --------------------------------------------------------------------------------------------------
> > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > =================================================
> > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:3F582E62-457F-41BD-BBEF-CDB45EF806C4@microsoft.com...
> > > > David -- not sure I understand. C:\WINDOWS\Debug\UserMode\ is empty -- no
> > > > hidden files, nothing.
> > > >
> > > > "David Candy" wrote:
> > > >
> > > > > C:\WINDOWS\Debug\UserMode\userenv.log
> > > > >
> > > > > Many failures are normal, it's how it checks what to do.
> > > > > --
> > > > > --------------------------------------------------------------------------------------------------
> > > > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > > > =================================================
> > > > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> > > > > > By default do you mean system managed? That's what I just did -- no
> > > > > > improvement.
> > > > > >
> > > > > > "Carey Frisch [MVP]" wrote:
> > > > > >
> > > > > > > Use the default Virtual memory settings and your problem will
> > > > > > > go away.
> > > > > > >
> > > > > > > --
> > > > > > > Carey Frisch
> > > > > > > Microsoft MVP
> > > > > > > Windows XP - Shell/User
> > > > > > > Microsoft Newsgroups
> > > > > > >
> > > > > > > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > > > > > > http://www.microsoft.com/athome/security/protect/window...
> > > > > > >
> > > > > > > -------------------------------------------------------------------------------------------
> > > > > > >
> > > > > > > "Matt J" wrote in:
> > > > > > >
> > > > > > > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > > > > > > | improvement.
> > > > > > > |
> > > > > > > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > > > > > > | to "Background Services" and Memory usage to "System Cache." System failed
> > > > > > > | repatedly at start-up until I rolled back changed settings.
> > > > > > > |
> > > > > > > | Any additional suggestions?
> > > > > > > |
> > > > > > > | "Richard Urban" wrote:
> > > > > > > |
> > > > > > > | > If the pagefile can not grow to what is ultimately required for fast user
> > > > > > > | > switching, you may crash the system or cause it to hang. I have found that
> > > > > > > | > some users who have altered their pagefile from what was the defaults have
> > > > > > > | > had this problem.
> > > > > > > | >
> > > > > > > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > > > > > > | > fragmentation can always be dealt with later!
> > > > > > > | >
> > > > > > > | > --
> > > > > > > | > Regards,
> > > > > > > | >
> > > > > > > | > Richard Urban
> > > > > > > | >
> > > > > > > | > aka Crusty (-: Old B@stard :-)
> > > > > > > | >
> > > > > > > | > If you knew as much as you think you know,
> > > > > > > | > You would realize that you don't know what you thought you knew!
> > > > > > > | >
> > > > > > > | >
> > > > > > > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > > > > > > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > > > > > > | > > What's your thinking in terms of potential solution? Page file is
> > > > > > > | > > contiguous
> > > > > > > | > > now -- won't resetting chunk it up?
> > > > > > > | > >
> > > > > > > | > > "Richard Urban" wrote:
> > > > > > > | > >
> > > > > > > | > >> Set it for "system managed" and try again! (-:
> > > > > > > | > >>
> > > > > > > | > >> --
> > > > > > > | > >> Regards,
> > > > > > > | > >>
> > > > > > > | > >> Richard Urban
> > > > > > > | > >>
> > > > > > > | > >> aka Crusty (-: Old B@stard :-)
> > > > > > > | > >>
> > > > > > > | > >> If you knew as much as you think you know,
> > > > > > > | > >> You would realize that you don't know what you thought you knew!
> > > > > > > | > >>
> > > > > > > | > >>
> > > > > > > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > > > > > > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > > > > > > | > >> >
> > > > > > > | > >> > "Richard Urban" wrote:
> > > > > > > | > >> >
> > > > > > > | > >> >> Have you played with your pagefile settings?
> > > > > > > | > >> >>
> > > > > > > | > >> >> --
> > > > > > > | > >> >> Regards,
> > > > > > > | > >> >>
> > > > > > > | > >> >> Richard Urban
> > > > > > > | > >> >>
> > > > > > > | > >> >> aka Crusty (-: Old B@stard :-)
> > > > > > > | > >> >>
> > > > > > > | > >> >> If you knew as much as you think you know,
> > > > > > > | > >> >> You would realize that you don't know what you thought you knew!
> > > > > > > | > >> >>
> > > > > > > | > >> >>
> > > > > > > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > > > > > > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > > > > > > | > >> >> >
> > > > > > > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > > > > > > | > >> >> > longer
> > > > > > > | > >> >> > works.
> > > > > > > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > > > > > > | > >> >> > select
> > > > > > > | > >> >> > second
> > > > > > > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > > > > > > | > >> >> > user,
> > > > > > > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > > > > > > | > >> >> > out
> > > > > > > | > >> >> > from
> > > > > > > | > >> >> > first user then log on just one user at a time.
> > > > > > > | > >> >> >
> > > > > > > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > > > > > > | > >> >> > switching
> > > > > > > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > > > > > > | > >> >> > I'm at my wit's end -- Any help????
> > > > > > > | > >> >>
> > > > > > > | > >> >>
> > > > > > > | > >> >>
> > > > > > > | > >>
> > > > > > > | > >>
> > > > > > > | > >>
> > > > > > > | >
> > > > > > > | >
> > > > > > > | >
> > > > > > >
> > > > >
> > > > >
> > >
> > >
>
>
Anonymous
June 11, 2005 4:45:19 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

If you create a new account can you switch to that?

--
--------------------------------------------------------------------------------------------------
http://webdiary.smh.com.au/archives/_comment/001075.htm...
=================================================
"Matt J" <MattJ@discussions.microsoft.com> wrote in message news:E157D5EF-4CA5-451A-97B3-1BBC1E37C679@microsoft.com...
> Can't find anything -- but not confident that I know what I'm looking for.
> tried to switch userts again -- but no post to event viewer for that event
> time.
>
> "David Candy" wrote:
>
> > Nope. Pro has the troubleshooting tools. Home doesn't. Have you looked in Event Viewer for hints.
> >
> > --
> > --------------------------------------------------------------------------------------------------
> > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > =================================================
> > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:E0B721CA-8E88-4366-9D33-1D85AC184855@microsoft.com...
> > > Thanks -- I have Win XP Home Edition, not listed in the KB article. Doesn't
> > > appear I can set it for debug logging. Thoughts?
> > >
> > > "David Candy" wrote:
> > >
> > > > Though it should be logging by default.
> > > > Knowledge Base
> > > >
> > > > How to Enable User Environment Debug Logging in Retail Builds of WindowsPSS ID Number: 221833
> > > > Article Last Modified on 1/24/2003
> > > >
> > > >
> > > > The information in this article applies to:
> > > >
> > > >
> > > > Microsoft Windows XP Professional
> > > > Microsoft Windows 2000 Datacenter Server
> > > > Microsoft Windows 2000 Advanced Server
> > > > Microsoft Windows 2000 Server
> > > > Microsoft Windows 2000 Professional
> > > >
> > > >
> > > >
> > > > This article was previously published under Q221833
> > > > IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
> > > > 256986 Description of the Microsoft Windows Registry
> > > > SUMMARY
> > > > The versions of Microsoft Windows listed at the beginning of this article include debug logging of the user profile and the Windows system policy processes. To turn on debug logging, modify the registry on the computer on which the logging occurs. The debug logging functionality is also available with Microsoft Windows NT 4.0, but the functionality requires a checked (debug) build of the Userenv.dll file on Windows NT 4.0.
> > > > For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
> > > > 154120 Debugging User Profiles and System Policies in Windows NT 4.0
> > > > You can use the output of this logging to troubleshoot problems with user profiles and Group Policy processing.
> > > > MORE INFORMATION
> > > > WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
> > > >
> > > > Use Registry Editor to add the following registry value (or modify it, if the value already exists):
> > > > Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
> > > > Value: UserEnvDebugLevel
> > > > Value Type: REG_DWORD
> > > > Value Data: 10002 (Hex)
> > > > UserEnvDebugLevel can have the following values:
> > > > NONE 0x00000000
> > > > NORMAL 0x00000001
> > > > VERBOSE 0x00000002
> > > > LOGFILE 0x00010000
> > > > DEBUGGER 0x00020000
> > > > The default value is NORMAL (0x00010000). NOTE: To disable logging, select NONE (where the value would be [0X0000000000000]).
> > > >
> > > > You can also combine the values. For example, you can combine VERBOSE 0x00000002 and LOGFILE 0x00010000 to get 0x00010002. So if UserEnvDebugLevel is set with a value of 0x00010002, this turns on both LOGFILE and VERBOSE. Combining these values is the same as using an AND statement:
> > > > 0x00010000 AND 0x00000002 = 0x00010002
> > > > The log file is written to the %SystemRoot%\Debug\UserMode\Userenv.log file.
> > > >
> > > >
> > > > Additional query words: userenv.log enable
> > > > Keywords: kbhowto KB221833
> > > > Technology: kbwin2000AdvServ kbwin2000AdvServSearch kbwin2000DataServ kbwin2000DataServSearch kbwin2000Pro kbwin2000ProSearch kbwin2000Search kbwin2000Serv kbwin2000ServSearch kbWinAdvServSearch kbWinDataServSearch kbWinXPPro kbWinXPProSearch kbWinXPSearch
> > > >
> > > >
> > > >
> > > >
> > > > Send feedback to Microsoft
> > > > © 2003 Microsoft Corporation. All rights reserved.
> > > > --
> > > > --------------------------------------------------------------------------------------------------
> > > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > > =================================================
> > > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:3F582E62-457F-41BD-BBEF-CDB45EF806C4@microsoft.com...
> > > > > David -- not sure I understand. C:\WINDOWS\Debug\UserMode\ is empty -- no
> > > > > hidden files, nothing.
> > > > >
> > > > > "David Candy" wrote:
> > > > >
> > > > > > C:\WINDOWS\Debug\UserMode\userenv.log
> > > > > >
> > > > > > Many failures are normal, it's how it checks what to do.
> > > > > > --
> > > > > > --------------------------------------------------------------------------------------------------
> > > > > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > > > > =================================================
> > > > > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> > > > > > > By default do you mean system managed? That's what I just did -- no
> > > > > > > improvement.
> > > > > > >
> > > > > > > "Carey Frisch [MVP]" wrote:
> > > > > > >
> > > > > > > > Use the default Virtual memory settings and your problem will
> > > > > > > > go away.
> > > > > > > >
> > > > > > > > --
> > > > > > > > Carey Frisch
> > > > > > > > Microsoft MVP
> > > > > > > > Windows XP - Shell/User
> > > > > > > > Microsoft Newsgroups
> > > > > > > >
> > > > > > > > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > > > > > > > http://www.microsoft.com/athome/security/protect/window...
> > > > > > > >
> > > > > > > > -------------------------------------------------------------------------------------------
> > > > > > > >
> > > > > > > > "Matt J" wrote in:
> > > > > > > >
> > > > > > > > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > > > > > > > | improvement.
> > > > > > > > |
> > > > > > > > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > > > > > > > | to "Background Services" and Memory usage to "System Cache." System failed
> > > > > > > > | repatedly at start-up until I rolled back changed settings.
> > > > > > > > |
> > > > > > > > | Any additional suggestions?
> > > > > > > > |
> > > > > > > > | "Richard Urban" wrote:
> > > > > > > > |
> > > > > > > > | > If the pagefile can not grow to what is ultimately required for fast user
> > > > > > > > | > switching, you may crash the system or cause it to hang. I have found that
> > > > > > > > | > some users who have altered their pagefile from what was the defaults have
> > > > > > > > | > had this problem.
> > > > > > > > | >
> > > > > > > > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > > > > > > > | > fragmentation can always be dealt with later!
> > > > > > > > | >
> > > > > > > > | > --
> > > > > > > > | > Regards,
> > > > > > > > | >
> > > > > > > > | > Richard Urban
> > > > > > > > | >
> > > > > > > > | > aka Crusty (-: Old B@stard :-)
> > > > > > > > | >
> > > > > > > > | > If you knew as much as you think you know,
> > > > > > > > | > You would realize that you don't know what you thought you knew!
> > > > > > > > | >
> > > > > > > > | >
> > > > > > > > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > > > > > > > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > > > > > > > | > > What's your thinking in terms of potential solution? Page file is
> > > > > > > > | > > contiguous
> > > > > > > > | > > now -- won't resetting chunk it up?
> > > > > > > > | > >
> > > > > > > > | > > "Richard Urban" wrote:
> > > > > > > > | > >
> > > > > > > > | > >> Set it for "system managed" and try again! (-:
> > > > > > > > | > >>
> > > > > > > > | > >> --
> > > > > > > > | > >> Regards,
> > > > > > > > | > >>
> > > > > > > > | > >> Richard Urban
> > > > > > > > | > >>
> > > > > > > > | > >> aka Crusty (-: Old B@stard :-)
> > > > > > > > | > >>
> > > > > > > > | > >> If you knew as much as you think you know,
> > > > > > > > | > >> You would realize that you don't know what you thought you knew!
> > > > > > > > | > >>
> > > > > > > > | > >>
> > > > > > > > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > > > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > > > > > > > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > > > > > > > | > >> >
> > > > > > > > | > >> > "Richard Urban" wrote:
> > > > > > > > | > >> >
> > > > > > > > | > >> >> Have you played with your pagefile settings?
> > > > > > > > | > >> >>
> > > > > > > > | > >> >> --
> > > > > > > > | > >> >> Regards,
> > > > > > > > | > >> >>
> > > > > > > > | > >> >> Richard Urban
> > > > > > > > | > >> >>
> > > > > > > > | > >> >> aka Crusty (-: Old B@stard :-)
> > > > > > > > | > >> >>
> > > > > > > > | > >> >> If you knew as much as you think you know,
> > > > > > > > | > >> >> You would realize that you don't know what you thought you knew!
> > > > > > > > | > >> >>
> > > > > > > > | > >> >>
> > > > > > > > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > > > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > > > > > > > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > > > > > > > | > >> >> >
> > > > > > > > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > > > > > > > | > >> >> > longer
> > > > > > > > | > >> >> > works.
> > > > > > > > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > > > > > > > | > >> >> > select
> > > > > > > > | > >> >> > second
> > > > > > > > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > > > > > > > | > >> >> > user,
> > > > > > > > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > > > > > > > | > >> >> > out
> > > > > > > > | > >> >> > from
> > > > > > > > | > >> >> > first user then log on just one user at a time.
> > > > > > > > | > >> >> >
> > > > > > > > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > > > > > > > | > >> >> > switching
> > > > > > > > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > > > > > > > | > >> >> > I'm at my wit's end -- Any help????
> > > > > > > > | > >> >>
> > > > > > > > | > >> >>
> > > > > > > > | > >> >>
> > > > > > > > | > >>
> > > > > > > > | > >>
> > > > > > > > | > >>
> > > > > > > > | >
> > > > > > > > | >
> > > > > > > > | >
> > > > > > > >
> > > > > >
> > > > > >
> > > >
> > > >
> >
> >
Anonymous
June 11, 2005 4:45:20 PM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Good idea -- but no luck. Same "blink" then back to welcome screen.

"David Candy" wrote:

> If you create a new account can you switch to that?
>
> --
> --------------------------------------------------------------------------------------------------
> http://webdiary.smh.com.au/archives/_comment/001075.htm...
> =================================================
> "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:E157D5EF-4CA5-451A-97B3-1BBC1E37C679@microsoft.com...
> > Can't find anything -- but not confident that I know what I'm looking for.
> > tried to switch userts again -- but no post to event viewer for that event
> > time.
> >
> > "David Candy" wrote:
> >
> > > Nope. Pro has the troubleshooting tools. Home doesn't. Have you looked in Event Viewer for hints.
> > >
> > > --
> > > --------------------------------------------------------------------------------------------------
> > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > =================================================
> > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:E0B721CA-8E88-4366-9D33-1D85AC184855@microsoft.com...
> > > > Thanks -- I have Win XP Home Edition, not listed in the KB article. Doesn't
> > > > appear I can set it for debug logging. Thoughts?
> > > >
> > > > "David Candy" wrote:
> > > >
> > > > > Though it should be logging by default.
> > > > > Knowledge Base
> > > > >
> > > > > How to Enable User Environment Debug Logging in Retail Builds of WindowsPSS ID Number: 221833
> > > > > Article Last Modified on 1/24/2003
> > > > >
> > > > >
> > > > > The information in this article applies to:
> > > > >
> > > > >
> > > > > Microsoft Windows XP Professional
> > > > > Microsoft Windows 2000 Datacenter Server
> > > > > Microsoft Windows 2000 Advanced Server
> > > > > Microsoft Windows 2000 Server
> > > > > Microsoft Windows 2000 Professional
> > > > >
> > > > >
> > > > >
> > > > > This article was previously published under Q221833
> > > > > IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
> > > > > 256986 Description of the Microsoft Windows Registry
> > > > > SUMMARY
> > > > > The versions of Microsoft Windows listed at the beginning of this article include debug logging of the user profile and the Windows system policy processes. To turn on debug logging, modify the registry on the computer on which the logging occurs. The debug logging functionality is also available with Microsoft Windows NT 4.0, but the functionality requires a checked (debug) build of the Userenv.dll file on Windows NT 4.0.
> > > > > For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
> > > > > 154120 Debugging User Profiles and System Policies in Windows NT 4.0
> > > > > You can use the output of this logging to troubleshoot problems with user profiles and Group Policy processing.
> > > > > MORE INFORMATION
> > > > > WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
> > > > >
> > > > > Use Registry Editor to add the following registry value (or modify it, if the value already exists):
> > > > > Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
> > > > > Value: UserEnvDebugLevel
> > > > > Value Type: REG_DWORD
> > > > > Value Data: 10002 (Hex)
> > > > > UserEnvDebugLevel can have the following values:
> > > > > NONE 0x00000000
> > > > > NORMAL 0x00000001
> > > > > VERBOSE 0x00000002
> > > > > LOGFILE 0x00010000
> > > > > DEBUGGER 0x00020000
> > > > > The default value is NORMAL (0x00010000). NOTE: To disable logging, select NONE (where the value would be [0X0000000000000]).
> > > > >
> > > > > You can also combine the values. For example, you can combine VERBOSE 0x00000002 and LOGFILE 0x00010000 to get 0x00010002. So if UserEnvDebugLevel is set with a value of 0x00010002, this turns on both LOGFILE and VERBOSE. Combining these values is the same as using an AND statement:
> > > > > 0x00010000 AND 0x00000002 = 0x00010002
> > > > > The log file is written to the %SystemRoot%\Debug\UserMode\Userenv.log file.
> > > > >
> > > > >
> > > > > Additional query words: userenv.log enable
> > > > > Keywords: kbhowto KB221833
> > > > > Technology: kbwin2000AdvServ kbwin2000AdvServSearch kbwin2000DataServ kbwin2000DataServSearch kbwin2000Pro kbwin2000ProSearch kbwin2000Search kbwin2000Serv kbwin2000ServSearch kbWinAdvServSearch kbWinDataServSearch kbWinXPPro kbWinXPProSearch kbWinXPSearch
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > Send feedback to Microsoft
> > > > > © 2003 Microsoft Corporation. All rights reserved.
> > > > > --
> > > > > --------------------------------------------------------------------------------------------------
> > > > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > > > =================================================
> > > > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:3F582E62-457F-41BD-BBEF-CDB45EF806C4@microsoft.com...
> > > > > > David -- not sure I understand. C:\WINDOWS\Debug\UserMode\ is empty -- no
> > > > > > hidden files, nothing.
> > > > > >
> > > > > > "David Candy" wrote:
> > > > > >
> > > > > > > C:\WINDOWS\Debug\UserMode\userenv.log
> > > > > > >
> > > > > > > Many failures are normal, it's how it checks what to do.
> > > > > > > --
> > > > > > > --------------------------------------------------------------------------------------------------
> > > > > > > http://webdiary.smh.com.au/archives/_comment/001075.htm...
> > > > > > > =================================================
> > > > > > > "Matt J" <MattJ@discussions.microsoft.com> wrote in message news:2D6574C2-825D-4B01-99E9-8426A3D888C2@microsoft.com...
> > > > > > > > By default do you mean system managed? That's what I just did -- no
> > > > > > > > improvement.
> > > > > > > >
> > > > > > > > "Carey Frisch [MVP]" wrote:
> > > > > > > >
> > > > > > > > > Use the default Virtual memory settings and your problem will
> > > > > > > > > go away.
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Carey Frisch
> > > > > > > > > Microsoft MVP
> > > > > > > > > Windows XP - Shell/User
> > > > > > > > > Microsoft Newsgroups
> > > > > > > > >
> > > > > > > > > Get Windows XP Service Pack 2 with Advanced Security Technologies:
> > > > > > > > > http://www.microsoft.com/athome/security/protect/window...
> > > > > > > > >
> > > > > > > > > -------------------------------------------------------------------------------------------
> > > > > > > > >
> > > > > > > > > "Matt J" wrote in:
> > > > > > > > >
> > > > > > > > > | Changed pagefile (now min 2MB, rec 766 MB, and current 767 MB). No
> > > > > > > > > | improvement.
> > > > > > > > > |
> > > > > > > > > | Interesting sidebar -- also tried changing settings for Processor Scheduling
> > > > > > > > > | to "Background Services" and Memory usage to "System Cache." System failed
> > > > > > > > > | repatedly at start-up until I rolled back changed settings.
> > > > > > > > > |
> > > > > > > > > | Any additional suggestions?
> > > > > > > > > |
> > > > > > > > > | "Richard Urban" wrote:
> > > > > > > > > |
> > > > > > > > > | > If the pagefile can not grow to what is ultimately required for fast user
> > > > > > > > > | > switching, you may crash the system or cause it to hang. I have found that
> > > > > > > > > | > some users who have altered their pagefile from what was the defaults have
> > > > > > > > > | > had this problem.
> > > > > > > > > | >
> > > > > > > > > | > First things first. Did you try as I suggested with the pagefile? Pagefile
> > > > > > > > > | > fragmentation can always be dealt with later!
> > > > > > > > > | >
> > > > > > > > > | > --
> > > > > > > > > | > Regards,
> > > > > > > > > | >
> > > > > > > > > | > Richard Urban
> > > > > > > > > | >
> > > > > > > > > | > aka Crusty (-: Old B@stard :-)
> > > > > > > > > | >
> > > > > > > > > | > If you knew as much as you think you know,
> > > > > > > > > | > You would realize that you don't know what you thought you knew!
> > > > > > > > > | >
> > > > > > > > > | >
> > > > > > > > > | > "Matt J" <MattJ@discussions.microsoft.com> wrote in message
> > > > > > > > > | > news:816348FF-C9B4-4771-8C0C-76412FB8D1F4@microsoft.com...
> > > > > > > > > | > > What's your thinking in terms of potential solution? Page file is
> > > > > > > > > | > > contiguous
> > > > > > > > > | > > now -- won't resetting chunk it up?
> > > > > > > > > | > >
> > > > > > > > > | > > "Richard Urban" wrote:
> > > > > > > > > | > >
> > > > > > > > > | > >> Set it for "system managed" and try again! (-:
> > > > > > > > > | > >>
> > > > > > > > > | > >> --
> > > > > > > > > | > >> Regards,
> > > > > > > > > | > >>
> > > > > > > > > | > >> Richard Urban
> > > > > > > > > | > >>
> > > > > > > > > | > >> aka Crusty (-: Old B@stard :-)
> > > > > > > > > | > >>
> > > > > > > > > | > >> If you knew as much as you think you know,
> > > > > > > > > | > >> You would realize that you don't know what you thought you knew!
> > > > > > > > > | > >>
> > > > > > > > > | > >>
> > > > > > > > > | > >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > > > > | > >> news:A42BDF35-9BFB-477D-9F25-E463D0C14EEA@microsoft.com...
> > > > > > > > > | > >> > Not recently. Keep it set at a fixed 1000MB.
> > > > > > > > > | > >> >
> > > > > > > > > | > >> > "Richard Urban" wrote:
> > > > > > > > > | > >> >
> > > > > > > > > | > >> >> Have you played with your pagefile settings?
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >> --
> > > > > > > > > | > >> >> Regards,
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >> Richard Urban
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >> aka Crusty (-: Old B@stard :-)
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >> If you knew as much as you think you know,
> > > > > > > > > | > >> >> You would realize that you don't know what you thought you knew!
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >> "Matt J" <Matt J@discussions.microsoft.com> wrote in message
> > > > > > > > > | > >> >> news:36AFFE82-D30D-4975-B119-204A40A32954@microsoft.com...
> > > > > > > > > | > >> >> > Searched newsgroups and KB, but can't find solution to my problem.
> > > > > > > > > | > >> >> >
> > > > > > > > > | > >> >> > Windows XP Home has been "corrupted" and fast user switching no
> > > > > > > > > | > >> >> > longer
> > > > > > > > > | > >> >> > works.
> > > > > > > > > | > >> >> > When I try to switch and go back to the welcome screen -- if I
> > > > > > > > > | > >> >> > select
> > > > > > > > > | > >> >> > second
> > > > > > > > > | > >> >> > user the screen blinks and shows the desktop of the first logged in
> > > > > > > > > | > >> >> > user,
> > > > > > > > > | > >> >> > then blinks back to welcome screen. Only way to switch is to log
> > > > > > > > > | > >> >> > out
> > > > > > > > > | > >> >> > from
> > > > > > > > > | > >> >> > first user then log on just one user at a time.
> > > > > > > > > | > >> >> >
> > > > > > > > > | > >> >> > Terminal services is running, and I've tried unchecking fast user
> > > > > > > > > | > >> >> > switching
> > > > > > > > > | > >> >> > in user profile, restarting, switching back, restarting, etc.
> > > > > > > > > | > >> >> > I'm at my wit's end -- Any help????
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >>
> > > > > > > > > | > >> >>
> > > > > > > > > | > >>
> > > > > > > > > | > >>
> > > > > > > > > | > >>
> > > > > > > > > | >
> > > > > > > > > | >
> > > > > > > > > | >
> > > > > > > > >
> > > > > > >
> > > > > > >
> > > > >
> > > > >
> > >
> > >
>
>
!