Sign in with
Sign up | Sign in
Your question

Assassin's brotherhood does not run smooth enough?

Tags:
  • PC gaming
  • Video Games
Last response: in Video Games
Share
January 26, 2012 8:31:51 PM

hi, I install assassin's brotherhood recently, and it did not run as smooth as I expected, I did update my system just to avoid such problems with the new games, and it did cost me about 1000$ may I add, I recently have: (gigabyte 990fxa-ud3 motherboard, asus NVIDA GeForc GTX 460 video card, 8GigaByte ram, AMD 4-core FX-4100 3.6G 8M R AM3+ CPU, DirectX 11 ), So as you can see it is quite a set? and you can imagin My disappointment, pleaseeeeeeeeeee any help to run the game smoothly. please

More about : assassin brotherhood run smooth

January 26, 2012 9:15:14 PM

Hi :) 

The graphics card is too old and too cheap....

That is why...

All the best Brett :) 

m
0
l
January 26, 2012 9:48:21 PM

The Assassin's Creed games are not very well optimized, so gameplay does get a bit choppy on most systems. A better video card may help, though cards that are significantly better than the GTX 460 are quite expensive, you'd want to look at something in at least the 300USD range for a worthwhile upgrade. Then again, a better GPU might not help at all, as the problem is the game's framerates are quite unstable, making gameplay quite choppy, a better card would get you better maximum framerates, but might not improve the minimum framerates to the point where it would be smooth.

Bottom Line: You're just going to have to tolerate any bad performance for that particular game unless you are willing to spend a lot of money for an upgrade. If your board supports SLI, a second GTX 460 would be a cheaper option, but you would probably need to upgrade your power supply as well if you don't have a good quality 650+ power supply.
m
0
l
Related resources
January 26, 2012 10:38:14 PM

At what resolution are you running the game? Better yet leave anti-aliasing off and run the game at default setting to avoid lag. If you want better performance grab a GTX570 and play at 1080p with ease
m
0
l
January 29, 2012 8:02:50 PM

OK, thnx for the response, but I don't think the video card is the problem, I gave the CD to my brother, and he install the game, and manage to play it (I don't know how with the U-play protection and everything?) with the same settings I am trying on mine, and it run perfectly. His video card is much older and cheaper then mine. one more thing I should I add, for some reason, when I install the game it did not ask me for the CD key, the game runs automatically, I don't know why, wile when he did it he submit the CD key????? may be this is what cause the problem. if any one has any other idea?
m
0
l
January 29, 2012 8:23:24 PM

have you got the latest gpu drivers, the beta ones from nvidia? what resolution, try medium settings and turn AA and Physx off.
m
0
l
January 29, 2012 8:24:50 PM

Brett928S2 said:
Hi :) 

The graphics card is too old and too cheap....

That is why...

All the best Brett :) 


Its a ported game from the xbox 360, which has a much older and cheaper gpu, I don't think your comment is that useful.
m
0
l
January 29, 2012 8:42:09 PM

Update the graphic card and try to run the game in medium or buy a new dvd of it..
m
0
l
January 29, 2012 9:01:32 PM

yasermahone said:
Update the graphic card and try to run the game in medium or buy a new dvd of it..

It runs on another machine, why get a new dvd?

Check temps on gpu and cpu too, it could be that you are running hot, also look at task manager and see what else is running at the same time.
m
0
l
February 7, 2012 6:39:27 PM

Hi there, thank you very much, but I finally got it, there was nothing wrong with video card - I knew that from the beginning - nor it was any other piece of hard wear, you see it was the game launcher. When I install assassin creed 2 I download unofficial game launcher ( and it looks like it was keep the system busy doing some thing in the background), so all I did was, I uninstall all ubisoft games then uninstall the game launcher, then I went to the c-drive and search then delete any left files has to do with ubisoft manually, finally I  reinstall assassin Ceres brotherhood as fresh as I can, and voila, after that I went to the game setting and set every thing to the max, and the game still work as smooth as silk????? 
Again thank you for your time and efforts, and till the next problem, hope you all well.
m
0
l
February 7, 2012 7:19:52 PM

Glad its sorted.
m
0
l
March 23, 2012 2:45:14 AM

the dvd may have enough scratches on it that an older or heavily used dvd drive may have problems reading it. try pcmark05 or 06 on both systems and see which one is better and why.. Also close background apps, GAMEBOOSTER is free and it disables unnecessary background junk and can turn them back on after gaming without needing to reboot.
m
0
l
!