Sign in with
Sign up | Sign in
Your question
Closed

Crysis and Computer Hardware

Last response: in Video Games
Share
January 28, 2012 4:57:56 PM

So i recently purchased the original Crysis from Steam and love it. I am however a bit disappointed as it seems like my computer should be able to run it flawlessly at max (very high) settings. It doesn't.

there are a number of times when the game stutters (especially when turning the camera or zooming in w/ binoculars or when more than a couple enemies are on screen)

Here is my computer (bought and assembled about 2 months ago):

intel 3.3 ghz 4core processor
radeon hd 6850 with latest drivers
120 gb ssd
600w corsair gpu
8 gb ram
win 7 64 bit

i am using a 720p lcd tv as a monitor via hdmi

seems like it should be able to handle a five year old game right?

i tried installing the Xconfig performance mod and that helped a little
i tried overclocking my card and that didnt seem to do anything.

so i turned off the overclocking and for some reason it runs a little better, but still not at the performance level of gameplay videos i've watched on youtube (and the specs on for those videos are much less powerful than my current build)

i've turned off everything in the Catalyst control center that would override any of the games settings... i've also tried turning off everything in the game menu and control the graphics entirely through the CCC.

still i get little bumps and stutters.
I've also had similar problems with Far Cry 2.

I've been tweaking things for about a month now.
am i crazy? is there a missing switch i need to flip?

:fou:  :cry: 
or is this just the harsh reality of pc gaming i've gotta get used to?
January 28, 2012 4:59:56 PM

I should also not I've turned off all anti-aliasing, anisotropic filtering, and v-sync to no avail
Score
0

Best solution

January 29, 2012 1:37:37 AM

go back to ccc panel 3d game settings and select default.
everything else will be controlled in game...
set the game to max settings then turn down fsaa to x2.
on your system you should expect 30fps minimum in most areas. underground you may have to turn fsaa off to stay above 30fps.

crysis is a demanding game. probably 1 of the most demanding gfx wise.
the real issue is the cpu usage because it only uses 2 cores in real terms it may bottleneck on a cpu that has poor single threaded performance when pared with a high end gfx card ...
there are some real poor optomizations that were back in the day thought to be cutting edge, and these are what cause the problems on bigger machines.

so with crysis, no matter how big your machine you will always have lower performance than you think you should have.

modding will go some way to relieve the issues but then you wont be playing crysis.
Share
Related resources
January 29, 2012 1:59:05 AM

AF has almost no impact on gpu performance these days. Just to set you on the right path there. Never disable it.
Score
0
January 29, 2012 2:17:50 AM

Best answer selected by uninformedpcgamer.
Score
0
January 29, 2012 7:56:28 AM

i guess you haven't played crysis lately... even on the newest cards fsaa will cripple performance... please try it... my 5870 will be lucky to stay over 30 with fsaa on x4 if i turn it off i get a solid 35 fps... so thats what a 12 percent performance hit... you may think thats a small hit but in real terms its the difference between smooth and playable or frustrating and laggy. even a 580 takes a performance hit off crysis it may not be the newest or best game but it still crumples most gfx cards at higher settings.
Score
0
January 29, 2012 12:02:16 PM

This topic has been closed by Mousemonkey
Score
0
January 29, 2012 6:23:17 PM

This topic has been reopen by Mousemonkey
Score
0
January 29, 2012 6:43:38 PM

* my apologies to cas, i misread your last post to which i replied.. you meant anisotropic filers and i misread anti aliasing...

thanx to mousemonkey for allowing me to edit this topic...
Score
0
January 29, 2012 7:06:38 PM

This topic has been closed by Mousemonkey
Score
0
!