Sign in with
Sign up | Sign in
Your question

Skyrim FRAPS FPS

Last response: in Video Games
Share
January 31, 2012 12:59:10 PM

Hi,

I know this is not really a hardware question, but is it possible FRAPS is totally wrong about the FPS. I have i72600k@4.5 Ghz and HD6970 crossfire.
I have Skyrim on ultra and some ini-tweaks to improve distance. To me it seems as if the game runs very smooth. Gpu-load is about 56% each card in the heaviest areas. CPU-load isn't about 50-60% in heaviest areas. RAM-usage is about 3.6GB but this can't be the problem either since I have 8GB.

Still FRAPS says that my FPS are not higher then 25, with drops to 15. I have the same problem in Oblivion. It seems as if FRAPS is only counting the frames rendered by 1 card.

So is it possible FRAPS is very wrong about FPS, and if this is true, then how do I check my real FPS?

Thx

More about : skyrim fraps fps

January 31, 2012 1:48:28 PM

I take it your taking about the none-recording part of fraps? (since that has a fixed framerate) does skyrim have its own FPS counter in it? maybe try out a different program and see if it yields a different result (then you know its fraps messing up)
January 31, 2012 2:11:22 PM

Skyrim has no console command for FPS. Indeed none-recording. Gonna try another program.
Related resources
January 31, 2012 2:14:10 PM

semperfidelis said:
Hi,

I know this is not really a hardware question, but is it possible FRAPS is totally wrong about the FPS. I have i72600k@4.5 Ghz and HD6970 crossfire.
I have Skyrim on ultra and some ini-tweaks to improve distance. To me it seems as if the game runs very smooth. Gpu-load is about 56% each card in the heaviest areas. CPU-load isn't about 50-60% in heaviest areas. RAM-usage is about 3.6GB but this can't be the problem either since I have 8GB.

Still FRAPS says that my FPS are not higher then 25, with drops to 15. I have the same problem in Oblivion. It seems as if FRAPS is only counting the frames rendered by 1 card.

So is it possible FRAPS is very wrong about FPS, and if this is true, then how do I check my real FPS?

Thx


Hm... that is strange, you can try using MSI Afterburner and enable ingame fps to check out.
January 31, 2012 3:36:54 PM

Tried using MSI Afterburner, ODS doesn't seem to work in Skyrim. So I can't check FPS. Any other programs?
January 31, 2012 3:52:56 PM

semperfidelis said:
Tried using MSI Afterburner, ODS doesn't seem to work in Skyrim. So I can't check FPS. Any other programs?



Are using FXAA Injection on skyrim?

found it in another forum:

"To allow OSD to work in conjunction with directx overriders such as FXAA, create a profile for the game then go to C:\Program Files (x86)\MSI Afterburner\Bundle\OSDServer\Profiles and modify the cfg file. In the [hooking] section, add EnableDynamicOffsetDetection=1 , save the file and restart Afterburner."

you can try that.
January 31, 2012 4:18:13 PM

ricardois said:
Are using FXAA Injection on skyrim?

found it in another forum:

"To allow OSD to work in conjunction with directx overriders such as FXAA, create a profile for the game then go to C:\Program Files (x86)\MSI Afterburner\Bundle\OSDServer\Profiles and modify the cfg file. In the [hooking] section, add EnableDynamicOffsetDetection=1 , save the file and restart Afterburner."

you can try that.



Tried it, no effect. Probably cause I'm using quite a lot of mods... Any other programs?
January 31, 2012 4:50:35 PM

semperfidelis said:
Tried it, no effect. Probably cause I'm using quite a lot of mods... Any other programs?


maybe some mods are causing wrong fraps problems? try without mods.
February 1, 2012 10:27:55 AM

ricardois said:
maybe some mods are causing wrong fraps problems? try without mods.



Perhaps it has something to do with skse. I'll just leave it with that and stop using fraps :) . When I record with FRAPS I do get a solid 60 FPS and everything remains smooth. So it is very strange
February 2, 2012 11:49:54 AM

The only other thing i can think of is in Skyrim's ini files. It could be that you have the following setting set to 2 for some reason (which doubles your Vsync) Here's a copy/paste from Nvidia's tweak guide:

iPresentInterval=0 - A form of Vertical Synchronization (VSync) is enabled by default in Skyrim and cannot be disabled in the in-game settings. If this variable is added to the bottom of the [Display] section of Skyrim.ini and set to 0, it will forcibly disable VSync. Disabling VSync reduces/eliminates mouse lag and removes the cap on your FPS, and can also improve overall performance. However disabling VSync also has several potentially negative impacts: you may see screen "tearing" which is harmless but may be annoying; in areas where you get very high framerates, such as indoors, the vertical (up/down) axis of your mouse will become much more sensitive than the horizontal axis; game world physics and timing may also accelerate or glitch, especially in areas where you get high FPS.

!