Sign in with
Sign up | Sign in
Your question

Help! Power Down?

Tags:
  • Power Supplies
  • Power
  • Cable
  • Components
Last response: in Components
Share
March 14, 2005 1:14:35 AM

OK. I tried to recable my power cables in my case. Then I tried to turn the power on but did not get the green light on my motherboard like I usually do. I am starting to panic! Do you think my motherboard got short circuit somehow? (Yes! I did unplug my powercord when working on my power cables). My powersupply is 520W so there should be enough power since it was working like a baby pior to getting to my cable fixing.
Too much money invested for this to happen to me now.:<


HW Specs
Asus A8N-SLI DX
AMD-64 FX-53
1 Gig DR400(Dual)
Asus Star Ice (CPU Cooler)
OCZ PowerStream 520PSU
2 Nvidia 6800GT SLI
Lian Li PC-V2000B MOD w blowhole

More about : power

March 15, 2005 11:11:44 PM

Problem solved! The issue was the way the rid is designed, the 5 1/2inch FAN on top hits too close to where the pw,pw hdd connectors go on the motherboard. When reinserting the FAN, I bumped these connectors off their pins without knowing it. LIVE and Learn.
What I have learned today: To carefully install FANS that come close to connectors on the motherboard. Also, not to try to connect too many things together at once before testing. It is always good to go slow and boot test your way up to an awsome kick-ass rig! :D 


HW Specs
Asus A8N-SLI DX
AMD-64 FX-53
1 Gig DR400(Dual)
Asus Star Ice (CPU Cooler)
OCZ PowerStream 520PSU
2 Nvidia 6800GT SLI
Lian Li PC-V2000B MOD w blowhole
!