Sign in with
Sign up | Sign in
Your question

Capped FPS at 30 in multiple games

Last response: in Video Games
Share
February 15, 2012 5:41:40 AM

Hey guys,

I'm having some FPS issues with my laptop. It's Asus N61JQ and I'm pretty noob at this sort of stuff.

-RAM 4 GB (says physical is 3.93 and Availabe Physical 1.05)
-CPU i7 Q740 1.73GH, 4 core(s)
-Windows 7 64-bit
-Graphics ATI 5730 1GB

The games that seem to cap at 30 are Kingdoms of Amalur and Skyrim. Both seem like demanding games but it just won't go passed 30, even staring at a wall. I just updated all my drivers and installed "Catalyst Control" for ATI cards.

I have the games at 1780 x 1000 resolution and everything on medium to low, nothing on High. Although when I put everything on High and on a higher resolution, it still caps at 30. Always fluctuating between 22-30.

Anyone know if I somehow capped my computer to do this? Is it always like this? Why is it doing this -_-?

Thanks for the help
February 15, 2012 6:33:20 AM

Also, here's a dumb question, when I go into my system information, am I supposed to see my graphics card in there too?
m
0
l
February 15, 2012 8:45:25 AM

Make sure that your monitor's refresh rate is set to 60, or conversely disable Vsync. Also some games (Alice: Madness Returns) were actually written with an fps-limiter that is by default set to 30, although Skyrim is not one of these games. If you're consistently at 30 fps while staring at a wall, I would guess somehow your monitor's refresh rate is set to that. If it's spiking a lot, your comp just isn't fast enough (your gpu specifically looking at it).
m
0
l
February 15, 2012 9:15:29 AM

It seems that you might have enabled Vsync.
Vsync or Vertical sync, caps the amount of frames with respect to your monitor's refresh rate.

If you haven't enabled it in these games, there's a chance that it might be enabled through CCC. Force off Vysnc form CCC.
m
0
l
!