Sign in with
Sign up | Sign in
Your question

The Elder Scrolls V: Skyrim will not go fullscreen

Last response: in Video Games
Share
February 15, 2012 6:21:50 AM

Hello,

I bought Skyrim off of Steam and I've been having the same problem as the OP. I tried changing the bFull Screen=1, and manually set the resolution but to no avail. Every time I start the launcher I uncheck 'windowed' mode (even though it automatically rechecks it each time I restart the launcher) and set the resolution to 1280 x 1024 (also resets itself to default every time game is closed). I have tried launching off Steam and off the TESV.exe file but it makes no difference.

I did a quick google search and I noticed that other people were having the same problem, but it was either: a) for a cracked version or b) fixed with a manual change to the 'bFull Screen=1' line in the skyrimprefs.ini file

I'm using:
Windows 7 64-bit
Latest version of steam/DirectX
AMD Radeon HD6800 Series

In the meantime, does anyone have any suggestions?

Thank you.

More about : elder scrolls skyrim fullscreen

February 15, 2012 9:19:44 AM

Make the the config/ini file *read only*, so that it doesn't over write itself.

m
0
l
February 15, 2012 10:26:56 AM

start the game in windowed mode, as soon as you are in press ALT + Enter, then it switches to fullscreen
m
0
l
Related resources
February 15, 2012 1:19:08 PM

I changed the skyrimprefs.ini file, which according to the file description is the config file, read-only but its still opening up in a tiny window in the corner. I tried starting it from the launcher as well as the TESV.exe file but same deal.

Thank you, but ALT+Enter did not work for me.
m
0
l
February 15, 2012 3:01:14 PM

Did you uncheck 'read only' in properties, before making changes to the file itself?
m
0
l
February 15, 2012 4:13:05 PM

I made the changes to the file and saved it prior to clicking 'read only'.
The config file (SkyrimPrefs.ini) contents have the following saved configuration:

bFull Screen=1
iSize H=1024
iSize W=1280

But when I start the game it opens in a tiny window. After I close the game and open SkyrimPrefs.ini it is still correctly configured.

The launcher for Skyrim allows me to uncheck 'windowed mode' but when I close the window for the 'options' menu (thus taking me back to main menu of the launcher) and then reopen 'options' it is set back to the default 'windowed mode' and the default resolution.
m
0
l
February 15, 2012 4:37:37 PM

Win 7's read only stuff is funky and doesn't exactly show the truth of it's state.

Have you tried running it in admin mode?
m
0
l
February 15, 2012 7:12:25 PM

what is your windows desktop resolution?
m
0
l
February 16, 2012 1:21:50 AM

so if your resolution is 1920x1080, why are you trying to full screen it at 1280x1024?

one thing that comes to mind, you have wide screen selected in options and then you try to set it to 4:3 resolution, which is not widescreen.

if your card is something like 6850 or 6870 you should be able to run the game at your desktop resolution, there should be no need to turn it down so much
m
0
l
February 16, 2012 2:03:18 AM

I've tried assorted resolutions but regardless of what I set it to (including my monitors native resolution of 1920x1080) Skyrim always opens in a window of the same size.

I noticed that it the preferences I select in the 'options' menu of the launcher do not get saved so I am unable to change any of the display settings from the default 'windowed mode'
m
0
l
February 16, 2012 12:19:50 PM

hmm, it seems to me that either you got antivirus or security prog that is causing launcher to malfunction or you're not set as admin on your account
m
0
l
February 26, 2012 6:39:11 AM

I tried disabling background programs but it also didnt work.

I did manage to find a solution and it involved downloading a new SkyrimPrefs.ini file and replacing the one that already existed in C:\Users\Administrator\AppData\Local\Skyrim\My Games\Skyrim

*Note: Do not replace the SkyrimPrefs.ini file in the common folder under program files [can use windows search to locate this if it doesnt show up]

The following site has the replacement SkryimPrefs.ini and instructions:
http://www.guide4games.com/index.php/fixes/885-the-elde...

I hope this helps :) 

Thank you all for your assistance!
m
0
l
June 9, 2012 5:12:30 PM

Hey, I was having the same problem, but i could solve it!
I am using Windows 8 RP, but it will be the same.
In the same box where you can choose run as administrator, there is an option like this "Deactivate ... from DPI Resolution", check that option and the game will work fine!
m
0
l
!