Sign in with
Sign up | Sign in
Your question

What SERVICEs does DISK DEFRAG need to operate properly?

Last response: in Windows XP
Share
Anonymous
July 20, 2005 12:23:02 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

I seem to have disabled something by accident and can no longer defrag my
drive(s). What services are specific to Defrag working properly?

Thanks!
July 21, 2005 12:46:13 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Go to Start/All Programs/Administrative Tools/Services and check down the
list for RPC - Remote Procedure Call, set to Automatic and Started
(Defragmenter should also be set similarly.)

--
Peter
Toronto, Canada
XP Home SP2
P4 HT @ 3ghz, 1gb RAM, 360gb HD
"btbk" <btbk@discussions.microsoft.com> wrote in message
news:9ABCD471-6A23-4F79-AB12-E6352A619D59@microsoft.com...
>I seem to have disabled something by accident and can no longer defrag my
> drive(s). What services are specific to Defrag working properly?
>
> Thanks!
Anonymous
July 21, 2005 1:55:02 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

I'd considered that and checked. RPC has never been touched. Also, I don't
see a Defragmenter service anywhere. Is there another related to it? (As in
my original question)

It's strange, because Defrag loads, and I can click on the "Analyze" and
"Defragment" buttons, but they do nothing. ??


"Peter" wrote:

> Go to Start/All Programs/Administrative Tools/Services and check down the
> list for RPC - Remote Procedure Call, set to Automatic and Started
> (Defragmenter should also be set similarly.)
>
> --
> Peter
> Toronto, Canada
> XP Home SP2
> P4 HT @ 3ghz, 1gb RAM, 360gb HD
> "btbk" <btbk@discussions.microsoft.com> wrote in message
> news:9ABCD471-6A23-4F79-AB12-E6352A619D59@microsoft.com...
> >I seem to have disabled something by accident and can no longer defrag my
> > drive(s). What services are specific to Defrag working properly?
> >
> > Thanks!
>
>
>
Related resources
Anonymous
July 21, 2005 5:37:56 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

Visit http://www.kellys-korner-xp.co­m/xp_tweaks.htm
and scroll down to Item No. 280 "Restore Defrag.exe".

[Courtesy of Kelly Theriot, MS-MVP]


"btbk" <btbk@discussions.microsoft.com> wrote in message
news:9ABCD471-6A23-4F79-AB12-E6352A619D59@microsoft.com...
>I seem to have disabled something by accident and can no longer defrag my
> drive(s). What services are specific to Defrag working properly?
>
> Thanks!
Anonymous
July 21, 2005 5:37:57 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

That doesn't help. It would be a DLL that's been deleted. I tried to run
PerfectDisk and it doesn't work either:

Failed to connect to computer XX. The RPC server is unavailable.

Very strange...

"Touchbase" wrote:

> Visit http://www.kellys-korner-xp.co­m/xp_tweaks.htm
> and scroll down to Item No. 280 "Restore Defrag.exe".
>
> [Courtesy of Kelly Theriot, MS-MVP]
>
>
> "btbk" <btbk@discussions.microsoft.com> wrote in message
> news:9ABCD471-6A23-4F79-AB12-E6352A619D59@microsoft.com...
> >I seem to have disabled something by accident and can no longer defrag my
> > drive(s). What services are specific to Defrag working properly?
> >
> > Thanks!
>
>
>
July 21, 2005 11:38:07 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

I was gueeing about defrag being in Services. I use Diskeeper 9 Pro and it
shows there.
Maybe it's time for asking SP2 Help & Support
Not sure where you are but this works for me:
http://support.microsoft.com/oas/default.aspx/

--
Peter
Toronto, Canada
XP Home SP2
P4 HT @ 3ghz, 1gb RAM, 360gb HD
"btbk" <btbk@discussions.microsoft.com> wrote in message
news:43E0164A-DE64-4970-BD67-908510D9A3C6@microsoft.com...
> I'd considered that and checked. RPC has never been touched. Also, I don't
> see a Defragmenter service anywhere. Is there another related to it? (As
> in
> my original question)
>
> It's strange, because Defrag loads, and I can click on the "Analyze" and
> "Defragment" buttons, but they do nothing. ??
>
>
> "Peter" wrote:
>
>> Go to Start/All Programs/Administrative Tools/Services and check down the
>> list for RPC - Remote Procedure Call, set to Automatic and Started
>> (Defragmenter should also be set similarly.)
>>
>> --
>> Peter
>> Toronto, Canada
>> XP Home SP2
>> P4 HT @ 3ghz, 1gb RAM, 360gb HD
>> "btbk" <btbk@discussions.microsoft.com> wrote in message
>> news:9ABCD471-6A23-4F79-AB12-E6352A619D59@microsoft.com...
>> >I seem to have disabled something by accident and can no longer defrag
>> >my
>> > drive(s). What services are specific to Defrag working properly?
>> >
>> > Thanks!
>>
>>
>>
July 21, 2005 11:58:30 AM

Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

...GUESSING...sorry

--
Peter
Toronto, Canada
XP Home SP2
P4 HT @ 3ghz, 1gb RAM, 360gb HD
"Peter" <ex-brit AT rogers DOT com> wrote in message
news:uvNFriejFHA.1044@tk2msftngp13.phx.gbl...
>I was gueeing about defrag being in Services. I use Diskeeper 9 Pro and it
>shows there.
> Maybe it's time for asking SP2 Help & Support
> Not sure where you are but this works for me:
> http://support.microsoft.com/oas/default.aspx/
>
> --
> Peter
> Toronto, Canada
> XP Home SP2
> P4 HT @ 3ghz, 1gb RAM, 360gb HD
> "btbk" <btbk@discussions.microsoft.com> wrote in message
> news:43E0164A-DE64-4970-BD67-908510D9A3C6@microsoft.com...
>> I'd considered that and checked. RPC has never been touched. Also, I
>> don't
>> see a Defragmenter service anywhere. Is there another related to it? (As
>> in
>> my original question)
>>
>> It's strange, because Defrag loads, and I can click on the "Analyze" and
>> "Defragment" buttons, but they do nothing. ??
>>
>>
>> "Peter" wrote:
>>
>>> Go to Start/All Programs/Administrative Tools/Services and check down
>>> the
>>> list for RPC - Remote Procedure Call, set to Automatic and Started
>>> (Defragmenter should also be set similarly.)
>>>
>>> --
>>> Peter
>>> Toronto, Canada
>>> XP Home SP2
>>> P4 HT @ 3ghz, 1gb RAM, 360gb HD
>>> "btbk" <btbk@discussions.microsoft.com> wrote in message
>>> news:9ABCD471-6A23-4F79-AB12-E6352A619D59@microsoft.com...
>>> >I seem to have disabled something by accident and can no longer defrag
>>> >my
>>> > drive(s). What services are specific to Defrag working properly?
>>> >
>>> > Thanks!
>>>
>>>
>>>
>
>
February 24, 2013 6:45:52 AM

Quote:
Archived from groups: microsoft.public.windowsxp.perform_maintain (More info?)

I seem to have disabled something by accident and can no longer defrag my
drive(s). What services are specific to Defrag working properly?

Thanks!




did you disable or uninstall the .net framework ?
!